User avatar
rin67630
Posts: 376
Joined: Fri Mar 04, 2016 10:15 am

Swapping the SD card between a Raspi 3a+ and a Zero

Tue Jul 09, 2019 8:35 pm

I use to swap or clone the the SD card (with Raspbian Stretch) between a Raspi 3a+ (my developing machine and reference) and my Raspi 3 ZeroesW (the working horses in the measuring stations).
It seems to work fine, but have I got a hidden drawback, some difference in the code, that would make my Zeroes run suboptimally when using a cloned SD-Card from a 3a+?

User avatar
rpdom
Posts: 14705
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Swapping the SD card between a Raspi 3a+ and a 3Zero

Tue Jul 09, 2019 8:57 pm

The Zero range is much slower than the Pi 3 range and only has a single CPU core instead of four.

User avatar
rin67630
Posts: 376
Joined: Fri Mar 04, 2016 10:15 am

Re: Swapping the SD card between a Raspi 3a+ and a 3Zero

Wed Jul 10, 2019 8:23 am

rpdom wrote:
Tue Jul 09, 2019 8:57 pm
The Zero range is much slower than the Pi 3 range and only has a single CPU core instead of four.
Ok, but does that answer the question?
I don't mind speed, my Zeroes run at 3% CPU.

User avatar
rpdom
Posts: 14705
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Swapping the SD card between a Raspi 3a+ and a 3Zero

Wed Jul 10, 2019 9:51 am

Perhaps you can clarify what the actual issue was?

By saying it was "suboptimal" you appeared to be saying that the Zeroes ran slower - which they do.

User avatar
rin67630
Posts: 376
Joined: Fri Mar 04, 2016 10:15 am

Re: Swapping the SD card between a Raspi 3a+ and a 3Zero

Wed Jul 10, 2019 10:44 am

I did not mean speed, but reliability. My Zeroes appear to get apparent hardware problems (HDMI port, CPU running hot without load, not booting any more). I am just wondering...

User avatar
rpdom
Posts: 14705
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Swapping the SD card between a Raspi 3a+ and a 3Zero

Wed Jul 10, 2019 10:54 am

Ah, ok. I haven't had any problems with my Zeroes, apart from the first one which died I assume because I somehow short circuited it.

Here's one example of one of mine

Code: Select all

pi@raspi9:~ $ uptime
 11:50:47 up 370 days,  5:47,  1 user,  load average: 0.32, 0.34, 0.30
pi@raspi9:~ $ cat /sys/firmware/devicetree/base/model ;echo
Raspberry Pi Zero Rev 1.3
pi@raspi9:~ $ vcgencmd measure_temp
temp=33.6'C
That one has been running uncased on a bare tiled floor and driving a WS2812 LED strip. It is covered in dust and the area does get damp.

Obviously it is not running Buster yet, but is on my list for upgrading.

I'm not using the HDMI out on that Pi, but I have run a Zero W for a few months with HDMI driving a 1080P monitor that was showing a status page updating every few minutes.

User avatar
RaTTuS
Posts: 10373
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Swapping the SD card between a Raspi 3a+ and a 3Zero

Wed Jul 10, 2019 11:14 am

rin67630 wrote:
Wed Jul 10, 2019 10:44 am
I did not mean speed, but reliability. My Zeroes appear to get apparent hardware problems (HDMI port, CPU running hot without load, not booting any more). I am just wondering...
what have you got connected to the PI0's - and how - show all circuits ,
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

Return to “Troubleshooting”