CZMG
Posts: 1
Joined: Sun Jun 16, 2019 8:26 pm

APT completely broken

Sun Jun 16, 2019 8:35 pm

Every time I run an APT command (install, update, upgrade, etc.) I get this error message.

Code: Select all

Setting up ssl-cert (1.0.39) ...
Could not create certificate. Openssl output was:
openssl: /usr/lib/arm-linux-gnueabihf/libssl.so.1.1: version `OPENSSL_1_1_1' not found (required by openssl)
openssl: /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.1: version `OPENSSL_1_1_1' not found (required by openssl)
dpkg: error processing package ssl-cert (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 ssl-cert
E: Sub-process /usr/bin/dpkg returned an error code (1)
and

Code: Select all

 dpkg --configure ssl-cert
returns the same error.

Return to “Troubleshooting”