totemspirithousecat
Posts: 1
Joined: Tue Feb 12, 2019 6:31 am

Pi Zero W Does not connect to Wifi

Tue Feb 12, 2019 6:45 am

I have a Pi Zero W that I want to set up as a headless unit. I do not have a way to plug in a keyboard, so need to connect to Wifi and use SSH. I have done this before on a Zero W and just did it again using a Pi3+.

I started this quest by flashing Raspian Stretch Lite and saving wpa_supplicant.conf and ssh to the boot directory.

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
     ssid="networkID"
     psk="password"
     key_mgmt=WPA-PSK
}
I have double and triple checked the network ID and password are correct. Didn't work. Tried setting it up with NOOBS, but that doesn't work well without a keyboard. Raspian Stretch didn't work either.

I flashed a clean copy of Stretch to my Pi3+, plugged in a keyboard and mouse, and connected to Wifi through the GUI. It worked great! Then, I took the SD card and placed it in my Pi Zero. Booted and watched as it reached the desktop without connecting to Wifi. It never does. This is a brand new Pi (I picked it up locally from Sparkfun today).

When booting Stretch Lite on the Zero, it displays "Starting disable wifi if country not set..." . . . "Started disable wifi if country not set...". I have followed every forum thread and the advice I've found so far has proven no results for me. I am relatively new to Linux and Pi stuff.

Any ideas? Thanks!

Ernst
Posts: 991
Joined: Sat Feb 04, 2017 9:39 am
Location: Germany

Re: Pi Zero W Does not connect to Wifi

Tue Feb 12, 2019 11:40 am

totemspirithousecat wrote:
Tue Feb 12, 2019 6:45 am
I flashed a clean copy of Stretch to my Pi3+, plugged in a keyboard and mouse, and connected to Wifi through the GUI. It worked great! Then, I took the SD card and placed it in my Pi Zero. Booted and watched as it reached the desktop without connecting to Wifi. It never does. This is a brand new Pi (I picked it up locally from Sparkfun today).
There can be two reasons for this problem:
1) You have a 5Ghz WiFi access point, this is something that the Pi0W does not support
2) You have a 2.4Ghz WiFi access point and the Pi0W has a defective WiFi interface.

During the night another thought has come up: could there be a mac filter on the access point ?
Last edited by Ernst on Wed Feb 13, 2019 6:35 am, edited 1 time in total.
The road to insanity is paved with static ip addresses

dominic03
Posts: 67
Joined: Fri Dec 21, 2018 1:50 am

Re: Pi Zero W Does not connect to Wifi

Tue Feb 12, 2019 2:01 pm

Since it seems to not connect at boot, you can enable "Wait for network at boot" in raspi-config or from the config GUI. But make sure you can connect before you do it (like boot it up, when it logs in assuming it has no network plug in your mouse / keyboard and try to connect from the menu). If it connects, enable it and you might get a connection. If you don't get a connection from the menu, do not toggle the wait setting on.

I've never personally used a 0W or the wait for network setting, but maybe it could help you.
Always install things with

Code: Select all

sudo apt-get install app && sudo apt-get clean
My setup:
Raspberry Pi 3b+ Raspbian Stretch, probably the latest version
Kingston 32 GB class 10 (U1) SDHC card
Lexar 16GB flash drive for backups
Official power supply

Return to “Troubleshooting”