gifty74
Posts: 1
Joined: Mon Feb 11, 2019 8:25 pm

Tilt Pi not consistently logging data to Google Sheet

Mon Feb 11, 2019 8:33 pm

Hi all. Recently bought a pretty cool tool called a Tilt that is for monitoring a fermenting liquid (in my case beer). It continually shows temperature and gravity of the wort, and transmits that data to a Rasp Pi 3 (or newer) via bluetooth. The Rasp Pi has to be loaded with a custom version of it called Tilt Pi. It then logs that data, at an interval set on the Logging Settings page, to a Google Sheet. When using an iphone or amazon fire tablet the logging happens right on, never misses a beat. However, when connected to the Rasp Pi 3, it misses many of the logging points. I currently have it set to upload at 15 min intervals. It'll go 3 in a row, then miss 2, then log 1, then miss 1, then log 2..etc, etc. Not sure why it's inconsistent, or how to start troubleshooting. It seems the bluetooth is connected and solid as it shows that it's connected to the Tilt device. I've tested it by moving the two within a few feet of each other, and same result. Seems the logging to the Sheet is the issue. I've tried to take wifi out of the equation by hooking the Rasp Pi directly to my router and using the wired LAN port. Does anyone have any experience with Tilt Pi? Any ideas on where to start troubleshooting?

Return to “Troubleshooting”