0xDECAFBAD
Posts: 1
Joined: Mon Nov 19, 2012 4:21 pm

Overclock Not Working

Mon Nov 19, 2012 4:24 pm

I have arm_freq=1000 and force_turbo=1 in config.txt but when I run /opt/vc/bin/vcgencmd measure_clock arm it still shows 700mhz. Even when I used raspi_config and set it to the automatic turbo overclocking mode and I was opening multiple browser windows at a time, maxing out the cpu, /opt/vc/bin/vcgencmd measure_clock arm still showed 700mhz. This is a brand new 512mb Pi with Raspbian that I set up yesterday. Anyone know whats going on?

ChadP
Posts: 57
Joined: Sat Jul 07, 2012 2:30 pm
Location: West Virginia. United States
Contact: Yahoo Messenger

Re: Overclock Not Working

Fri Nov 23, 2012 1:21 pm

Im having the same problem. I used raspi config to set mine to turbo but when i check it it shows 695. When i check the config file all the overclock settings are in the config file like they should be.

User avatar
RaTTuS
Posts: 10462
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Overclock Not Working

Fri Nov 23, 2012 1:29 pm

put the system under load then check
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

dknute
Posts: 57
Joined: Thu Nov 08, 2012 9:05 pm

Re: Overclock Not Working

Fri Nov 23, 2012 1:53 pm

This is a Raspbian issue I think. It's supposed to be using "ondemand" power governor but instead sticks to "powersave". Maybe it's enabled if you select the overclock option in the config menu but I never did that, I wanted to try out my own settings so I just added new entries to config.txt.

Anyway, try adding this line to /etc/rc.local, at the end is good but before "exit 0":

Code: Select all

echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
With this and enough system load you should see the clock rise. To see your current setup just run cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor.

Dilligaf
Posts: 283
Joined: Wed May 23, 2012 6:48 pm

Re: Overclock Not Working

Fri Nov 23, 2012 2:07 pm

In the original post he states force_turbo=1 this should disable dynamic overclock and run at 1000 all the time, governor should have no effect. Is this not the case, or am I mistaken?

dknute
Posts: 57
Joined: Thu Nov 08, 2012 9:05 pm

Re: Overclock Not Working

Fri Nov 23, 2012 3:29 pm

Uh, truth be told I'm not quite sure how force_turbo=1 works exactly. I was under the impression that clocks are still at default settings during boot and only after that forced to config values. If that's the case then maybe some other setting prevents that?

However, 0xDECAFBAD also had problems with the dynamic overclocking and that is exactly what I experienced - so I suggested a solution that worked for me. Sorry if I caused a confusion.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5331
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Overclock Not Working

Fri Nov 23, 2012 4:27 pm

0xDECAFBAD wrote:I have arm_freq=1000 and force_turbo=1 in config.txt but when I run /opt/vc/bin/vcgencmd measure_clock arm it still shows 700mhz. Even when I used raspi_config and set it to the automatic turbo overclocking mode and I was opening multiple browser windows at a time, maxing out the cpu, /opt/vc/bin/vcgencmd measure_clock arm still showed 700mhz. This is a brand new 512mb Pi with Raspbian that I set up yesterday. Anyone know whats going on?
What does

Code: Select all

vcgencmd get_cconfig int
and

Code: Select all

dmesg |grep cpu | grep max
return?

Return to “Troubleshooting”