Snakuzzo
Posts: 1
Joined: Sat Jan 19, 2019 7:19 pm

RPi 3 B Model internet speed slow behind gigabit switch

Sat Jan 19, 2019 7:31 pm

Hello everyone.
I have a Rpi 3 B model behind a gigabit switch.
My internet connection has a stable 200Mbit download speed.

Behind the switch the speed is limited to 2MB/s

Code: Select all

pi@snakeberry:~ $ wget http://debian.fastweb.it/debian-cd/current/i386/iso-cd/debian-9.6.0-i386-netinst.iso
--2019-01-19 20:23:37--  http://debian.fastweb.it/debian-cd/current/i386/iso-cd/debian-9.6.0-i386-netinst.iso
Resolving debian.fastweb.it (debian.fastweb.it)... 213.156.32.111
Connecting to debian.fastweb.it (debian.fastweb.it)|213.156.32.111|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 396361728 (378M) [application/octet-stream]
Saving to: ‘debian-9.6.0-i386-netinst.iso.7’

debian-9.6.0-i386-netinst.iso.7   2%[>                                                    ]  10.99M  2.15MB/s    eta 2m 58s 
Without the switch is ok... 10MB/s

Code: Select all

wget http://debian.fastweb.it/debian-cd/current/i386/iso-cd/debian-9.6.0-i386-netinst.iso
--2019-01-19 19:17:52--  http://debian.fastweb.it/debian-cd/current/i386/iso-cd/debian-9.6.0-i386-netinst.iso
Resolving debian.fastweb.it (debian.fastweb.it)... 213.156.32.111
Connecting to debian.fastweb.it (debian.fastweb.it)|213.156.32.111|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 396361728 (378M) [application/octet-stream]
Saving to: ‘debian-9.6.0-i386-netinst.iso’

debian-9.6.0-i386-netinst.iso     8%[===>                                                 ]  32.07M  9.97MB/s    eta 35s    ^


I thought the problem was the switch...but...another strange thing...
If I run a speedtest with speedtest-cli behind the switch I have the same result when RPi is directly connected to the modem

Code: Select all

pi@snakeberry:~/speedtest-cli $ ./speedtest.py 
Retrieving speedtest.net configuration...
Testing from Telecom Italia (xxx.xxx.xxx.xxx)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by Telecom Italia S.p.A. (Rome) [1.30 km]: 20.552 ms
Testing download speed................................................................................
Download: 91.25 Mbit/s
Testing upload speed................................................................................................
Upload: 20.12 Mbit/s
Any suggestion ?

Thank you

fruitoftheloom
Posts: 18531
Joined: Tue Mar 25, 2014 12:40 pm

Re: RPi 3 B Model internet speed slow behind gigabit switch

Sat Jan 19, 2019 7:53 pm

Snakuzzo wrote:
Sat Jan 19, 2019 7:31 pm
Hello everyone.
I have a Rpi 3 B model behind a gigabit switch.
My internet connection has a stable 200Mbit download speed.

Behind the switch the speed is limited to 2MB/s

Code: Select all

pi@snakeberry:~ $ wget http://debian.fastweb.it/debian-cd/current/i386/iso-cd/debian-9.6.0-i386-netinst.iso
--2019-01-19 20:23:37--  http://debian.fastweb.it/debian-cd/current/i386/iso-cd/debian-9.6.0-i386-netinst.iso
Resolving debian.fastweb.it (debian.fastweb.it)... 213.156.32.111
Connecting to debian.fastweb.it (debian.fastweb.it)|213.156.32.111|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 396361728 (378M) [application/octet-stream]
Saving to: ‘debian-9.6.0-i386-netinst.iso.7’

debian-9.6.0-i386-netinst.iso.7   2%[>                                                    ]  10.99M  2.15MB/s    eta 2m 58s 
Without the switch is ok... 10MB/s

Code: Select all

wget http://debian.fastweb.it/debian-cd/current/i386/iso-cd/debian-9.6.0-i386-netinst.iso
--2019-01-19 19:17:52--  http://debian.fastweb.it/debian-cd/current/i386/iso-cd/debian-9.6.0-i386-netinst.iso
Resolving debian.fastweb.it (debian.fastweb.it)... 213.156.32.111
Connecting to debian.fastweb.it (debian.fastweb.it)|213.156.32.111|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 396361728 (378M) [application/octet-stream]
Saving to: ‘debian-9.6.0-i386-netinst.iso’

debian-9.6.0-i386-netinst.iso     8%[===>                                                 ]  32.07M  9.97MB/s    eta 35s    ^


I thought the problem was the switch...but...another strange thing...
If I run a speedtest with speedtest-cli behind the switch I have the same result when RPi is directly connected to the modem

Code: Select all

pi@snakeberry:~/speedtest-cli $ ./speedtest.py 
Retrieving speedtest.net configuration...
Testing from Telecom Italia (xxx.xxx.xxx.xxx)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by Telecom Italia S.p.A. (Rome) [1.30 km]: 20.552 ms
Testing download speed................................................................................
Download: 91.25 Mbit/s
Testing upload speed................................................................................................
Upload: 20.12 Mbit/s
Any suggestion ?

Thank you

https://github.com/esnet/iperf

https://linux.die.net/man/1/iperf
adieu

My other Computer is an Asus CS10 ChromeBit

Return to “Troubleshooting”