jultur
Posts: 2
Joined: Sun Jan 13, 2019 2:14 pm

Raspbian stuck on screen with cursor+black screen+yellow lightning during boot

Sun Jan 13, 2019 2:45 pm

Hi,

I have an issue with my raspberry pi 3 B+ running on Raspbian. Indeed just after trying to set up a 4 inch HDMI LCD screen in the following way :

-Adding these lines in the config.txt
Hdmi_group = 2
Hdmi_mode = 87
Hdmi_cvt 480 800 60 6 0 0 0
Dtoverlay = ads7846 , cs = 1 , penirq = 25 , penirq_pull = 2 , speed = 50000 , keep_vref_on = 0 , swapxy = 0 , pmax = 255 , xohms = 150 , xmin = 200 , xmax = 3900 , ymin = 200 , ymax = 3900
Display_rotate = 3

-git clone https : //github.com/waveshare/LCD-show.git

-and running the file LCD4 - 800x480 - show

At this point the board reboot and since then my problems started :

The boot start correctly until the last line on screen :

Code: Select all

Starting Terminate Plymouth Boot Screnn...
Image

After that I'm stuck with that screen :

Image

And the red and green LEDs are blinking.

It's a problem really simillar to this one :

viewtopic.php?t=128307
But no answers are working for me.

Personnaly I think it's a problem with the memory during the installation of the LCD driver but I have no idea how to solve it. I really need to get it working without wiping all the memory, beacause I have really important files for a project inside.

Thank you for the help!

fruitoftheloom
Posts: 19767
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Raspbian stuck on screen with cursor+black screen+yellow lightning during boot

Sun Jan 13, 2019 4:25 pm

jultur wrote:
Sun Jan 13, 2019 2:45 pm
Hi,

I have an issue with my raspberry pi 3 B+ running on Raspbian. Indeed just after trying to set up a 4 inch HDMI LCD screen in the following way :

-Adding these lines in the config.txt
Hdmi_group = 2
Hdmi_mode = 87
Hdmi_cvt 480 800 60 6 0 0 0
Dtoverlay = ads7846 , cs = 1 , penirq = 25 , penirq_pull = 2 , speed = 50000 , keep_vref_on = 0 , swapxy = 0 , pmax = 255 , xohms = 150 , xmin = 200 , xmax = 3900 , ymin = 200 , ymax = 3900
Display_rotate = 3

-git clone https : //github.com/waveshare/LCD-show.git

-and running the file LCD4 - 800x480 - show

At this point the board reboot and since then my problems started :

The boot start correctly until the last line on screen :

Code: Select all

Starting Terminate Plymouth Boot Screnn...
Image

After that I'm stuck with that screen :

Image

And the red and green LEDs are blinking.

It's a problem really simillar to this one :

viewtopic.php?t=128307
But no answers are working for me.

Personnaly I think it's a problem with the memory during the installation of the LCD driver but I have no idea how to solve it. I really need to get it working without wiping all the memory, beacause I have really important files for a project inside.

Thank you for the help!

The Yellow Warning is under-voltage:

https://www.raspberrypi.org/documentati ... g-icons.md

Use the Official and recommended Power Supply:

https://www.raspberrypi.org/products/ra ... er-supply/


The Waveshare instructions support Raspbian Stretch ?? if it is a genuine Waveshare product then what model ??

https://www.waveshare.com/product/mini- ... splays.htm
adieu

My other Computer is an Asus CS10 ChromeBit running Chrome Operating System.
HP Envy 4500 Wireless Printer supported by HPLIP software in Raspbian Buster.
Raspberry Pi Model 2B v1.1

jultur
Posts: 2
Joined: Sun Jan 13, 2019 2:14 pm

Re: Raspbian stuck on screen with cursor+black screen+yellow lightning during boot

Sun Jan 13, 2019 6:22 pm

Thanks for the answer !

I have also read that this lightning logo can appear due to boot problems. The board is powered by my PC and I used the same configuration with an other board and it was working, that why i'm not sure if it's a supply problem.

And for the screen I'm using this one :

https://www.waveshare.com/product/mini- ... mi-lcd.htm

User avatar
davidcoton
Posts: 3770
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: Raspbian stuck on screen with cursor+black screen+yellow lightning during boot

Sun Jan 13, 2019 9:40 pm

Your PC's USB may be limited to 500mA. The Pi3B+ can draw over twice that.
Get a proper 5V-5V2 2A5 PSU (not a repurposed charger), preferably the "official" 5V1 2A5 PSU which is known to be of good quality.
Make sure the cable, if separate, is adequate -- at least 22AWG and preferanbly 18AWG wires (smaller number is thicker).
Signature retired

Return to “Troubleshooting”