Page 1 of 1

lxappearance not working

Posted: Fri Jan 11, 2019 9:59 am
by drmullins
After latest update/upgrade this morning lxappearance does not run - I just see the cursor with the hourglass then the hourglass disappaears after some 10's of seconds - HELP !

Re: lxappearance not working

Posted: Fri Jan 11, 2019 12:43 pm
by gkreidl
drmullins wrote:
Fri Jan 11, 2019 9:59 am
After latest update/upgrade this morning lxappearance does not run - I just see the cursor with the hourglass then the hourglass disappaears after some 10's of seconds - HELP !
This is caused by the latest "improvements" of the Raspbian Desktop (segfault). The same was true for obconf, but someone reported today that this has been fixed by a new update.
I fixed it for me by reverting to openbox_3.6.1-4+rpi7_armhf.deb and libobrender32v5_3.6.1-4+rpi7_armhf.deb.

Re: lxappearance not working

Posted: Fri Jan 11, 2019 5:27 pm
by drmullins
Thanks gkreidl - a good work round - but I hope the foundation are going to fix it as this is of course an absolutely core part of LXDE !
One other possibility I suppose is to manually edit /home/pi/.config/lxsession/LXDE-pi/desktop.conf to configure some of the GTK themes but this doesn't fix everything of course and is a distinctly non-preferred approach.
Thanks again.

Re: lxappearance not working (due to obconf plug-in seg fault)

Posted: Sun Jan 13, 2019 5:31 pm
by drmullins
Inspired by Frederk in a separate thread I removed lxappearance-obconf to make lxappearance work. I hope the foundation arrange for lxappearance-obconf plug-in to be fixed (like obconf) so that the integrity of LXDE metapackage is restored !

Re: lxappearance not working

Posted: Mon Jan 21, 2019 8:17 am
by ShiftPlusOne
Simon has just pushed an updated package - it just needed a rebuild against openbox. It should be live within an hour.