lunae0023
Posts: 6
Joined: Sat Dec 29, 2018 1:41 am

Seagate plus hub 8TB error

Sat Dec 29, 2018 1:56 am

Hello,

I just got a Raspberry pi. I have setup plex on it and now I am trying to use my Seagate plus hub 8TB HDD that has all my media on it. When I plug it in I get an error, see attachment. I was using this drive on a Windows computer before trying to move it to the RPi, so I don't know if that has something to do with it. I can't find any solutions to this error. Can someone please help me. Also I am very new to using Linux so I have a step learning curve. Image
Attachments
Capture.PNG
Capture.PNG (138.56 KiB) Viewed 299 times

User avatar
thagrol
Posts: 1777
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK
Contact: Website

Re: Seagate plus hub 8TB error

Sat Dec 29, 2018 12:52 pm

It's probably been formatted with a filesystem that raspbian doesn't understand without additional software.

Plug the drive back into windows, open "This PC", find the drive, right click, then properties. Look for "File system" on the "General" tab and post what it shows for that.

Someone can then probably point you at the right software to install.
This space unintentionally left blank.

fruitoftheloom
Posts: 20431
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Seagate plus hub 8TB error

Sat Dec 29, 2018 1:04 pm

lunae0023 wrote:
Sat Dec 29, 2018 1:56 am
Hello,

I just got a Raspberry pi. I have setup plex on it and now I am trying to use my Seagate plus hub 8TB HDD that has all my media on it. When I plug it in I get an error, see attachment. I was using this drive on a Windows computer before trying to move it to the RPi, so I don't know if that has something to do with it. I can't find any solutions to this error. Can someone please help me. Also I am very new to using Linux so I have a step learning curve. Image

Have you installed the NTFS file system package ? natively Linux can not read the NTFS file system:

Code: Select all

sudo apt update
sudo apt instal ntfs-3g
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

fbe
Posts: 494
Joined: Thu Aug 17, 2017 9:08 pm

Re: Seagate plus hub 8TB error

Sat Dec 29, 2018 1:36 pm

...
or if the drive has an exFAT filesystem:

Code: Select all

sudo apt install exfat-utils
But I see at Amazon, that a NTFS driver is recommended on a Mac, to use it without reformatting...

lunae0023
Posts: 6
Joined: Sat Dec 29, 2018 1:41 am

Re: Seagate plus hub 8TB error

Sat Dec 29, 2018 11:36 pm

Here is the picture form the properties.
properties.PNG
properties.PNG (18.57 KiB) Viewed 220 times

fruitoftheloom
Posts: 20431
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Seagate plus hub 8TB error

Sat Dec 29, 2018 11:46 pm

lunae0023 wrote:
Sat Dec 29, 2018 11:36 pm
Here is the picture form the properties.properties.PNG

Have you an answer for what I asked above ?
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

User avatar
thagrol
Posts: 1777
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK
Contact: Website

Re: Seagate plus hub 8TB error

Sat Dec 29, 2018 11:53 pm

OK. For this to work, you'll need your Pi connected to the internet. And make sure any files you've been working on are saved and closed.

On you Pi, if in the desktop open a terminal.
Run these commands:

Code: Select all

sudo apt update
sudo apt install -y ntfs-3g
sudo reboot
If you're logging in via the text console or ssh just run those commands.

And see if your HDD mounts after the reboot. If it doesn't, my next guess is that the problem is related to MBR disc partitioning vs GPT paritioning. At 8TB the disc is likely to br GPT. Unfortunately I don't know what the fix is as I'd expect raspbian to support GPT.

A reboot isn't strictly necessary, retrying the mount command should be enough but you seem to be using file manager for mounting the HDD and I don't know for certain how that behaves (I'm a command line guy).
This space unintentionally left blank.

lunae0023
Posts: 6
Joined: Sat Dec 29, 2018 1:41 am

Re: Seagate plus hub 8TB error

Sun Dec 30, 2018 1:47 am

Thank you every one for your help. After running the commands
sudo apt update
sudo apt install -y ntfs-3g

My drive came right up. The only issue now is why can't plex see the files. So if any of you know how to make plex see the files that would be awesome.

Return to “Troubleshooting”