Stefan_69
Posts: 3
Joined: Sun Dec 09, 2018 10:32 pm

X-Forwarding over SSH => Pi crashes

Sun Dec 09, 2018 11:04 pm

Hello all,

my new Raspberry Pi 3B+ is driving my nuts: when I use "ssh -X pi@10.1.1.99" from a virtual machine (Debian 9.6) and start
a program with graphics (like xeyes) the Pi simply crashes and needs a reboot (red an green led are on permanently).
Pi is running Rapsbian, updated to latest release.

/var/log/debug shows the following entry right before every single crash: xrdp-sesman[442]: (442)(1995931648)[DEBUG] libscp initialized
/var/log/kernel has no entries related to the crashes

Some other observations:

+ starting xeyes, chromium or other programs with graphics via the desktop (i.e. using mouse and keyboard) is working fine, no crash
+ graphics output over ssh -X only crashes the Pi when done over the 1 GBit network card, when done over WLAN, the Pi keeps running
+ using ssh -XC (= compression) helps with xeyes (sometimes), but running chromium still crashes the Pi consistently
+ reducing the internal network card speed to 100 MBit is not helping, disabling LAN energy saving (eee=off) shows no improvement
+ tried different power supplies (rated 2.4 A and 3.1 A), no difference. Voltage measured at the pin header is ~5.05 V for both power supplies
(no devices are connected to USB ports)
+ increasing the Pi core and memory voltages slightly (set to +2) is not helping
+ Stressing the Pi with stressberry and memtester works fine, no crashes

Any ideas what's going on here?


Thanks and best regards,
Stefan

Stefan_69
Posts: 3
Joined: Sun Dec 09, 2018 10:32 pm

Re: X-Forwarding over SSH => Pi crashes

Tue Dec 11, 2018 6:12 pm

Hello,

did some further investigations on the problem:

+ running OSMC instead of Raspbian does not help, Pi is still crashing
+ basically any "heavy" network traffic, like file copy with scp (form another linux machine) or using Winscp (under Windows), on the onboard LAN is crashing the Pi

Now I'm suspecting that I'm dealing with a defective board, unfortunately after all the experimenting the PCB is not in the original state
anymore, so I cannot return it ;-( Anyhow, WLAN works, so I'll stick to that for now.

Anything else to try?


Thanks and regards,
Stefan

Stefan_69
Posts: 3
Joined: Sun Dec 09, 2018 10:32 pm

Re: X-Forwarding over SSH => Pi crashes

Sat Dec 15, 2018 7:04 pm

Hello all,

short update, bough a new Pi 3B+ today and this one is working fine (using exactly the same power supply and the same SD-Card),
so basically my first Pi is broken ;-(

I'm suspecting a faulty LAN7515 chip (or some support circuitry in its vicinity) as USB ports were also not working correctly for USB memory drives.

Is there a schematic of the 3B+ out there? I'd be curious to do some trouble shooting ;-)


Regards,
Stefan

Return to “Troubleshooting”