Arikania
Posts: 8
Joined: Tue Sep 11, 2018 6:44 am

Unable to mount ext4 usb hdd via fstab as read-write

Sat Dec 08, 2018 6:06 pm

I have a Pi B 3+ with Raspbian Stretch on it, and a 3 TB USB hard disk connected to it.

On Jessie Lite, I can mount the drive in rw mode with no problems. But whatever I do, even using the very copies from Jessie's /etc/fstab records, I am unable to get the hard disk mounted in read-write mode on the Raspbian. It always puts the whole file system in read-only mode, and I can't even log in graphically anymore, only via a shell using ssh.

I did try adding uid=alicia,gid=alicia to the mount options to no avail, and which I really want to avoid coz the mount must be accessible to all users. My account is renamed from 'pi' to 'alicia'.

This line is the output of uname -a of the computer that the hdd should be connected to:
Linux jessie 4.14.85-v7+ #1173 SMP Tue Dec 4 17:59:59 GMT 2018 armv7l GNU/Linux

and the lines in /etc/fstab spell:
PARTUUID=8 hex. digits-01 /mnt/x/1 ext4 defaults,rw 0 0

and the same line with '2' at the end instead of '0'.


The uname -a output of the computer where it works properly:
Linux jasmine 4.14.71-v7+ #1145 SMP Fri Sep 21 15:38:35 BST 2018 armv7l GNU/Linux

having this /etc/fstab record, which i already tried on Raspbian:
/dev/sda1 /mnt/2 ext4 rw,suid,dev,user,exec,relatime,stripe=8191 0 2

Kindly,


Arikania

Return to “Troubleshooting”