mfraser
Posts: 19
Joined: Thu Oct 18, 2012 2:52 pm

dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 11:48 am

Since upgrading the package raspberrypi-sys-mods to the latest version, I am seeing the message
dpkg-query: no packages found matching at-spi2-core
when I log in.
If I install the package at-spi2-core, this changes to
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-============================-===================-===================-==============================================================
ii at-spi2-core 2.22.0-6+deb9u1 armhf Assistive Technology Service Provider Interface (dbus core)

Looks like the file /etc/profile.d/at-dbus-fix.sh
is doing:

if ! /usr/bin/dpkg -l at-spi2-core | /bin/grep ii ; then
export NO_AT_BRIDGE=1
fi

Anyone know why?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5964
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 11:59 am

That should be resolved with the next sys-mods update (which should be live now)

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5964
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 1:56 pm

Could you post your /etc/apt/sources.list?

The output of 'apt policy' could be helpful too.

It's strange that you would be seeing 'dpkg-query: no packages found matching at-spi2-core', since dpkg should be aware of it. Otherwise you should not have been able to install it.

GaryH1
Posts: 15
Joined: Tue Nov 20, 2018 5:19 pm

Re: dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 2:17 pm

If it's any help, my 3B and 3B+ updated this morning and both are showing this same error.

skypi
Posts: 111
Joined: Sat Aug 09, 2014 11:48 pm

Re: dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 2:27 pm

getting same error on a Pi Zero just updated, first time using the spi interface LOL and am wondering if this error is why the WS2812 library does not work on spi, first time I tried it, kind of works but leds get set to wrong color... does work OK on the pwm pin but then got the requires-root-access problem (which can be worked round, thought I'd try working round it by using SPI pin which does and does not work)

update: just tested another spi library to drive neopixels and that does work OK, so its a subtlety of the library that does not work rather than the spi implementation.

Code: Select all

$cat /etc/apt/sources.list
deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi

$ apt policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://archive.raspberrypi.org/debian stretch/ui armhf Packages
     release o=Raspberry Pi Foundation,a=stable,n=stretch,l=Raspberry Pi Foundation,c=ui,b=armhf
     origin archive.raspberrypi.org
 500 http://archive.raspberrypi.org/debian stretch/main armhf Packages
     release o=Raspberry Pi Foundation,a=stable,n=stretch,l=Raspberry Pi Foundation,c=main,b=armhf
     origin archive.raspberrypi.org
 500 http://raspbian.raspberrypi.org/raspbian stretch/rpi armhf Packages
     release o=Raspbian,a=stable,n=stretch,l=Raspbian,c=rpi,b=armhf
     origin raspbian.raspberrypi.org
 500 http://raspbian.raspberrypi.org/raspbian stretch/non-free armhf Packages
     release o=Raspbian,a=stable,n=stretch,l=Raspbian,c=non-free,b=armhf
     origin raspbian.raspberrypi.org
 500 http://raspbian.raspberrypi.org/raspbian stretch/contrib armhf Packages
     release o=Raspbian,a=stable,n=stretch,l=Raspbian,c=contrib,b=armhf
     origin raspbian.raspberrypi.org
 500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages
     release o=Raspbian,a=stable,n=stretch,l=Raspbian,c=main,b=armhf
     origin raspbian.raspberrypi.org
Pinned packages:
Last edited by skypi on Mon Nov 26, 2018 2:55 pm, edited 1 time in total.

DirkS
Posts: 9941
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 2:34 pm

skypi wrote:
Mon Nov 26, 2018 2:27 pm
getting same error on a Pi Zero just updated, first time using the spi interface
Don't think it has anything to do with the SPI (Serial Peripheral Interface) bus
at-spi stands for Assistive Technology Service Provider Interface

skypi
Posts: 111
Joined: Sat Aug 09, 2014 11:48 pm

Re: dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 2:59 pm

yes, just tested another spi library

https://github.com/joosteto/ws2812-spi

and that one works OK

so some problem (maybe my oversight) in this library with spi, using it on PWM is OK

https://github.com/jgarff/rpi_ws281x

UPDATE:

Turns out to be a weird solution for the above library, on the github issues someone said they had set number of pixels to more than the actual pixels being used and it worked for them, I'm using two and tried double like suggested and that produced different shifting colors, then I tried setting it to 8 pixels and lo and behold, let there be light of the specified colour LOL... It works...

I know its not related to the original post and that has been cured now as well!
Last edited by skypi on Mon Nov 26, 2018 6:38 pm, edited 1 time in total.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5964
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 3:03 pm

Ok, we misunderstood how dpkg -l worked. New update coming within an hour.

GaryH1
Posts: 15
Joined: Tue Nov 20, 2018 5:19 pm

Re: dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 4:42 pm

Have just updated again with new version, all OK now.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5964
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 4:48 pm

Thanks for reporting the issue.

GaryH1
Posts: 15
Joined: Tue Nov 20, 2018 5:19 pm

Re: dpkg-query: no packages found matching at-spi2-core

Mon Nov 26, 2018 4:50 pm

Thanks for fixing it!

Return to “Troubleshooting”