wildbillnj1975
Posts: 30
Joined: Mon Apr 17, 2017 12:39 pm

NFS version mismatch causes hang when mounting

Wed Oct 31, 2018 7:07 pm

I have a Raspberry Pi model B that I use as a NAS server, and a collection of other Pis (a mixture Zero W, 3B and 3B+) all mount the NAS the same way.
Some of them work just fine with this line in /etc/fstab:

Code: Select all

nasserver:/nasroot   /mountpoint   defaults   0   0
But others (there's no rhyme or reason to it), require the NFS version:

Code: Select all

nasserver:/nasroot   /mountpoint   defaults,vers=4   0   0
For that second group, if I omit the NFS version option, mount just hangs indefinitely.
All of these Pis are running Stretch or Stretch Lite... although they were installed at different times (so may be based on older/newer images), they're mostly equivalent. On the second batch, I thought perhaps they needed some (apt-get update && apt-get upgrade) to get NFS 4 and make it the default, but that did not resolve the problem. One of them has the brand new October 2018 image (Lite) and needs "vers=4"... another has the Oct image (with X desktop) and does not need the version option.

What must I do to make NFS 4 the default on all my NFS clients?

Return to “Troubleshooting”