marranxo
Posts: 30
Joined: Thu Dec 03, 2015 2:16 pm

xpanel? blinking after dist-upgrade & rpi-upgrade

Fri Aug 24, 2018 3:21 pm

Hi,

I've just updated my 'old' raspberry 2B (Rev 1.1). Now I'm running kernel 4.14.62-v7+ and my distro according to /etc/os-release is Raspbian 7 (wheezy ).

The upper panel that used to display the menu is blinking, like it's being created and destroed several times per second. Does anyone know how to address this?

Thanks.

User avatar
DougieLawson
Posts: 36330
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: xpanel? blinking after dist-upgrade & rpi-upgrade

Fri Aug 24, 2018 4:16 pm

Start with a fresh install of Stretch (as that's still supported, Wheezy was end-of-life three years ago).

Don't ever run rpi-update, unless you fully understand what it gives you and when you should be running it.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

n67
Posts: 938
Joined: Mon Oct 30, 2017 4:55 pm

Re: xpanel? blinking after dist-upgrade & rpi-upgrade

Fri Aug 24, 2018 5:02 pm

Get to a shell prompt and do:

$ killall -v lxpanel
$ lxpanel --profile LXDE-pi

This will run lxpanel in a mode where you will be able to see what it is doing and what messages it is generating. It may be informative/helpful.

Note: This may or may not be useful advice. I've used this technique when lxpanel has been acting up for me, but, given that OP describes it as "blinking", it may be that they are experiencing a different problem.

Still, worth trying...
"L'enfer, c'est les autres"

G fytc hsqr rum umpbq rm qyw rm rfc kmbq md rfgq dmpsk:

Epmu Sn!

J lnacjrw njbruh-carppnanm vxm rb mnuncrwp vh yxbcb!

Return to “Troubleshooting”