Page 1 of 1

Belkin N150 problem

Posted: Wed Oct 31, 2012 5:29 pm
by dnhime
I am having trouble getting my Belkin N150 to work with my Pi. It is a F7D1101 v1 RTL 8188su.
I have installed Occidentialis v0.2 but it will not work.
I am able to connect to the internet when it is hard wired to my router.
I have tried Raspbian with no luck. I have tried using an external powered hub, no luck.
I don't think power is an issue.
I don't know where to get the driver or even how to load it.
Can anyone help me? I am getting frustrated...
Be kind, I am very new to all of this.
Thanks,
dhime
Urbana Illinois

Re: Belkin N150 problem

Posted: Wed Oct 31, 2012 5:50 pm
by malakai
Not familiar with the card google search didn't help. I am thinking it is a newer card and not fully supported.

A list of working adapters

http://elinux.org/RPi_VerifiedPeriphera ... i_Adapters

Try typing:

lsusb

and post what comes back.

Most the working adapters can be bought off eBay for under $10 shipped from within the US. You can also get them at Amazon but typically will be a bit more expensive.

If you are looking to directly plug it into the Pi and not through a powered hub (Which could be the problem you are having) http://www.raspberrypi.org/phpBB3/viewt ... t+external

2012-10-28-wheezy-raspbian PROBLEMS with Wireless

Posted: Wed Oct 31, 2012 6:39 pm
by fableman
Iam using the new : 2012-10-28-wheezy-raspbian

And every wirless adapter that worked before stop working and I cant make anyone of them work.

I even tried using the GUI setup tool and it can scan network with the USB driver but it never manage to loginto my AP with WAP2 Personal.

Tried Belkin N150
And a Netgear USB wirless
And both stop working.

Something must be broking witht he new 2012-10-28-wheezy-raspbian

Re: Belkin N150 problem

Posted: Wed Oct 31, 2012 8:48 pm
by dnhime
pi@raspberrypi ~ $ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 005: ID 050d:945a Belkin Components F7D1101 v1 Basic Wireless Adapter [Realtek RTL8188SU]

When I searched the site you suggested I see that it says you must download and install firmware-realtek from non-free squeeze repo. I have no idea how to do that. Would that fix my problem? Can you guide me through that?

Belkin Components F7D1101 v1 Basic Wireless Adapter [Realtek RTL8188SU] USB ID 050d:945a, r8712u staging driver, included on Fedora Remix & Arch, must download for Debian and install firmware-realtek from non-free squeeze repo (B)

Re: Belkin N150 problem

Posted: Wed Oct 31, 2012 9:01 pm
by dnhime
Here is a link to the Belkin Model F9L1001v1 N150 Wireless USB Adapter I have
http://www.belkin.com/us/p/P-F9L1001

Re: Belkin N150 problem

Posted: Thu Nov 01, 2012 8:39 am
by fableman
2012-10-28-wheezy-raspbian image got the driver included and the included driver dose not work and there is no new driver or anything I mange to roll back to to get it working!

The driver let me scan network and see my network and others but as soon as I try to connect then it fails. tried two different USB adapters two different brands same problem.

Something is broken in 2012-10-28-wheezy-raspbian when it cames to N150 wirelss USB devices.

Re: Belkin N150 problem

Posted: Tue Dec 25, 2012 5:56 am
by tempVariable
Hi there! I don't know if you still have this problem so I thought that i'd post this anyway. I was looking for how to use the same belkin n150 adapter with my pi several months ago on an older version of debian, and this worked for me:

http://ubuntuforums.org/showthread.php?t=1522815

Try doing the manual method anyway, even though the kernel probably supports it out of the box. I don't know if it will help, but maybe it is a step in the right direction?? Good luck!

-WH