User avatar
seamus
Posts: 28
Joined: Fri Sep 30, 2016 1:25 am

[SOLVED] “mount error(112): Host is down” on stretch, but not jessie! Why?

Sat Apr 07, 2018 3:41 am

First, some background: the CIFS drive I am trying to mount: `PASSPORT2TB` is connected via USB to a small wifi AP running [OpenWRT](https://openwrt.org/), and it is shared via the Samba server on that (OpenWRT) host. I want to connect to `PASSPORT2TB` from my two RPi boxes; one runs `jessie`, the other runs `stretch`. I do not have an entry in `/etc/fstab` for `PASSPORT2TB` on either of the RPis. `RPi:stretch` is a new install on a new 3B+; `RPi:jessie` was recently upgraded from wheezy, and has an operational mount point that has worked for... years.

Here's the exchange when I attempt to mount `PASSPORT2TB` from `RPi:stretch`:

sudo mount -t cifs //192.168.1.250/PASSPORT2TB ~/mntPassport
Password for root@//192.168.1.250/PASSPORT2TB: ********
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

This same command works perfectly on `RPi:jessie`. But not on `RPi:stretch`.

I've searched for an answer, and tried the `-o` option as follows with no success :

sudo mount -t cifs //192.168.1.250/PASSPORT2B mntPassport -o vers=1.0
Password for root@//192.168.1.250/PASSPORT2B: ********
Retrying with upper case share name
mount error(6): No such device or address
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Here's what `journalctl -fb` tells me:
Apr 07 04:23:08 raspberrypi3b sudo[17967]: pam_unix(sudo:session): session closed for user root
Apr 07 04:23:08 raspberrypi3b kernel: CIFS VFS: cifs_mount failed w/return code = -6

Searching for meaning here leads to an [old Samba bug report] (https://bugzilla.samba.org/show_bug.cgi?id=8046) fixed years ago

Anyone know what is causing this - or how to correct it?
Last edited by seamus on Sun Apr 08, 2018 3:24 pm, edited 1 time in total.

User avatar
DougieLawson
Posts: 36306
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: “mount error(112): Host is down” on stretch, but not jessie! Why?

Sat Apr 07, 2018 7:13 am

Are you sure that //192.168.1.250/PASSPORT2TB is shared?
Are you sure that a root userid exists on the CIFS/Samba server? Samba uses a seperate password file.

Since OpenWRT is a Linux system it supports NFS for shared filesystems. Since it does then mounting an NFS export is a) more secure, b) quicker and c) easy to set-up.

https://wiki.openwrt.org/doc/howto/nfs.server
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
seamus
Posts: 28
Joined: Fri Sep 30, 2016 1:25 am

Re: “mount error(112): Host is down” on stretch, but not jessie! Why?

Sat Apr 07, 2018 5:18 pm

DougieLawson wrote:
Sat Apr 07, 2018 7:13 am
1.Are you sure that //192.168.1.250/PASSPORT2TB is shared?
2. Are you sure that a root userid exists on the CIFS/Samba server? Samba uses a seperate password file.

Since OpenWRT is a Linux system it supports NFS for shared filesystems. Since it does then mounting an NFS export is a) more secure, b) quicker and c) easy to set-up.

3. https://wiki.openwrt.org/doc/howto/nfs.server
Hello @Dougie - I really appreciate the help :)
1. Yes, I am quite sure (how else could my `RPi-jessie` mount the drive?
2. I cannot answer that question with 100% certainty because I did not (directly) populate `/etc/samba/smbpasswd` file. But with 99% certainty, the answer is "Yes". I say this because: a) I can mount the drive from my `RPi-jessie`, b) I can mount the drive from OS X as root, and as 'guest', c) it's "how things are done" in the GL-iNet (the mfr) installs of OpenWRT on their WiFi routers (mine is AR-150).
3. This may be OpenWRT's advice now, but it hasn't always been (much upset there now as you may know). Further, there is **NO OPTION** provided to switch over at this point (in the LUCI interface at any rate). I am running the latest firmware from GL-iNet.

To summarize, I really, truly appreciate your suggestions for making over my system, and I know you do so with the best of intentions. But without trying to sound ungrateful, I do not feel the need to invest that time now, and potentially wreck a configuration that has been serving its purpose well and securely for some time now on the theory that an NFS install will solve the problem.

That said, if you can answer the question I asked without requiring me to make over my system, I would really like to hear it. Something has changed in Raspbian between Jessie and Stretch that is causing this... do you know what it is? If it's an authentication issue, and you have any clue as to where I need to begin looking, I would appreciate that. Your NFS evangelism is duly noted.

User avatar
DougieLawson
Posts: 36306
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: “mount error(112): Host is down” on stretch, but not jessie! Why?

Sat Apr 07, 2018 5:37 pm

Do you know the samba configuration on your OpenWRT device, are any shares public and don't need a userid/password?

Take a look with the following commands

nmblookup __SAMBA__
nmblookup -S __SAMBA__
nmblookup '*'
nmblookup -S '*'
nmblookup -S WORKGROUP


For that last command you can use your own workgroup name if it's not set to the Microsoft default of "WORKGROUP".

I suspect your problem will be that the credentials for your "root" user aren't recognised. I don't know OpenWRT (because I've never had a device that can run it) but it probably logs Samba/CIFS requests and failures.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
seamus
Posts: 28
Joined: Fri Sep 30, 2016 1:25 am

Re: “mount error(112): Host is down” on stretch, but not jessie! Why?

Sat Apr 07, 2018 6:39 pm

DougieLawson wrote:
Sat Apr 07, 2018 5:37 pm
Do you know the samba configuration on your OpenWRT device, are any shares public and don't need a userid/password?

Take a look with the following commands

nmblookup __SAMBA__
nmblookup -S __SAMBA__
nmblookup '*'
nmblookup -S '*'
nmblookup -S WORKGROUP


For that last command you can use your own workgroup name if it's not set to the Microsoft default of "WORKGROUP".

I suspect your problem will be that the credentials for your "root" user aren't recognised. I don't know OpenWRT (because I've never had a device that can run it) but it probably logs Samba/CIFS requests and failures.
Thank you again. I take it then, that you're unaware of any diffs between raspbian Jessie and raspbian Stretch that could be responsible for this new behavior?

Yes - all files on the Passport (a 2TB USB drive used mostly to house my MP3 collection for Sonos) are designated as accessible from the 'guest' account. The entire drive is also marked as read-only. A screenshot follows that shows most of the config options (scratch that - I can't insert an image in posts here). Anyway, I am mounting PASSPORT2TB as the root user because occasionally I need to use it to back up files from my RPi. I've also tried to mount PASSPORT2TB as guest, and that fails also.

FWIW, this feels like a bug in raspbian stretch.

Thanks,
~S

User avatar
DougieLawson
Posts: 36306
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: “mount error(112): Host is down” on stretch, but not jessie! Why?

Sat Apr 07, 2018 7:50 pm

Are you using
mount //192.168.1.250/PASSPORT2TB /home/pi/mntPassport -o guest,vers=1.0,...
or
mount //192.168.1.250/PASSPORT2TB /home/pi/mnt/Passport -o username=guest,password=,vers=1.0,...
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

anik
Posts: 15
Joined: Tue Jul 09, 2013 7:43 pm

Re: “mount error(112): Host is down” on stretch, but not jessie! Why?

Sun Apr 08, 2018 12:11 am

Try changing vers=1.0 to vers=3.0 (or 2.0). Microsoft has deprecated 1.0, though I'm not sure why it would work on one system but not another.

User avatar
scruss
Posts: 2542
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: “mount error(112): Host is down” on stretch, but not jessie! Why?

Sun Apr 08, 2018 2:16 am

samba security tightened up between jessie and stretch, and I've had the "Host is down" report for hosts that are so very up indeed.

Adding these options to the fstab line made a formerly disappeared host work for me:

Code: Select all

sec=ntlm,noserverino,vers=2.0
I have no idea why these worked.
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

User avatar
seamus
Posts: 28
Joined: Fri Sep 30, 2016 1:25 am

Re: “mount error(112): Host is down” on stretch, but not jessie! Why?

Sun Apr 08, 2018 2:30 pm

anik wrote:
Sun Apr 08, 2018 12:11 am
Try changing vers=1.0 to vers=3.0 (or 2.0). Microsoft has deprecated 1.0, though I'm not sure why it would work on one system but not another.
Tried that - didn't work, but I do get different error messages. :) But thanks anyway.

User avatar
seamus
Posts: 28
Joined: Fri Sep 30, 2016 1:25 am

Re: “mount error(112): Host is down” on stretch, but not jessie! Why?

Sun Apr 08, 2018 3:22 pm

DougieLawson wrote:
Sat Apr 07, 2018 7:50 pm
Are you using
mount //192.168.1.250/PASSPORT2TB /home/pi/mntPassport -o guest,vers=1.0,...
or
mount //192.168.1.250/PASSPORT2TB /home/pi/mntPassport -o username=guest,password=,vers=1.0,...


I have tried:

Code: Select all

sudo mount -t cifs //192.168.1.250/PASSPORT2B /home/pi/mntPassport

Code: Select all

sudo mount -t cifs //192.168.1.250/PASSPORT2B /home/pi/mntPassport -o vers=1.0

Code: Select all

sudo mount -t cifs //192.168.1.250/PASSPORT2B /home/pi/mntPassport -o vers=2.0

Code: Select all

sudo mount.cifs //192.168.1.250 /home/pi/mntPassport -o guest,ro

Code: Select all

sudo mount.cifs //192.168.1.250/pri_library /home/pi/mntPassport -o guest,ro

Code: Select all

sudo mount.cifs //192.168.1.250/pri_library /home/pi/mntPassport -o user=root,password=********,nounix,sec=ntlmssp

Code: Select all

sudo mount -t cifs -o username=root,password=********,nounix,sec=ntlmssp //192.168.1.250/PASSPORT2B /home/pi/mntPassport
BUT! Trying your suggestion:

Code: Select all

sudo mount //192.168.1.250/PASSPORT2TB /home/pi/mntPassport -o username=guest,password=,vers=1.0
and

Code: Select all

sudo mount //192.168.1.250/PASSPORT2TB /home/pi/mntPassport -o username=root,password=********,vers=1.0
and

Code: Select all

sudo mount -t cifs //192.168.1.250/PASSPORT2TB /home/pi/mntPassport -o username=root,password=********,vers=1.0
WORKS!!!

FWIW, the key diffs are: `vers=1.0` AND `username` instead of `user`

For the record:

1.) using `vers=2.0` and `vers=3.0` both fail on Stretch
2.) using `-o user=*****` works fine on Jessie, but Stretch won't have it! Stretch **requires** `-o username=*****
3.) from `man mount.cifs`:

Code: Select all

vers=
           SMB protocol version. Allowed values are:

           ·   1.0 - The classic CIFS/SMBv1 protocol. This is the default.(*)

(*): Which we now know is INCORRECT.

But I was careless, and stupid - mea culpa; my apologies for that, and my thanks for your patience.

That said, I do find it odd that these changes were made **without** also making a change to the error codes that were returned.

Code: Select all

mount error(112): Host is down
isn't really very helpful. Beyond that, it appears there are some "issues" in the code and/or the man page.
Last edited by seamus on Sun Apr 08, 2018 5:07 pm, edited 1 time in total.

n67
Posts: 938
Joined: Mon Oct 30, 2017 4:55 pm

Re: [SOLVED] “mount error(112): Host is down” on stretch, but not jessie! Why?

Sun Apr 08, 2018 4:16 pm

Code: Select all

mount error(112): Host is down
isn't really very helpful.
Welcome to Unix.
"L'enfer, c'est les autres"

G fytc hsqr rum umpbq rm qyw rm rfc kmbq md rfgq dmpsk:

Epmu Sn!

J lnacjrw njbruh-carppnanm vxm rb mnuncrwp vh yxbcb!

User avatar
seamus
Posts: 28
Joined: Fri Sep 30, 2016 1:25 am

Re: “mount error(112): Host is down” on stretch, but not jessie! Why?

Sun Apr 08, 2018 4:45 pm

scruss wrote:
Sun Apr 08, 2018 2:16 am
samba security tightened up between jessie and stretch, and I've had the "Host is down" report for hosts that are so very up indeed.

Adding these options to the fstab line made a formerly disappeared host work for me:

Code: Select all

sec=ntlm,noserverino,vers=2.0
I have no idea why these worked.
Yes, I read that the Samba vulnerability from last year had resulted in some changes. And I think that's fine, but it seems awkwardly implemented here.

It's interesting that `vers=2.0` worked in your fstab, but not on my command line... I hope that's not still more sloppiness (that's not the "Debian way").

User avatar
seamus
Posts: 28
Joined: Fri Sep 30, 2016 1:25 am

Re: [SOLVED] “mount error(112): Host is down” on stretch, but not jessie! Why?

Sun Apr 08, 2018 5:12 pm

n67 wrote:
Sun Apr 08, 2018 4:16 pm

Code: Select all

mount error(112): Host is down
isn't really very helpful.
Welcome to Unix.
Indeed! But I suppose as users of an open source system, that puts some of the responsibility for maintenance on us, eh?

vectraboyv6
Posts: 43
Joined: Fri Aug 17, 2012 11:28 am

Re: [SOLVED] “mount error(112): Host is down” on stretch, but not jessie! Why?

Mon May 14, 2018 8:41 am

hi all, im trying to mount a share on startup (stretch) without anyluck. it works from the command line with

sudo mount -t cifs -o username=admin,password=password,vers=1.0 //192.168.1.100/movies /mnt/movies

but not in /etc/fstab

//192.168.1.100/movies /mnt/movies cifs defaults,vers=1.0,username=admin,password=password 0 0

sudo mount -a completes without any error but it does not mount

please help

User avatar
scruss
Posts: 2542
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: [SOLVED] “mount error(112): Host is down” on stretch, but not jessie! Why?

Wed May 16, 2018 1:42 am

please don't add to a [SOLVED] post; everyone assumes it's resolved. Start a new thread
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

tlc76
Posts: 2
Joined: Tue Mar 06, 2018 1:15 pm

Re: [SOLVED] “mount error(112): Host is down” on stretch, but not jessie! Why?

Wed May 30, 2018 7:28 am

I confirm it works with option vers=1.0 !

system:

Code: Select all

##        Release = Raspbian GNU/Linux 9 (stretch)
##         Kernel = Linux 4.14.34-v7+
##       Platform = Raspberry Pi 3 Model B Rev 1.2
smb server: Zyxel NSA325-v2

/etc/fstab:

Code: Select all

//10.0.0.253/3tb_1      /mnt/3tb_1      cifs    credentials=/home/openhabian/.smbcredentials,uid=openhabian,gid=openhabian,rw,vers=1.0 0 0
//10.0.0.253/3tb_2      /mnt/3tb_2      cifs    credentials=/home/openhabian/.smbcredentials,uid=openhabian,gid=openhabian,rw,vers=1.0 0 0
/home/openhabian/.smbcredentials:

Code: Select all

username=userxxx
password=**************

.smbcredentials security:

Code: Select all

openhabian@pi:~ $ ll /home/openhabian/.smbcredentials
-rw------- 1 openhabian openhabian 33 May 17 13:37 /home/openhabian/.smbcredentials

without this option I get the classical error "host is down":

Code: Select all

openhabian@pi:~ $ sudo mount -a
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Many thanks for helping out with this issue!

bailey-t3
Posts: 2
Joined: Thu Mar 22, 2018 4:32 pm

Re: [SOLVED] “mount error(112): Host is down” on stretch, but not jessie! Why?

Fri Jul 27, 2018 3:49 pm

Many thanks for this post, I had exactly the same problem, I was using 'user' and 'passwd' now both require the full
'username' and 'password', also the vers=1.0 finally fixed it.

sudo mount -t cifs //192.168.0.111/Download /home/pi/wdshare -o username=pi,password=******,rw,file_mode=0777,dir_mode=0777,vers=1.0

Works fine on both 3B and 3B+

Interesting though, mounting to a windows share has not changed, this still works to my PC share.

sudo mount -t cifs -o username=XYZ,password=********,file_mode=0777,dir_mode=0777 //192.168.0.14/Pi /mnt

tascar01
Posts: 16
Joined: Thu Sep 15, 2016 3:20 pm
Location: Brittany, France

Re: [SOLVED] “mount error(112): Host is down” on stretch, but not jessie! Why?

Mon Jul 30, 2018 5:10 pm

Thanks for this post, it fixed my problem as well.

just added vers-1.0 at the end of the mount and it worked.

same as the other user, my Windows mount didn't need the change.

User avatar
exartemarte
Posts: 373
Joined: Sat Mar 03, 2012 3:51 pm
Location: Middle England
Contact: Website

Re: [SOLVED] “mount error(112): Host is down” on stretch, but not jessie! Why?

Thu Aug 16, 2018 1:17 pm

For the record, this worked for me too. I am accessing networked Pi's (with Samba and various old versions of Raspbian) on the network from a newly set up Pi with current Raspbian Stretch. Fstab entries which had previously worked in Jessie generated the 'Host is down' message in Stretch.

To mount a drive called 'disk1', on a remote Pi called 'hannah' (don't ask...), to the local directory /media/hannah, the relevant line in my /etc/fstab is now:

//hannah/disk1 /media/hannah cifs username=pi,password=MyPasswordForHannah,vers=1.0 0 0

This works, though I did have to check the 'Wait for Network' option in Raspi configuration for it to work on boot.

nclaan
Posts: 1
Joined: Thu Aug 15, 2019 2:56 am

Re: [SOLVED] “mount error(112): Host is down” on stretch, but not jessie! Why?

Thu Aug 15, 2019 2:57 am

vectraboyv6 wrote:
Mon May 14, 2018 8:41 am
hi all, im trying to mount a share on startup (stretch) without anyluck. it works from the command line with

sudo mount -t cifs -o username=admin,password=password,vers=1.0 //192.168.1.100/movies /mnt/movies

but not in /etc/fstab

//192.168.1.100/movies /mnt/movies cifs defaults,vers=1.0,username=admin,password=password 0 0

sudo mount -a completes without any error but it does not mount

please help
I am having the same problem but can't find any other thread that opened on this one. did you solve it?

Return to “Troubleshooting”