AforAlex
Posts: 85
Joined: Thu May 31, 2012 7:56 pm

Pi 3 b+ with official supply refusing to boot and power led blinking

Mon Mar 19, 2018 8:28 pm

Hi, I purchased the official raspberrypi power supply about a month ago and using perfectly well with the previous model of pi (pi 3 model b?... The one before the b+). I've tried the same sd card and same powersupply (official raspberrypi supply for pihut) and instead of booting all I get is the rainbow screen with a lighting logo in top right of screen and the red led light flashes.

The sd card has noobs installed along with openelec and rasbian (now updated to latest version) but the pi still refuses to boot.

Just wondering if others have had problems with the new pi 3 b+ model and the official supply?

Could it be that I either have an underpowered official supply or a rare defective pi 3b+?

Im willing to buy a new supply if that really is the issue but having got the official supply so recently I am assuming that it would be good enough to supply the power needs of the 3b+.

Could it be something else that I'm missing? Should I give cpc a shout about getting the 3b+ replaced?

Many thanks in advance to anyone that can offer any help with troubleshooting or if have had problems also.

Alex

User avatar
davidcoton
Posts: 4202
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: Pi 3 b+ with official supply refusing to boot and power led blinking

Mon Mar 19, 2018 8:44 pm

Did you also update NOOBS to the latest (2.7.0 IIRC) version?
(Sorry I'm not a NOOBS user and don't know offhand how to do that.)
Signature retired

AforAlex
Posts: 85
Joined: Thu May 31, 2012 7:56 pm

Re: Pi 3 b+ with official supply refusing to boot and power led blinking

Mon Mar 19, 2018 9:01 pm

Thanks, I've been doing some reading, and I think some of the sticky posts on the part have been updated since the last time I read, apparently the problem with stuck on the rainbow screen and lighting symbol is pointing at an issue with the version of the booting OS, in this case noobs, going to give that an update (never done before but sure can find some instructions).

Think this issue can be marked as probably solved. Many thanks

User avatar
davidcoton
Posts: 4202
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: Pi 3 b+ with official supply refusing to boot and power led blinking

Mon Mar 19, 2018 9:06 pm

AforAlex wrote:
Mon Mar 19, 2018 9:01 pm
Think this issue can be marked as probably solved.
You do that yourself. Edit your OP and add "[Solved]" to the title. Best to wait til you know that the fix worked, though 8-) :idea:
Signature retired

AforAlex
Posts: 85
Joined: Thu May 31, 2012 7:56 pm

Re: Pi 3 b+ with official supply refusing to boot and power led blinking

Mon Mar 19, 2018 10:09 pm

Cheers, will do. Just trying to figure out how to get access to the recovery partition to noobs so can copy the updated files over. Noobs don't half make it tricky to update itself 😲 will edit once got it sorted, failed to find the partition under Ubuntu so going to try under windows tomorrow at work and see if fair any better.

Cheers

HiassofT
Posts: 221
Joined: Fri Jun 30, 2017 10:07 pm
Location: Salzburg, Austria
Contact: Website

Re: Pi 3 b+ with official supply refusing to boot and power led blinking

Mon Mar 19, 2018 10:48 pm

We (LibreELEC) received several similar bug reports and I could reproduce the issue with old NOOBS versions on an RPi3B+.

I, too, had problems finding instructions how to officially update NOOBS. What finally worked for me (with an initial NOOBS 2.4.5 installation) were the infos buried in this pihut blog post: https://thepihut.com/blogs/raspberry-pi ... berry-pi-2

I've also posted instructions on how to do that from within LibreELEC here: https://forum.libreelec.tv/thread/11929 ... #post84991

But please keep in mind that I only did a quick test with a single NOOBS version and I can't guarantee this'll also work for your NOOBS version. If in doubt better contact the NOOBS developers and ask them about the official instructions how to update NOOBS. It could well be that official upgrades instructions are already published and I just didn't find them.

so long,

Hias

Return to “Troubleshooting”