Fraserp
Posts: 1
Joined: Tue Jan 09, 2018 6:25 pm

Help me fix my eth01

Tue Jan 09, 2018 6:27 pm

When trying to get a static ip a few days ago, I used the following lines

sudo nano /etc/dhpcd.conf sudo nano /etc/network/interfaces

I remember editing values but then removing them later. Now when I used ipconfig I get this: https://pastebin.com/e3Ts9vmp

It says enxb827ebddef65 instead of eth01? what does this mean.

The following is in /etc/dhpcd.conf if that helps: https://pastebin.com/ig5NehH7

beta-tester
Posts: 1237
Joined: Fri Jan 04, 2013 1:57 pm
Location: de_DE

Re: Help me fix my eth01

Tue Jan 09, 2018 6:38 pm

what veraion of raspbian stretch is installed on your sd card?
i remember the very first version(s) didn't had the flag to use the old interface naming in the /boot/cmdline.txt
new raspbian stretch versions do have that flag in the cmdline.txt

or did you modified your cmdline.txt? (added line feeds by accident)
you can bring back the old interface naming behavoir by adding " net.ifnames=0" to the cmdline.txt file.

note: do not add any linefeeds to the cmdline.txt ! everything MUST be in the very first line.
{ I only give negative feedback }
RPi Model B (rev1, 256MB) & B (rev2, 512MB) & B+, RPi2B, RPi3B, RPi3B+, RPiZeroW, ...

User avatar
DougieLawson
Posts: 36173
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Help me fix my eth01

Tue Jan 09, 2018 7:30 pm

sudo apt update && sudo apt -y dist-upgrade
That will add an option to sudo raspi-config to enable "predictable" names (enxb827ebddef65/wlxdeadbeefcafe) or disable them (eth0/wlan0). It needs a reboot after you pick your option.

Personally I think predictable names make life easier, every raspberry has a unique interface name.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Return to “Troubleshooting”