maddy_in65
Posts: 14
Joined: Mon Aug 19, 2013 2:42 pm

Deluge stopped working on Raspbian

Thu Dec 28, 2017 6:27 am

I have installed deluge on raspbian and it was worked fine for 2 days.
Now it is not downloading anything although there are lots of seeders available, tested with new torrent file as well and its same issue.
These torrent are showing "Error" in progress bar but no reason mentioned.
The connected Seeder count increases sometime but again goes back to 0.
I can download with same torrent file on other system in the same network, so its not network related issue.
Deluge version:

Code: Select all

deluged: 1.3.13
I got this message when i checked for Deluge version in terminal:

Code: Select all

/usr/lib/python2.7/dist-packages/deluge/_libtorrent.py:59: RuntimeWarning: to-Python converter for boost::shared_ptr<libtorrent::alert> already registered; second conversion method ignored


Any help would be appreciated!!

beta-tester
Posts: 1237
Joined: Fri Jan 04, 2013 1:57 pm
Location: de_DE

Re: Deluge stopped working on Raspbian

Thu Dec 28, 2017 7:19 am

maybe try an other software... e.g. transmission-gtk (GUI version) or transmission-cli (command line interface version)
{ I only give negative feedback }
RPi Model B (rev1, 256MB) & B (rev2, 512MB) & B+, RPi2B, RPi3B, RPi3B+, RPiZeroW, ...

maddy_in65
Posts: 14
Joined: Mon Aug 19, 2013 2:42 pm

Re: Deluge stopped working on Raspbian

Thu Dec 28, 2017 12:39 pm

Yes tried transmission but again faced issue with that as well. Transmission worked fine for some time but later stopped working. Is there any work around for deluge issue

fred44nl
Posts: 292
Joined: Sat Jun 25, 2016 11:59 am
Location: Scharendijke, NL

Re: Deluge stopped working on Raspbian

Thu Dec 28, 2017 4:55 pm

as I could not get transmission to work, I installed Deluge and follow these instructions:

https://www.howtogeek.com/142044/how-to ... rrent-box/
headless RPi 3B running from usbhdd.

jlynton
Posts: 5
Joined: Sat Dec 16, 2017 9:07 am

Re: Deluge stopped working on Raspbian

Thu Feb 07, 2019 1:23 pm

fred44nl wrote:
Thu Dec 28, 2017 4:55 pm
as I could not get transmission to work, I installed Deluge and follow these instructions:

https://www.howtogeek.com/142044/how-to ... rrent-box/
Doesn't work on 2018-11-13 Stretch - deluged will not start, exits with error:

/usr/lib/python2.7/dist-packages/deluge/_libtorrent.py:59: RuntimeWarning: to-Python converter for boost::shared_ptr<libtorrent::alert> already registered; second conversion method ignored.
import libtorrent as lt

LTolledo
Posts: 1946
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: Deluge stopped working on Raspbian

Thu Feb 07, 2019 2:38 pm

Mine has been running for about 8 months now since first installation... on a native USB boot RPi2B, updated/upgraded regularly.
Only time it was turned off was during every 3 months "cleaning of RPi board" and HDD upgrade (it has 2 x 2TB 2.5" HDDs connected now).
Another (newer) one is running on an RPi1B+ (bootcode.bin boot to USB flash memory) with 1TB 2.5" HDD

the RPi2B's current uptime (after last maintenance period):

Code: Select all

~ $ uptime
 23:25:56 up 25 days, 14:52,  2 users,  load average: 0.08, 0.07, 0.01
the RPi1B+ uptime :

Code: Select all

~$ uptime
 23:31:41 up 61 days, 15:40,  1 user,  load average: 1.60, 1.54, 1.68
followed the installation procedure by TechWiz (search for his YT video). watched it but fast forwarded to the actual Deluge installation only.

I also have encountered the "error". the cause of which is "missing" part of downloaded file that needs to continue updating. Try force re-check.
you may also need to check the destination drive where you are saving the downloaded file. It may be full or does not have enough capacity to complete the download.
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

Dan1jel
Posts: 18
Joined: Wed Aug 08, 2018 6:21 pm
Location: Sweden
Contact: Twitter

Re: Deluge stopped working on Raspbian

Mon Jul 15, 2019 10:11 am

LTolledo wrote:
Thu Feb 07, 2019 2:38 pm
Mine has been running for about 8 months now since first installation... on a native USB boot RPi2B, updated/upgraded regularly.
Only time it was turned off was during every 3 months "cleaning of RPi board" and HDD upgrade (it has 2 x 2TB 2.5" HDDs connected now).
Another (newer) one is running on an RPi1B+ (bootcode.bin boot to USB flash memory) with 1TB 2.5" HDD

the RPi2B's current uptime (after last maintenance period):

Code: Select all

~ $ uptime
 23:25:56 up 25 days, 14:52,  2 users,  load average: 0.08, 0.07, 0.01
the RPi1B+ uptime :

Code: Select all

~$ uptime
 23:31:41 up 61 days, 15:40,  1 user,  load average: 1.60, 1.54, 1.68
followed the installation procedure by TechWiz (search for his YT video). watched it but fast forwarded to the actual Deluge installation only.

I also have encountered the "error". the cause of which is "missing" part of downloaded file that needs to continue updating. Try force re-check.
you may also need to check the destination drive where you are saving the downloaded file. It may be full or does not have enough capacity to complete the download.
I have transmission installed atm but thinking to change to Deluge, but I updated from stretch to buster, but I can't get it to work. Do you know a guide that I can follow to install Debian from scratch and get it to work via web ?

LTolledo
Posts: 1946
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: Deluge stopped working on Raspbian

Mon Jul 15, 2019 12:18 pm

have not updated (yet) to Raspbian Buster, as I think there are still some "teething problems"... and will wait a little bit longer until the "smoke settles" (within 3 months, perhaps)
though irrelevant, am still waiting for availability of RPi4B (all RAM versions) where I want to try Raspbian Buster there.

anyway, in the meantime, will try Buster on another SBC, and install Deluge there to see how it goes, and then port it later to the RPi system....as the same settings usually apply

...will report back once I've got it running properly there....
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

LTolledo
Posts: 1946
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: Deluge stopped working on Raspbian

Mon Jul 15, 2019 2:09 pm

what kind of errors were you getting with your Deluge installation in Raspbian Buster?

though not RPi board, I've upgraded my other SBC's Stretch to Buster by editing the sources.list (the "not recommended method")
installed Deluge and configured it according to my preferences.

accessed that SBC's Deluge webpage using this RPi3B+ desktop (that am using to access this forum)
made some test downloads (Raspbian Buster with Desktop and recommended software)
...it downloaded properly without any problems....

the steps I took (always) was from this site
https://techwiztime.com/article/best-ra ... orrentbox/
I skipped the VPN part (dont need it /not required where I am) and went straight to the deluge installation part
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

Return to “Troubleshooting”