HeAdLeSs
Posts: 17
Joined: Wed Oct 15, 2014 12:18 pm
Location: Cyprus
Contact: Website

Problem with audio noises

Wed Sep 27, 2017 9:35 am

Hello together.

Following setting:
I have a Pi in my RV. The whole electricity system is powered by the RV battery. Right before the Pi is a powerbank as USV. Very simple, a 5V converter is charging the powerbank and the Pi is powered by this powerbank. Now I added a small sound system (4x 200 Watt amp with 2 speaker and a subwoofer). The only way, for now, was to connect the amp to the 3,5 jack of the Pi.

The problem:
I have noises. Not bad, but disturbing. If the Pi is not playing anything, I can hear quit noises. They change. I mean it is not a constant sound.
And when I play music then there is noise too. The funny thing... when I play something quit then there is more noise. And if someone is just talking then the noise is getting louder when the person is speaking and in the break of speaking, the noise is quit too.
If I connect the amp to my mobile then the sound is great. So the problem must be the Pi.

I guess it is a problem with the ground. I also have another problem with the ground. My first question: Would it be a problem if I connect the ground pin of the Pi direct to the ground of the vehicle battery. So that the amp and the Pi have the same ground (else the Pi would have the ground of the powerbank battery). Should I remove the ground of the powerbank in this case? That only plus comes from the powerbank. Would there be a problem if the powerbank does not get ground back?

(Sorry for my english... I am not a native english speaker. I hope you understood anyway what I mean.)

Cheers
Gordon

Return to “Troubleshooting”