Frederk
Posts: 27
Joined: Wed Aug 02, 2017 8:56 pm

[Solved] Error message: "Desktop manager is not active" when trying to login

Wed Aug 02, 2017 9:28 pm

I put a script for randomly changing the wallpaper(viewtopic.php?f=38&t=51744) in /etc/profile.d and when i tried logging later it stayed at the login background and there was an error message that said "Desktop manager is not active". I tried using ctrl+alt+f1/2 but that doesn't do anything i also tried logging in with other accounts but it said the same message. I'm using Raspbian on a pi 3. It would be enough if I could get access to terminal.
Last edited by Frederk on Thu Aug 03, 2017 7:01 pm, edited 1 time in total.

pcmanbob
Posts: 6939
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Error message: "Desktop manager is not active" when trying to login

Thu Aug 03, 2017 9:44 am

Hi.

Did you enable SSH on your pi ? if so just use another pc ( and putty if using windows pc ) to SSH in that will give you a command line.

If SSH is not enabled then power down your pi put the SD card back in to the pc you used to install the image on the SD card and create a file called ssh or ssh.txt then when you power the pi with the SD card in SSH will be enabled ready.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

Frederk
Posts: 27
Joined: Wed Aug 02, 2017 8:56 pm

Re: Error message: "Desktop manager is not active" when trying to login

Thu Aug 03, 2017 1:19 pm

When I put the SD card in my laptop there is a drive called boot and one called RECOVERY.
Which one should I put the ssh.txt file in?

pcmanbob
Posts: 6939
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Error message: "Desktop manager is not active" when trying to login

Thu Aug 03, 2017 2:21 pm

Frederk wrote:
Thu Aug 03, 2017 1:19 pm
When I put the SD card in my laptop there is a drive called boot and one called RECOVERY.
Which one should I put the ssh.txt file in?
It needs to go in to boot
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

Frederk
Posts: 27
Joined: Wed Aug 02, 2017 8:56 pm

Re: Error message: "Desktop manager is not active" when trying to login

Thu Aug 03, 2017 6:41 pm

When I try to connect via ssh it says:

Code: Select all

Last login: Thu Aug  3 20:31:30 2017 from **.*.*.8
/bin/ls: cannot access Backgrounds: No such file or directory
Cannot open display: 
Connection to **.*.*.13 closed.

pcmanbob
Posts: 6939
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Error message: "Desktop manager is not active" when trying to login

Thu Aug 03, 2017 6:56 pm

The way you have added your script obviously means its called when ever the user logs in, so the only option now would be to use another Linux computer to access your SD card and remove the script.

You could do this using your pi if you have another SD card and a card reader that works with the pi.
install raspbian Jessie on spare SD card and boot pi, install old SD card in card reader and plug in to pi.
form what you have said looks like you have used noobs to set up card and as I never use noobs I cant advise you as to which partition to look in to fine the correct folder.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

Frederk
Posts: 27
Joined: Wed Aug 02, 2017 8:56 pm

Re: Error message: "Desktop manager is not active" when trying to login

Thu Aug 03, 2017 6:58 pm

I found out how to fix the problem!!
I did:

Code: Select all

ssh pi@**.*.*.13 sudo mv /etc/profile.d/Wallz.sh /home/frederik/Backgrounds
and now I can login again!
Thanks for your help pcmanbob. :D

Return to “Troubleshooting”