Canedje
Posts: 263
Joined: Thu Mar 26, 2015 7:18 am

Trouble mounting 2 RPI's

Sat Jun 24, 2017 6:54 pm

I try to mount to RPI to each other.
It is working from one RPI to another.
The other way around not.

As far as I know I do have exactly the same fstab and export files on both RPI (except other IP adresses offcourse)
But I still receive an error trying sudo mount -av on one RPI:

Code: Select all

mount.nfs: trying text-based options 'vers=4,addr=192.168.2.185,clientaddr=192.168.2.187'
mount.nfs: mount(2): Connection refused
The export line is:

Code: Select all

/home/ewh 192.168.2.187 *(rw,sync,no_subtree_check)
command: sudo systemctl status rpcbind
gives:

Code: Select all

● rpcbind.service - RPC bind portmap service
   Loaded: loaded (/etc/systemd/system/rpcbind.service; enabled)
  Drop-In: /run/systemd/generator/rpcbind.service.d
           └─50-rpcbind-$portmap.conf
   Active: active (running) since za 2017-06-24 21:37:42 CEST; 12s ago
 Main PID: 26194 (rpcbind)
   CGroup: /system.slice/rpcbind.service
           └─26194 /sbin/rpcbind -f -w

jun 24 21:37:42 raspberrypi-3 systemd[1]: Unit rpcbind.service entered failed state.
jun 24 21:37:42 raspberrypi-3 systemd[1]: Starting RPC bind portmap service...
jun 24 21:37:42 raspberrypi-3 systemd[1]: Started RPC bind portmap service.
jun 24 21:37:42 raspberrypi-3 rpcbind[26194]: Cannot open '/run/rpcbind/rpcbind.xdr' file for reading, errno 2 (No such file or directory)
jun 24 21:37:42 raspberrypi-3 rpcbind[26194]: Cannot open '/run/rpcbind/portmap.xdr' file for reading, errno 2 (No such file or directory)
It cannot open two .xdr files??
Why is connection refused?

Canedje
Posts: 263
Joined: Thu Mar 26, 2015 7:18 am

Re: Trouble mounting 2 RPI's

Sun Jun 25, 2017 8:09 pm

I did found an additional strange thing about the item above:
On one RPI the command sudo exportfs is not working?

DirkS
Posts: 9956
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Trouble mounting 2 RPI's

Sun Jun 25, 2017 8:12 pm

Canedje wrote:I did found an additional strange thing about the item above:
On one RPI the command sudo exportfs is not working?
What is 'not working'?
No output or error message(s)?

Canedje
Posts: 263
Joined: Thu Mar 26, 2015 7:18 am

Re: Trouble mounting 2 RPI's

Sun Jun 25, 2017 8:29 pm

I found out that nfs-kernel was not installed
I installed it
Now sudo exportfs is working
But still got the message: Connection refused at sudo mount -av

See first message at this item

Return to “Troubleshooting”