Canedje
Posts: 263
Joined: Thu Mar 26, 2015 7:18 am

2 questions after reinstall RPI

Sat Jun 10, 2017 7:34 am

Because off a corrupted SD card
I reinstalled everything on my RPI.
It worked out fine.
I only have two questions I can not solve:
- QUESTION 1: Remove user PI. If I use

Code: Select all

sudo userdel pi -r
There are still some PI-user processes running

Code: Select all

pi is currently used by process 1268.
I did change the standard login on the desktop allready to try to have no PI processes running
after reinstall mij RPI Idid add some new users.
adding new users worked fine.
The problem about is that my other users are not standard SUDO, because login at Desktop not as PI but one off the other users I'm not able to make a clone cd by SD Card Copier. It says: unable to read source. (something to do with rights)
If I login as PI again I can make a clone
ps -fu pi gives:

Code: Select all

UID        PID  PPID  C STIME TTY          TIME CMD
pi        1123     1  0 10:47 ?        00:00:00 /lib/systemd/systemd --user
pi        1127  1123  0 10:47 ?        00:00:00 (sd-pam)
pi        1144   558  0 10:47 tty1     00:00:00 -bash
pi        1145  1110  0 10:47 ?        00:00:00 /usr/bin/lxsession -s LXDE-pi -e LXDE
pi        1218  1145  0 10:47 ?        00:00:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session x-session-manager
pi        1222     1  0 10:47 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session x-session-manager
pi        1225     1  0 10:47 ?        00:00:00 /usr/bin/dbus-daemon --fork --print-pid 4 --print-address 6 --session
pi        1260     1  0 10:47 ?        00:00:00 /usr/lib/gvfs/gvfsd
pi        1269     1  0 10:47 ?        00:00:00 /usr/lib/gvfs/gvfsd-fuse /run/user/1000/gvfs -f -o big_writes
pi        1296  1145  0 10:48 ?        00:00:01 openbox --config-file /home/pi/.config/openbox/lxde-pi-rc.xml
pi        1302  1145  0 10:48 ?        00:00:00 lxpolkit
pi        1303  1145  0 10:48 ?        00:00:03 lxpanel --profile LXDE-pi
pi        1305  1145  0 10:48 ?        00:00:02 pcmanfm --desktop --profile LXDE-pi
pi        1319     1  0 10:48 ?        00:00:00 /usr/bin/ssh-agent -s
pi        1367     1  0 10:48 ?        00:00:00 /usr/lib/gvfs/gvfs-udisks2-volume-monitor
pi        1414     1  0 10:48 ?        00:00:00 /usr/lib/gvfs/gvfs-afc-volume-monitor
pi        1419     1  0 10:48 ?        00:00:00 /bin/sh /usr/bin/start-pulseaudio-x11
pi        1420  1419  0 10:48 ?        00:00:00 /usr/bin/xprop -root -spy
pi        1422     1  0 10:48 ?        00:00:00 /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
pi        1426     1  0 10:48 ?        00:00:00 /usr/lib/gvfs/gvfs-goa-volume-monitor
pi        1432     1  0 10:48 ?        00:00:00 /usr/lib/gvfs/gvfs-mtp-volume-monitor
pi        1443     1  0 10:48 ?        00:00:00 /usr/lib/menu-cache/menu-cached /tmp/.menu-cached-:0-pi
pi        1481     1  0 10:48 ?        00:00:00 /usr/lib/gvfs/gvfsd-trash --spawner :1.1 /org/gtk/gvfs/exec_spaw/0
-QUESTION 2: Every time after startup and doing a sudo command the passwd is asked:

Code: Select all

 [sudo] password for ewh:
How to stop this question.

I changed /etc/sudoers allready with:

Code: Select all

# User privilege specification
root    ALL=(ALL:ALL) ALL
pi      ALL=(ALL:ALL) ALL
ewh     ALL=(ALL:ALL) ALL
ewh2    ALL=(ALL:ALL) ALL
www-data   ALL=NOPASSWD: /usr/sbin/hostapd_cli

# Allow members of group sudo to execute any command
%sudo   ALL=(ALL:ALL) ALL
I did have this problems in the past but don't know how to solve them anymore :?

Canedje
Posts: 263
Joined: Thu Mar 26, 2015 7:18 am

Re: 2 questions after reinstall RPI

Mon Jun 12, 2017 6:11 am

Nobody?

ghans
Posts: 7876
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: 2 questions after reinstall RPI

Mon Jun 12, 2017 7:28 am

2. Change the line to

Code: Select all

ewh ALL=(ALL) NOPASSWD: ALL
ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

Canedje
Posts: 263
Joined: Thu Mar 26, 2015 7:18 am

Re: 2 questions after reinstall RPI

Mon Jun 12, 2017 7:37 am

Thanks. I will try

Canedje
Posts: 263
Joined: Thu Mar 26, 2015 7:18 am

Re: 2 questions after reinstall RPI

Mon Jun 12, 2017 4:30 pm

I tried, but still the same situation.

User avatar
RaTTuS
Posts: 10493
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: 2 questions after reinstall RPI

Tue Jun 13, 2017 7:23 am

are you starting the gui desktop as user pi ?
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

Canedje
Posts: 263
Joined: Thu Mar 26, 2015 7:18 am

Re: 2 questions after reinstall RPI

Tue Jun 13, 2017 8:08 am

RaTTuS wrote:are you starting the gui desktop as user pi ?
No. I changed the file: /etc/lightdm/lightdm.conf to start the desktop with a login.
Normally I only operate by SSH. So I normally never log in to the desktop. Only if I need to make a clone SD.
Still there are Pi processes running somehow. (see post above)

Canedje
Posts: 263
Joined: Thu Mar 26, 2015 7:18 am

Re: 2 questions after reinstall RPI

Tue Jun 13, 2017 6:23 pm

I expected to ask simpel questons. It looks like its more difficult as aspected :(

User avatar
RaTTuS
Posts: 10493
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: 2 questions after reinstall RPI

Wed Jun 14, 2017 7:38 am

run sudo rasp-config
and change to boot options to boot to cli , text console requiring user to login .
as you seem to have the session set for desktop as user pi
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

Canedje
Posts: 263
Joined: Thu Mar 26, 2015 7:18 am

Re: 2 questions after reinstall RPI

Wed Jun 14, 2017 4:12 pm

Thanks this worked out fine.

I did found out the other problem also.
The problem was solved because I had the lines in /etc/sudoers in the wrong order
It is importend that the user rights lines are the last/ at the bottom in the file

Case can be closed

Return to “Troubleshooting”