Page 1 of 1

Cast to ChromeCast not functioning in Chromium [SOLVED]

Posted: Mon Mar 13, 2017 7:00 pm
by fruitoftheloom
I have a fully up-to-date Raspbian Jessie install on my Raspberry Pi 3B

chromium-browser "Version 56.0.2924.84 Built on Ubuntu 14.04, running on Raspbian 8.0"

I usually use my ChromeCast from an Android Device works AOK. Unfortunately when use the Cast function from chromium-browser receive the message:

No Cast destinations found. Need help?


https://support.google.com/chromecast/answer/7249696


All my devices are connected to my wireless router, seems like this has been asked previously by Googling, but never resolved :?:

Re: Cast to ChromeCast not functioning in Chromium

Posted: Thu Apr 13, 2017 9:06 pm
by mika123
Have you found a solution?
I'm also seeing the same problem, which is quite frustrating, since it used to work fine with an earlier version of Chrome and the Cast extension :-\

Re: Cast to ChromeCast not functioning in Chromium

Posted: Thu Apr 13, 2017 9:22 pm
by fruitoftheloom
mika123 wrote:Have you found a solution?
I'm also seeing the same problem, which is quite frustrating, since it used to work fine with an earlier version of Chrome and the Cast extension :-\
Unfortunately not found a way to resolve this issue :(

Re: Cast to ChromeCast not functioning in Chromium

Posted: Thu Apr 13, 2017 10:11 pm
by mika123
fruitoftheloom wrote: Unfortunately not found a way to resolve this issue :(
Weird... and I couldn't find any workaround for this, or even many people complaining about it. :o
The only hope is reverting to Chrome 51 and triggering the extension install from https://www.google.com/chromecast/setup/
I don't know yet if the latest pixel image supports doing that though... I'll let you know

Re: Cast to ChromeCast not functioning in Chromium

Posted: Wed Nov 15, 2017 1:42 pm
by fkbreitl
I see the same problem with Chromium Version 60.0.3112.89 (Developer Build) Built on Ubuntu 14.04, running on Raspbian 9.1 (32-bit).

I also found this bug report which seems related and fixed since November 4:

https://bugs.debian.org/cgi-bin/bugrepo ... bug=870619

This issue was also reported at

https://raspberrypi.stackexchange.com/q ... ing-jessie .

So it seems like the Chromecast casting is currently not working but in some month the fixed version of Chromium could make it into Raspbian.

Re: Cast to ChromeCast not functioning in Chromium

Posted: Tue May 22, 2018 5:43 pm
by hippy
Just ran into the same problem myself; Pi 3B, Raspbian Stretch, Chromium 60.0.3112.89 - Same as reported back in November 2017 above.

Does anyone know when a later fixed version will be available ?

Re: Cast to ChromeCast not functioning in Chromium

Posted: Wed May 23, 2018 8:05 am
by ShiftPlusOne
The current version of chromium in our repo should be 65. Are you sure you're up to date?

Re: Cast to ChromeCast not functioning in Chromium

Posted: Wed May 23, 2018 11:04 am
by hippy
ShiftPlusOne wrote:
Wed May 23, 2018 8:05 am
The current version of chromium in our repo should be 65. Are you sure you're up to date?
I thought I was, but it seems chromium and rpi-chromium-mods had been kept back. That's new or I had missed it previously.

Ran 'sudo apt-get dist-upgrade' and that appears to have resolved everything, can now find and cast to my Chromecast ...

Code: Select all

pi@Pi3B:~$ uname -a
Linux Pi3B 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux

pi@Pi3B:~$ chromium-browser --version
--disable-quic --enable-tcp-fast-open --disable-gpu-compositing
--ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so 
--ppapi-flash-args=enable_stagevideo_auto=0 
--ppapi-flash-version=
Chromium 65.0.3325.181 Built on Raspbian , running on Raspbian 9.4

pi@Pi3B:~$
Thanks for pushing me to double-check.

Re: Cast to ChromeCast not functioning in Chromium

Posted: Tue Jul 24, 2018 10:42 am
by satomee
Hi,

I'm just planning to buy a Raspberry Pi 3 B+ and one of the requirements would be to stream video to Chromecast. Reading the above I understand this can be done by using Chromium. But how can I do this if I don1t have any screens attached to the RPI?
Thanks in advance

Re: Cast to ChromeCast not functioning in Chromium

Posted: Tue Jul 24, 2018 12:07 pm
by hippy
satomee wrote:
Tue Jul 24, 2018 10:42 am
how can I do this if I don1t have any screens attached to the RPI?
You can access the virtual desktop of the Pi via VNC, RDP or TeamViewer but it would seem to make more sense to initiate casting to a Chromecast from a device which directly supports that.

Perhaps provide more detail on what you are trying to achieve.

Re: Cast to ChromeCast not functioning in Chromium [solved]

Posted: Mon Jan 21, 2019 8:28 pm
by puccaso
Having the same issue right here.

Code: Select all


mahir@txq:~/build/barrier/build $ chromium-browser --version
 --disable-quic --enable-tcp-fast-open --disable-gpu-compositing --ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so --ppapi-flash-args=enable_stagevideo_auto=0 --ppapi-flash-version=
Chromium 65.0.3325.181 Built on Raspbian , running on Raspbian 9.6
Any update on this?

Re: Cast to ChromeCast not functioning in Chromium [solved]

Posted: Tue Jan 22, 2019 7:24 am
by fruitoftheloom
puccaso wrote:
Mon Jan 21, 2019 8:28 pm
Having the same issue right here.

Code: Select all


mahir@txq:~/build/barrier/build $ chromium-browser --version
 --disable-quic --enable-tcp-fast-open --disable-gpu-compositing --ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so --ppapi-flash-args=enable_stagevideo_auto=0 --ppapi-flash-version=
Chromium 65.0.3325.181 Built on Raspbian , running on Raspbian 9.6
Any update on this?

What same issue ? I originally posted when running Raspbian Jessie, subsequently Raspbian Stretch and chromium-browser v65 have become available and casting is now working as per the post in June 2018.

Any posts newer than that I have ignored as have no relevance to original question.

Maybe you would be better served by starting your own Topic with a full explanation of the issues you are having ??