Miziak
Posts: 3
Joined: Thu Mar 02, 2017 10:30 am

RaspPi Zero over USB problem

Thu Mar 02, 2017 10:48 am

Hi guys, I have problem with rPi Zero over USB. In other words when I try to connect to them over SSH I get connection refused.
Thats are steps which i make to try use it:
1. Download lasest raspbian image and burn it on sdcard
2. In config files I put:
- in cmdline.txt paste between rootwait and quiet: modules-load=dwc2,g_ether
- in config.txt paste at end of file: dtoverlay=dwc2
3. in boot partition create file called ssh (empty ofc)
4. plug pi to usb using usb socket (second from top of pi)

First issue i saw was - pi never is indentified as raspberrypi.local. So, I grab pi IP from windows network device and ping it, ping successfully knoks to pi. But when I try to connect to SSH over this IP my SSH software(putty) says "connection refused".
I think it isn't driver or network problem but i dont have idea why it isn't work either.
You guys have any idea why this isn't working?

In advice thanks for help!

shuckle
Posts: 565
Joined: Sun Aug 26, 2012 11:49 am
Location: Finland

Re: RaspPi Zero over USB problem

Thu Mar 02, 2017 10:55 am

Have you enabled ssh from raspi-config?

Miziak
Posts: 3
Joined: Thu Mar 02, 2017 10:30 am

Re: RaspPi Zero over USB problem

Thu Mar 02, 2017 10:59 am

I belive creating ssh file on boot partition should enable ssh by default? So no I dont enable it in rasp-config

Ernst
Posts: 1213
Joined: Sat Feb 04, 2017 9:39 am
Location: Germany

Re: RaspPi Zero over USB problem

Thu Mar 02, 2017 11:02 am

What did you do to create the ssh file ?

The most effective method to create the ssh file from Windows is to use the following command from the command prompt.

Code: Select all

echo > [drive letter]:/ssh
The road to insanity is paved with static ip addresses

Miziak
Posts: 3
Joined: Thu Mar 02, 2017 10:30 am

Re: RaspPi Zero over USB problem

Thu Mar 02, 2017 11:12 am

I create file using notepad++ editor but i repeat process and do this in your way and sadly it give mi same result pi refuse SSH connection

Return to “Troubleshooting”