Canedje
Posts: 265
Joined: Thu Mar 26, 2015 7:18 am

nfs-kernel-server not always start at startup

Wed Nov 23, 2016 8:33 pm

It looks like that after a reboot the nfs-kernel-server not always starting up.
I do have two RPI's (RPI1 and RPI3)

I conclude this because I do try to mount this RPI1 to RPI3 in /etc/fstab. at RPI1 sometimes mounting is not working.
Also df -h gives then no results (not able to show df -h because the mounting is not made??)
I have to break the df -h command with CTRL-C
sudo mount -a is also not working

If I do start the nfs kernel at RPI3 by the command :

Code: Select all

sudo /etc/init.d/nfs-kernel-server restart 
the mount at RPI1 is working again and I can do df -h after rebooting.

The strangepart is that the command: sudo systemctl status nfs-kernel-server on RPI3 says it is running:
Even before restarting. But I still have to restart it to make it running properly for RPI1 to mount.

Code: Select all

sudo systemctl status nfs-kernel-server
● nfs-kernel-server.service - LSB: Kernel NFS server support
   Loaded: loaded (/etc/init.d/nfs-kernel-server)
   Active: active (exited) since wo 2016-11-23 21:51:29 CET; 1min 50s ago

nov 23 21:51:28 raspberrypi-3 systemd[1]: Starting LSB: Kernel NFS server support...
nov 23 21:51:29 raspberrypi-3 nfs-kernel-server[529]: Exporting directories for NFS kernel daemon...exportfs: No options for /home/ewh 192.168.2.202: suggest 192.168.2.202(sync) to avoid warning
nov 23 21:51:29 raspberrypi-3 nfs-kernel-server[529]: exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specified for export "192.168.2.202:/home/ewh".
nov 23 21:51:29 raspberrypi-3 nfs-kernel-server[529]: Assuming default behaviour ('no_subtree_check').
nov 23 21:51:29 raspberrypi-3 nfs-kernel-server[529]: NOTE: this default has changed since nfs-utils version 1.0.x
nov 23 21:51:29 raspberrypi-3 nfs-kernel-server[529]: .
nov 23 21:51:29 raspberrypi-3 nfs-kernel-server[529]: Starting NFS kernel daemon: nfsd
nov 23 21:51:29 raspberrypi-3 nfs-kernel-server[529]: Not starting: portmapper is not running ... (warning).
nov 23 21:51:29 raspberrypi-3 systemd[1]: Started LSB: Kernel NFS server support.
How do I know sure that the nfs-kernel-server is starting at starup at every time?

Canedje
Posts: 265
Joined: Thu Mar 26, 2015 7:18 am

Re: nfs-kernel-server not always start at startup

Thu Nov 24, 2016 7:14 am

No one a hint?

User avatar
rpdom
Posts: 15608
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: nfs-kernel-server not always start at startup

Thu Nov 24, 2016 7:32 am

The clue is in this line

Code: Select all

Not starting: portmapper is not running ... (warning).
The problem is that the portmapper (prcbind) starts after the nfs-kernel-server, where it whould start before.

There seems to be a solution here viewtopic.php?f=28&t=149002&p=980161

Canedje
Posts: 265
Joined: Thu Mar 26, 2015 7:18 am

Re: nfs-kernel-server not always start at startup

Thu Nov 24, 2016 8:04 am

Thanks.
I didn't read that warning :oops:
I will try that tonight after work!

Canedje
Posts: 265
Joined: Thu Mar 26, 2015 7:18 am

Re: nfs-kernel-server not always start at startup

Thu Nov 24, 2016 4:28 pm

It looks like working.
Thanks again!

Return to “Troubleshooting”