Canedje
Posts: 265
Joined: Thu Mar 26, 2015 7:18 am

sambo not starting after upgrade to jessie

Sat Nov 12, 2016 8:37 pm

I upgraded an older Wheezy raspberry pi to jessie.
I succeeded except getting Samba running again.

after command :
sudo /etc/init.d/samba start
I get the error:

Code: Select all

[....] Starting nmbd (via systemctl): nmbd.serviceJob for nmbd.service failed. See 'systemctl status nmbd.service' and 'journalctl -xn' for details.
 failed!
after command: sudo systemctl status nmbd.service
I get:

Code: Select all

● nmbd.service - LSB: start Samba NetBIOS nameserver (nmbd)
   Loaded: loaded (/etc/init.d/nmbd)
   Active: failed (Result: exit-code) since za 2016-11-12 21:32:29 CET; 16s ago
  Process: 3867 ExecStart=/etc/init.d/nmbd start (code=exited, status=1/FAILURE)

nov 12 21:32:29 raspberrypi-1 nmbd[3867]: Starting NetBIOS name server: nmbd failed!
nov 12 21:32:29 raspberrypi-1 systemd[1]: nmbd.service: control process exited, code=exited status=1
nov 12 21:32:29 raspberrypi-1 systemd[1]: Failed to start LSB: start Samba NetBIOS nameserver (nmbd).
nov 12 21:32:29 raspberrypi-1 systemd[1]: Unit nmbd.service entered failed state.
after sudo journalctl -xn i get:

Code: Select all

-- Logs begin at za 2016-11-12 16:17:31 CET, end at za 2016-11-12 21:37:04 CET. --
nov 12 21:37:01 raspberrypi-1 CRON[4326]: (root) CMD (/usr/bin/python /home/ewh/WebDataNode.py >/dev/null 2>&1)
nov 12 21:37:01 raspberrypi-1 CRON[4329]: (root) CMD (/usr/bin/python /home/ewh/thermostaat.py >/dev/null 2>&1)
nov 12 21:37:02 raspberrypi-1 nmbd[4307]: Starting NetBIOS name server: nmbd failed!
nov 12 21:37:02 raspberrypi-1 systemd[1]: nmbd.service: control process exited, code=exited status=1
nov 12 21:37:02 raspberrypi-1 systemd[1]: Failed to start LSB: start Samba NetBIOS nameserver (nmbd).
-- Subject: Unit nmbd.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit nmbd.service has failed.
--
-- The result is failed.
nov 12 21:37:02 raspberrypi-1 systemd[1]: Unit nmbd.service entered failed state.
nov 12 21:37:02 raspberrypi-1 sudo[4290]: pam_unix(sudo:session): session closed for user root
nov 12 21:37:04 raspberrypi-1 CRON[4183]: pam_unix(cron:session): session closed for user root
nov 12 21:37:04 raspberrypi-1 sudo[4370]: ewh : TTY=pts/0 ; PWD=/home/ewh ; USER=root ; COMMAND=/bin/journalctl -xn
nov 12 21:37:04 raspberrypi-1 sudo[4370]: pam_unix(sudo:session): session opened for user root by ewh(uid=0)

How to start Samba again?

User avatar
DougieLawson
Posts: 36578
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: sambo not starting after upgrade to jessie

Sat Nov 12, 2016 8:39 pm

Start by running sudo testparm
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Canedje
Posts: 265
Joined: Thu Mar 26, 2015 7:18 am

Re: sambo not starting after upgrade to jessie

Sat Nov 12, 2016 8:53 pm

This gives:
sudo testparm
Load smb config files from /etc/samba/smb.conf
WARNING: Ignoring invalid value 'ewh' for parameter 'map to guest'
Error loading services.
after blocking this 2 rules

# security = user
# map to guest = ewh

and running sudo testparm again gives:

Code: Select all

Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Unknown parameter encountered: "quest account"
Ignoring unknown parameter "quest account"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[public]"
Unknown parameter encountered: "quest ok"
Ignoring unknown parameter "quest ok"
Unknown parameter encountered: "quest account"
Ignoring unknown parameter "quest account"
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

# Global parameters
[global]
        netbios name = RASPBERRYPI01
        server string = RaspberryPi01 server
        obey pam restrictions = Yes
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        wins support = Yes
        usershare allow guests = Yes
        panic action = /usr/share/samba/panic-action %d
        idmap config * : backend = tdb


[homes]
        comment = Home Directories
        valid users = %S
        read only = No
        create mask = 0775
        directory mask = 0775
        guest ok = Yes


[printers]
        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        printable = Yes
        print ok = Yes
        browseable = No


[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers


[public]
        path = /
        admin users = everyone
        read only = No
        create mask = 0777
        directory mask = 0777

User avatar
DougieLawson
Posts: 36578
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: sambo not starting after upgrade to jessie

Sat Nov 12, 2016 8:54 pm

guest (with a GEE) not quest (with a QUEUE).
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Canedje
Posts: 265
Joined: Thu Mar 26, 2015 7:18 am

Re: sambo not starting after upgrade to jessie

Sat Nov 12, 2016 8:56 pm

it is guest with a GEE.
That is not oke?
I changed it in a q Quee

After deblocking these two lines an try to start Samba it starts

User avatar
DougieLawson
Posts: 36578
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: sambo not starting after upgrade to jessie

Sat Nov 12, 2016 9:01 pm

Re-run testparm until it works without any errors. Then restart smbd, nmbd and winbind and they should work OK.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Canedje
Posts: 265
Joined: Thu Mar 26, 2015 7:18 am

Re: sambo not starting after upgrade to jessie

Sat Nov 12, 2016 9:53 pm

thanks again
It works

Return to “Troubleshooting”