troyrpi3
Posts: 2
Joined: Tue Aug 30, 2016 6:13 pm

"Bluetooth settings" grayed out

Tue Aug 30, 2016 6:42 pm

Noob, first post. Looked everywhere but can't figure this out. I have 2016-05-27-raspbian-jessie running on rpi3. Bluetooth works, connects to my bluetooth keyboard when i hit Connect, BUT, "Bluetooth settings" is grayed out on the desktop. I want to make the pi visible on startup so my keyboard connects automatically (after I wake my keyboard of course). I thought maybe I needed to log in as root, but I haven't been able to do that, can't seem to set a password for root. Ultimately I want to boot straight into Kodi and have my bluetooth keyboard be connected. I assume I can make this happen once I get access to bluetooth settings, why is it grayed out?

User avatar
bensimmo
Posts: 4073
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire

Re: "Bluetooth settings" grayed out

Tue Aug 30, 2016 7:20 pm

I think this was the post around the time of that NOOBs version, it might or might not help.

Either way, make sure you are up to date with the apt-get update etc . https://www.raspberrypi.org/documentati ... pdating.md

Before someone that knows pops along.
They may want to know the keyboard being used.

User avatar
Douglas6
Posts: 4675
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: "Bluetooth settings" grayed out

Tue Aug 30, 2016 7:36 pm

If by 'visible', you mean 'discoverable', that's not necessary once the two devices are paired. I can't help with the GUI Bluetooth software, but the keyboard should reestablish a broken connection. Sometimes it requires tapping a key a few times. Do make sure the pairing is trusted.

troyrpi3
Posts: 2
Joined: Tue Aug 30, 2016 6:13 pm

Re: "Bluetooth settings" grayed out

Thu Sep 01, 2016 5:22 pm

So, after many tries and what seemed like more reading than I did at university, I solved my problem. I found most of this info at raspberry-projects.com. I will try to explain in noob terms to save people the time I have wasted trying to decrypt the programming lingo.
FIRST, I went into the add/remove programs section of Raspbian in the menu and searched "bluetooth." I then installed a few packages that looked like Bluetooth management software and I upgraded the firmware of the Pi. After a reboot, I had a different menu under the Bluetooth icon which allowed me to change the settings of the adapter.

Getting my Pi to boot straight into Kodi and have my kybd automatically connect was a lot harder to acheive.
After using the windows program PuTTy, I ssh'd into Raspbian from my windows laptop, login as:pi, password:raspberry (password doesn't show as you type), I first tried editing /etc/default/kodi using:

sudo nano /etc/default/kodi

then changed ENABLED=0 to ENABLED=1
exit: CRTL+X, yes:Y to save changes, ENTER to save the file.

the word "sudo" gives you root access which is the same as administrator priviledges in Windows. "Nano" is a text editor. And /etc/default/kodi is both the location of and the text file I wanted to edit.

Doing this made the Rpi3 boot straight into Kodi, but did not give Raspbian the time to connect to my Bluetooth keyboard (the Sony NSG-MR5U, awesome remote, mouse pad still doesn't work, just the kybd part). I should mention I had already added my keyboard as a bluetooth device in the Bluetooth manager and set it as a trusted device before starting this whole venture. My kybd remote worked great in Raspbian, just not in Kodi when I booted straight into it. So I undid all that, set it back to ENABLED=0 and did the following:

sudo nano /home/pi/.config/lxsession/LXDE-pi/autostart

then inserted the line:
@kodi-standalone
at the end. This is just a list of programs Raspbian is to run after startup. @kodi will also start kodi but you get a black screen when you exit, adding the -standalone part fixes this problem.

At boot, the Raspbian desktop shows briefly (about 5 seconds) and then starts up kodi. This seems to give Raspbian the time to connect my keyboard before launching Kodi.

It still took about 10 seconds of pressing buttons on my kybd remote before it connected, but I can do it all from the couch.
Next I tried to raise the Nice value (priority level) of bluetooth hoping to speed it up using:

sudo renice -n -20 -p 711

where "sudo" gives the commands after it administrator priveledges, "renice" changes the priority a process is given by the CPU, "-n" can't remember what this does, "-20" is the new value (negative numbers are given higher priority and -20 is the highest level, lowest level is 10 I think, who designed that??), "-p" stands for the process number, and "711" is my bluetooth process number.

This only works once and is undone by a reboot as the -p # changes. I tried 'renice'ing the bluetoothd process using:

sudo renice -n -20 /usr/lib/bluetooth/bluetoothd

but it tells me bad value. Any ideas how to increase this, it's currently set to 0.

PS Long, but I hope it helps others as I saw lots of people with kybd connecting problems and few answers.

User avatar
cresfang
Posts: 37
Joined: Fri Apr 29, 2016 3:03 am
Location: Garden of Time
Contact: Website

Re: "Bluetooth settings" grayed out

Tue Oct 18, 2016 3:27 am

Btw, referring to OP, how to get Bluetooth Settings?
Mine is grayed out for as long as I remember.

Also I already updated to latest build with PIXEL, but still unable to get into bluetooth settings.

And where are the said new on/off switch for bluetooth & wifi?
Raspberry Pi 3

Return to “Troubleshooting”