User avatar
Pencoys
Posts: 39
Joined: Fri Jan 13, 2012 8:48 am

RPi3 no sound device

Tue Jul 05, 2016 9:22 pm

RPi3
o.s. Ubuntu mate 16.04
kernel updated today
software updates today
HDMI Monitor with HDMI sound - edid.dat confirms this

config.txt has


#normal hdmi mode sound enabled if supported and enabled
hdmi_drive=2
# read edid.dat from attached device
hdmi_edid_file=0
#pretend all audio formats supported
hdmi_force_edid_audio=1

there is no sound device available in System>preferences>hardware>sound
hardware device option is empty


$ amixer -c 0 cset numid=3 2
reports invalid card number

$ aplay -l
reports device_list:268: no soundcards found...

$ lsmod
reports snd_bcm2835 used by 0

ideas why no sound?

There is an error message in the first line of the boot-up test
something about system not reading or somesuch - it flashes past too fast to absorb what it really says

User avatar
topguy
Posts: 6152
Joined: Tue Oct 09, 2012 11:46 am
Location: Trondheim, Norway

Re: RPi3 no sound device

Wed Jul 06, 2016 10:13 am

"dmesg" command or "journalctl -k" (if its using systemd ) will show kernel log from boot.

User avatar
Pencoys
Posts: 39
Joined: Fri Jan 13, 2012 8:48 am

Re: RPi3 no sound device

Fri Jul 08, 2016 5:01 pm

Thanks TopGuy, the message was about kernel modules not being loaded by systemctl or similar. Thats as far as I have had time to investigate. I did try modprobe for the audio but that failed too.
The latest Jessie works ok for audio through the Monitor, but 16.04 Ubuntu Mate does'nt even find the audio device let alone talking to it.
Why is there not a Mate catagory in the forum?. later...

User avatar
topguy
Posts: 6152
Joined: Tue Oct 09, 2012 11:46 am
Location: Trondheim, Norway

Re: RPi3 no sound device

Mon Jul 11, 2016 10:30 am

The best place for Ubuntu questions is probably:

Operating systems -> Other
viewforum.php?f=56

Return to “Troubleshooting”