Mou141
Posts: 30
Joined: Fri Aug 17, 2012 9:24 pm

Raspi Won't Boot

Fri Aug 17, 2012 9:33 pm

My Raspberry pi has stopped booting! When I try to boot it the Red Light comes on but the green light only comes on very dimly and does not flash. I'm using the latest Raspbian distro on a 16GB SD card. It has been working for the past two weeks with no trouble but stopped working yesterday. I haven't been able to test my raspi with a spare sd card because I don't have another one large enough. Please help! :)
Last edited by Mou141 on Fri Aug 17, 2012 9:53 pm, edited 1 time in total.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12653
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Raspi Won't Boot

Fri Aug 17, 2012 9:39 pm

maybe the contents of the card has become damaged, especially the FAT partition seems to have problems when you do not perform regular clean shutdowns, so I would start with deleting the files in the FAT partition and write them anew.

User avatar
Jim JKla
Posts: 2218
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK

Re: Raspi Won't Boot

Fri Aug 17, 2012 9:40 pm

I think that has to be a 16 gig I dont think they make a 26gig.

But to test all you need is a 2gig stick wheezy on it and if it starts then you know it's your phantom 26gig sd with a problem. ;)

4Gig would be better.
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick

Mou141
Posts: 30
Joined: Fri Aug 17, 2012 9:24 pm

Re: Raspi Won't Boot

Fri Aug 17, 2012 9:54 pm

Thanks :D . Where can I get new copies of the files for the FAT partition?

Bad Wolf
Posts: 66
Joined: Wed Jan 25, 2012 11:18 pm

Re: Raspi Won't Boot

Fri Aug 17, 2012 10:34 pm

Mou141 wrote:Thanks :D . Where can I get new copies of the files for the FAT partition?
https://github.com/Hexxeh/rpi-firmware
To a person with a hammer, everything looks like a nail.

jasonjf
Posts: 1
Joined: Sat Aug 18, 2012 2:07 am

My Raspi Won't Boot

Sat Aug 18, 2012 2:12 am

Hello,
I really need some help guys. I downloaded the latest os file "2012-07-15-wheezy-raspbian" and used win 32 to flash my sd card. My SD card is actually a 32 GB Verbatim Class 6 MicroSD card in an SD Adapter. Anyway after flashing the card and putting it into the Raspberry Pi, it refuses to boot.

I have the red light thats solid. I have a blinking green light that turns solid for a few seconds than goes back to blinking. This cycle is repeated a few times (ie blink...solid, blink) and then the green light goes of completely. At no point does my display receive a signal.

What am i doing wrong? I do not have access to another SD card for debugging purposes.
Please HELP!
Jason

User avatar
Jim JKla
Posts: 2218
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK

Re: Raspi Won't Boot

Sat Aug 18, 2012 6:23 am

You probably need to check your power supply the symptoms match a weakness. ;)

Basicaly the load on your power supply rises till it can not cope it then shuts down tho load drops off it resets and tries again once its warmed up it stops resetting but never has enough oomph to continue.

This is an over simplified version of events wildly inaccurate but good enough to expalin that you probably need a meatier PSU. ;)

Read this in the wiki

http://elinux.org/RPi_Noob_Guide_to_the_Pi_image
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick

Mou141
Posts: 30
Joined: Fri Aug 17, 2012 9:24 pm

Re: Raspi Won't Boot

Sat Aug 18, 2012 10:35 pm

Still having trouble booting my raspi :( but now I have more info. I formatted my SD card and put the Raspbian image on it again but most of the time my raspi still refuses to boot (Red power light is on but green light is very dim and constantly on). On the rare occassions I can get it to boot I get this error message:
end request: I/O error, dev mmcblk0, sector 741501
This message repeats continously with the sector incrementing each time. I have tried reformatting my SD card and then putting the raspbian image back on but I still get the same problem. The SD card is on the trusted list. I have tried using another SD card but, again, I still get the same problem. Please help! :D

User avatar
Jim JKla
Posts: 2218
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK

Re: Raspi Won't Boot

Sun Aug 19, 2012 5:52 am

READ the posts PSU (Power supply Unit)

You need to find some alternative power source (Maybe temporary) because it looks like your RaspberryPi is not getting enough power. ;)

Remember your PSU may be rated suitable but be faulty.
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick

Mou141
Posts: 30
Joined: Fri Aug 17, 2012 9:24 pm

Re: Raspi Won't Boot

Sun Aug 19, 2012 3:03 pm

Until my Raspi stopped booting properly a few days ago, my phone charge had been running it fine. I tried a different power source but I got the same problem. Is there anything else I can try? :?:

SupremeSpod
Posts: 22
Joined: Thu Jan 05, 2012 12:19 pm

Re: Raspi Won't Boot

Sun Aug 19, 2012 3:41 pm

If you haven't overclocked your device, sent it back to the supplier for a replacement.

aclearn
Posts: 7
Joined: Sat Dec 24, 2011 9:55 pm

Re: Raspi Won't Boot

Tue Aug 21, 2012 11:39 am

Mou141 wrote:My Raspberry pi has stopped booting! When I try to boot it the Red Light comes on but the green light only comes on very dimly and does not flash. ... It has been working for the past two weeks with no trouble but stopped working yesterday.
I have a similar problem. I wasn't aware that a clean shutdown was necessary btw.
I reflashed the OS to the card but still no joy. I flashed a new card but still no boot. The only problem previously was an error on booting (that I think was caused by a keyboard drawing too much current, the boot screen looped on a USB message). Unplugging the mouse till it booted cured it. The current keyboard draws 100mA.

The PSU is a new panasonic 1A, I have tried two other new PSUs.
There is 5V across TPs.
So it looks like it's a rtb :/.

aclearn
Posts: 7
Joined: Sat Dec 24, 2011 9:55 pm

Re: Raspi Won't Boot

Tue Aug 21, 2012 12:06 pm

aclearn wrote:
Mou141 wrote:My Raspberry pi has stopped booting! .....
I read through this page http://elinux.org/R-Pi_Troubleshooting# ... on_display

I took a look at the sd card holder. There was a piece of plastic that had broken off the sd card that was stopping the card making contact with the pins.
It's booting now.

Mou141
Posts: 30
Joined: Fri Aug 17, 2012 9:24 pm

Re: Raspi Won't Boot

Wed Aug 22, 2012 3:14 pm

Thanks but I've already returned my raspi and asked for a replacement :(. I did check the SD card slot before I returned it though and the pins did seem to be making contact.

Return to “Troubleshooting”