fsamir
Posts: 2
Joined: Thu Jan 22, 2015 6:28 am

Operation not possible due to RF-kill

Thu Apr 28, 2016 1:17 am

Hi all,

after a fresh install of RASPBIAN jessie light on a RPI 3 (with embedded wifi) I get the error below, when I try to start the wireless netwrok(sudo ip link set wlan0 up):

Code: Select all

RTNETLINK answers: Operation not possible due to RF-kill
I can bypass the issue by running:

Code: Select all

rfkill list all
sudo rfkill unblock all
sudo ip link set wlan0 up
However, when I reboot , wifi will be soft blocked again.

How can I make it persistent, so wifi is powered up at boot?

Thanks,
Franklin

User avatar
ab1jx
Posts: 868
Joined: Thu Sep 26, 2013 1:54 pm
Location: Heath, MA USA
Contact: Website

Re: Operation not possible due to RF-kill

Thu Apr 28, 2016 4:00 am

I didn't touch RF-kill, I just use an /etc/network/interfaces file. I use an open WiFi network and a static IP ethernet network. You can leave out the last few lines for eth0 if you don't use them. Most people need WPA and a password, check the man page for the syntax and you'll need to do something in /etc/wpa_supplicant I think. But this file gets both networks working on every boot, no wi_cd or network manager. Oh, set your WiFi ESSID in here where mine says Moto_lte.

Code: Select all

# new interfaces file 4/23/2016

source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
  wireless-essid Moto_lte
  allow-hotplug wlan0

auto eth0
iface eth0 inet static
  address 192.168.0.16
  netmask 255.255.255.0
  network 192.168.0.0
  broadcast 192.168.0.255


fsamir
Posts: 2
Joined: Thu Jan 22, 2015 6:28 am

Re: Operation not possible due to RF-kill

Mon May 23, 2016 12:04 pm

I forgot to mention, I already had wpa_supplicant configured as the suggestion above.
This very same config works on a RPI2(wheezy), but in the RPI 3(jessie) it seems wifi boot in some sort of powersave mode.

Any other ideas?

DirkS
Posts: 9979
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Operation not possible due to RF-kill

Mon May 23, 2016 1:43 pm

fsamir wrote:I forgot to mention, I already had wpa_supplicant configured as the suggestion above.
This very same config works on a RPI2(wheezy), but in the RPI 3(jessie) it seems wifi boot in some sort of powersave mode.

Any other ideas?
Use

Code: Select all

sudo aot-get update
sudo apt-get dist-upgrade
This should get you the latest driver versions that have a fix / workaround for the power saving problems of earlier versions

AndersUk
Posts: 9
Joined: Wed Mar 07, 2012 8:41 am
Contact: Website

Re: Operation not possible due to RF-kill

Tue Jan 29, 2019 6:21 pm

Yep, I’ve strayed into this quagmire as well.

On Raspbian Stretch I tried out:

Code: Select all

#turn off radio power
iwconfig wlan0 txpower off
# turn off wifi interface
ifconfig wlan0 disable
Now the WiFi is off every time I reboot. Following the above:

Code: Select all

rfkill list all
sudo rfkill unblock all
sudo ip link set wlan0 up
Brings the WiFi up, but until next reboot.

I’ve tried putting the above rfkill commands in rc.local, but have failed to bring it back up at boot.

Any suggestions? Thanks

Return to “Troubleshooting”