coding
Posts: 40
Joined: Sun Jul 20, 2014 7:23 am

Some recent update must have killed my vsftpd

Tue Apr 05, 2016 8:40 am

Some recent apt-get update, which I automatically run every day, must have killed my vsftpd. The server is closed and won't start anymore. I don't know how to troubleshoot this. I did not change anything, and my (working-until-now) /etc/vsftpd.conf is still there.

Code: Select all

sudo service vsftpd status
● vsftpd.service - vsftpd FTP server
   Loaded: loaded (/lib/systemd/system/vsftpd.service; enabled)
   Active: failed (Result: exit-code) since Tue 2016-04-05 10:33:47 CEST; 4min 46s ago
  Process: 1950 ExecStart=/usr/sbin/vsftpd /etc/vsftpd.conf (code=exited, status=2)
  Process: 1947 ExecStartPre=/bin/mkdir -p /var/run/vsftpd/empty (code=exited, status=0/SUCCESS)
 Main PID: 1950 (code=exited, status=2)

Apr 05 10:33:47 raspberrypi systemd[1]: Started vsftpd FTP server.
Apr 05 10:33:47 raspberrypi systemd[1]: vsftpd.service: main process exited, cod...NTApr 05 10:33:47 raspberrypi systemd[1]: Unit vsftpd.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
What should be my next steps in troubleshooting?

User avatar
DougieLawson
Posts: 36544
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Some recent update must have killed my vsftpd

Tue Apr 05, 2016 9:57 am

Start by using systemctl -l status vsftpd.service to see the wider (not truncated) messages which may give you a clue as to what code it failed with.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

coding
Posts: 40
Joined: Sun Jul 20, 2014 7:23 am

Re: Some recent update must have killed my vsftpd

Tue Apr 05, 2016 11:39 am

Code: Select all

systemctl -l status vsftpd.service
● vsftpd.service - vsftpd FTP server
   Loaded: loaded (/lib/systemd/system/vsftpd.service; enabled)
   Active: failed (Result: exit-code) since Tue 2016-04-05 10:33:47 CEST; 2h 57min ago
  Process: 1950 ExecStart=/usr/sbin/vsftpd /etc/vsftpd.conf (code=exited, status=2)
  Process: 1947 ExecStartPre=/bin/mkdir -p /var/run/vsftpd/empty (code=exited, status=0/SUCCESS)
 Main PID: 1950 (code=exited, status=2)
I also found this line with sudo journalctl:

Code: Select all

systemd[1]: vsftpd.service: main process exited, code=exited, status=2/INVALIDARGUMENT

Code: Select all

ls -l /etc/vsftpd.conf
-rw-r--r-- 1 root root 254 Jan  1 12:30 /etc/vsftpd.conf
The vsftpd executable was changed on Apr 2:

Code: Select all

ls -l /usr/sbin/vsftpd
-rwxr-xr-x 1 root root 129604 Apr  2 19:41 /usr/sbin/vsftpd

User avatar
DougieLawson
Posts: 36544
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Some recent update must have killed my vsftpd

Tue Apr 05, 2016 8:31 pm

Is there anything in /var/log/syslog?

Have you checked the syntax of everything in your config file?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

coding
Posts: 40
Joined: Sun Jul 20, 2014 7:23 am

Re: Some recent update must have killed my vsftpd

Wed Apr 06, 2016 7:19 am

Same message in /etc/var/syslog:

Code: Select all

Apr  6 08:56:40 raspberrypi systemd[1]: Starting vsftpd FTP server...
Apr  6 08:56:40 raspberrypi systemd[1]: Started vsftpd FTP server.
Apr  6 08:56:40 raspberrypi systemd[1]: vsftpd.service: main process exited, code=exited, status=2/INVALIDARGUMENT
Apr  6 08:56:40 raspberrypi systemd[1]: Unit vsftpd.service entered failed state.
I now found this page, where someone else had a similar error: http://askubuntu.com/questions/683413/v ... ile-exists

He was told to have "listen=YES" in his /etc/vsftpd.conf
That answer has -1 reputation. However, for me it works.

I never had to use that option before. I checked the manual at http://vsftpd.beasts.org/vsftpd_conf.html. There it says the default is "listen=YES". I assume, now that I have to explicitly put it into /etc/vsftpd.conf, that for some reason YES is not the default anymore.

I wish we could confirm this. When suddenly a server stops like this, I am worried about the system's security.

Return to “Troubleshooting”