Adrius42
Posts: 1
Joined: Sat Mar 05, 2016 6:31 pm

2 RPI3 with 2 SD both not booting

Sat Mar 05, 2016 6:57 pm

I have just received 2 RPi3s with 2 SD Cards from RS Online, who sent the cards with the "latest software" neither would boot either RPI3. Rainbow Square and nothing else.
Tried the cards in the Original RPi and RPi 2 Model B V1.1 both cards booted fine.
Sudo apt-get update
sudo apt-get upgrade
A lot of upgrading to do, the card still does not work in either RPi3
Red Light comes on Solid, no Green ever
Jumps to large Rainbow Square and then small Rainbow Square top right and stays there

Have tried multiple power sources with the same result tried to different Monitors with two different HDMI Cables
Older RPIs work in all combinations.

HELP! I no longer have any hair.

Navyscourge
Posts: 258
Joined: Sat Oct 24, 2015 1:50 pm

Re: 2 RPI3 with 2 SD both not booting

Sat Mar 05, 2016 11:19 pm

I don't have a RPi3, nor have I read much about it, but...
then small Rainbow Square top right and stays there
this indicates a low power on other models of Pi; the Pi3 does need a bit more power. Is your power supply good enough?

User avatar
Pencoys
Posts: 39
Joined: Fri Jan 13, 2012 8:48 am

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 1:46 pm

Same problem here, both RPi3 failing to boot in _ANY_ os - been trying for three days now.

RPi3 - new SD Card (SanDisk Ultra10) - installed new images but only get 4 flashes long and 4 flashes short -
PSU has been running two RPi2 simultaneously so adequate PSU rating.
SD card booting in RPi2 without issue.

on another issue, Ubuntu Mate latest image ( 15.10.3 ) for RPi3 corrupted at source?. I hav'nt been able to download a working image of mate for any of my PI's

User avatar
DougieLawson
Posts: 36557
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 1:53 pm

Have you updated the SDCard with the firmware/kernel/modules from Jessie 2016-02-26? Or have you tried running rpi-update on a RPI2B to update it?

Is the card built with old NOOBS, if it is then easiest is a fresh download of NOOBS 1.8 and copy files over once Raspbian (or any other NOOBS supported OS is booted).
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
Pencoys
Posts: 39
Joined: Fri Jan 13, 2012 8:48 am

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 2:03 pm

in desperation, I have followed instructions on MagPi_43

booted in RPi2
sudo apt-get update
sudo apt-get dist-upgrade
sudo shutdown -h now

transferred SD card to RPi3
no boot - full flash screen on monitor - green LED 4 long and 4 short flashes.

back to RPi2
boots without demure.

I note that the usbhid.mousepoll=0 command has'nt been added to /boot/cmdline.txt either.

JonnyHacks
Posts: 1
Joined: Sun Mar 06, 2016 2:20 pm

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 2:30 pm

I seem to have the same problem.
Got a RPi3 kit from ModMyPi, with official power supply (5.1V 2.5A) and latest version of NOOBS. It works fine on my RPi2 but I get nothing on the RPi3. I've also tried different SD cards, different power supplies and the latest version of Raspbian.

Would love to know if there is a fix for this issue, as at the moment I just have a very expensive LED.

User avatar
DougieLawson
Posts: 36557
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 2:47 pm

What happens with a completely fresh SDCard and a copy of NOOBS 1.8, or a download of the Raspbian Jessie 2016-02-26 image dd'd to a re-usable SDCard?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
jartweb
Posts: 12
Joined: Thu Mar 12, 2015 9:33 pm
Location: Teddington
Contact: Website

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 2:57 pm

Sounds similar to my experience. Bought a Pi3 on Monday, arrived Tuesday, found time to experiment with it on Saturday. Tried 2 different PSUs (including the new official one for Pi3), three different SD cards (one SanDisk, two PNY of different speeds). The ONLY image I could get to boot was the 2016-02-26-raspbian-jessie-lite.img from the official download page. Nothing else (Jessie or Wheezy) would boot. Either got a solid red LED and no green or solid red and green flashing 4 long, 4 short.

User avatar
Pencoys
Posts: 39
Joined: Fri Jan 13, 2012 8:48 am

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 3:01 pm

Further testing,
reinstalled "2016-02-26-raspbrian-jessie.img" on known good SD card
Boots on RPiB+
Boots on RPI2
Boots on RPi0 (zero)
no boot on either RPi3 - both purchased from PiHUT

jdb
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2158
Joined: Thu Jul 11, 2013 2:37 pm

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 4:03 pm

Can people with non-booting Pi 3s (after verifying the SD card is both latest Jessie and works in other Pis) post high-resolution pictures of both sides of the board please?

Use a host like http://imgur.com to upload the files.
Rockets are loud.
https://astro-pi.org

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5370
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 4:32 pm

Pencoys wrote:in desperation, I have followed instructions on MagPi_43

booted in RPi2
sudo apt-get update
sudo apt-get dist-upgrade
sudo shutdown -h now
This only works from a Jessie image.
It won't work from Wheezy. It won't work from NOOBS.

User avatar
jartweb
Posts: 12
Joined: Thu Mar 12, 2015 9:33 pm
Location: Teddington
Contact: Website

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 6:29 pm

I can upload some images next weekend if it helps, but I can boot from the latest Jessie image, it's just the older ones which fail.

paulie
Posts: 263
Joined: Thu Jan 19, 2012 6:51 pm

Re: 2 RPI3 with 2 SD both not booting

Sun Mar 06, 2016 8:44 pm

I have a Pi2 which was originally running wheezy.
I changed /etc/apt/sources.List to point to Jessie & upgraded successfully.

I purchased a Pi3 kit from Pimoroni, and hoped to use uSD card from Pi2, but it gets stuck on the rainbow square (solid red LED no green), despite several apt-get update/dist-upgrade rpi-update cycles.

The Pi3 does boot with the supplied uSD card (which I haven't upgraded, in case it stops working).
PSU the same in both cases.

Pi2 card has installed software I need, so would need to clone it when it boots on Pi3
It has been my custom to use Xeyes

User avatar
Pencoys
Posts: 39
Joined: Fri Jan 13, 2012 8:48 am

Re: 2 RPI3 with 2 SD both not booting

Mon Mar 07, 2016 4:56 am

Well, for me its 'Nose back to the grindstone' for the week.
Hopefully the issue will be resolved by next weekend.
Thankyou, everyone, for your contributations :-)
until saturday, byeee

MrB2
Posts: 3
Joined: Tue Oct 13, 2015 12:44 pm

Re: 2 RPI3 with 2 SD both not booting

Tue Mar 08, 2016 12:19 pm

Just a quick note.

Only thing I could get to boot and then update was Jessie Lite.

Everything else stops at the Large (and Little) raindow squares - no matter what I tried with additional attached devices / cards / Rasbian Wheezy / etc.

paulie
Posts: 263
Joined: Thu Jan 19, 2012 6:51 pm

Re: 2 RPI3 with 2 SD both not booting

Tue Mar 08, 2016 1:44 pm

supra wrote:
U can't upgraded from wheezy to jessie

U have to download latest jessie(2016-02-16)
OK, could someone tell me which files in /boot are different, and which versions are known to work,

As I have run update/dist-upgrade and rpi-update several times this week,
So I'm pretty sure I'm running on the bleeding edge
It has been my custom to use Xeyes

ben54i321e432q
Posts: 10
Joined: Wed Mar 09, 2016 8:27 am

Re: 2 RPI3 with 2 SD both not booting

Wed Mar 09, 2016 8:30 am

massively disappointed, I've spent about 500+ hours building my home automation system on top of Raspbian Wheezy, thought I'd get a PI3 for the improved performance, there is no way I can spend the time to re-build the system on top of Jessie, it's just too time consuming.

I think Raspberry Pi foundation should make sure Wheezy can run on the new Pi, so much time and resources spent by members of the community should not needlessly go to waste.

Many likely upgraded just for a bit better performance, a lot won't be happy about having to start from scratch.

User avatar
DougieLawson
Posts: 36557
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: 2 RPI3 with 2 SD both not booting

Wed Mar 09, 2016 11:12 am

What part of Wheezy being end-of-life is a mystery to you?

Jessie is the currently supported DebIan version and has been since April 2015.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

fruitoftheloom
Posts: 21079
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: 2 RPI3 with 2 SD both not booting

Wed Mar 09, 2016 11:48 am

ben54i321e432q wrote:massively disappointed, I've spent about 500+ hours building my home automation system on top of Raspbian Wheezy, thought I'd get a PI3 for the improved performance, there is no way I can spend the time to re-build the system on top of Jessie, it's just too time consuming.

I think Raspberry Pi foundation should make sure Wheezy can run on the new Pi, so much time and resources spent by members of the community should not needlessly go to waste.

Many likely upgraded just for a bit better performance, a lot won't be happy about having to start from scratch.
Debian Wheezy is Officially unsupported from April 2016, there after it is Community Support, so the RPF have chosen not to offer Support it is there prerogative.

https://wiki.debian.org/LTS


Stating that as an exercise in fruitality I install June 2015 Wheezy on a 2B and after update / dist- upgrade /reboot / rpi-update / reboot I transferred to a 3B and it booted though the BT & WiFi not supported by default. It also still functions in the 2B & ZERO.
Retired disgracefully.....
This at present is my daily "computer" https://www.asus.com/us/Chrome-Devices/Chromebit-CS10/

User avatar
winkleink
Forum Moderator
Forum Moderator
Posts: 279
Joined: Mon Nov 07, 2011 9:12 am
Location: UK
Contact: Website

Re: 2 RPI3 with 2 SD both not booting

Wed Mar 09, 2016 11:55 am

In the original post you mentioned the rainbow top right on the Pi3.
This indicates a power issue.
The Pi3 uses more power than the original Pi or Pi2, also it peaks higher as well.
So, this may be a PSU issue.
If you're using the latest Raspian Jessie then all should work.

What is the rating for the PSU?
I'd expect a 1A to fail, a 1.5A to work some of the time depending on what's attached, a 2A to at least boot.
The recommendation for Pi3 is 2.5A.
Twitter:Winkleink
Google+: Winkleink

User avatar
RaTTuS
Posts: 10500
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: 2 RPI3 with 2 SD both not booting

Wed Mar 09, 2016 12:09 pm

ben54i321e432q wrote:massively disappointed, I've spent about 500+ hours building my home automation system on top of Raspbian Wheezy, thought I'd get a PI3 for the improved performance, there is no way I can spend the time to re-build the system on top of Jessie, it's just too time consuming.

I think Raspberry Pi foundation should make sure Wheezy can run on the new Pi, so much time and resources spent by members of the community should not needlessly go to waste.

Many likely upgraded just for a bit better performance, a lot won't be happy about having to start from scratch.
I expect that starting with a fresh jessie
you should be able to get everything you need up and running in next to no time
what is it that you have changed to needs so much time to move ?
1) get latest jessie
2) expand filesystem
3) apt-get install all the stuff you need
4) build from source
5) see what does not work.
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

Oblivifrek
Posts: 1
Joined: Wed Mar 09, 2016 2:37 pm

Re: 2 RPI3 with 2 SD both not booting

Wed Mar 09, 2016 2:41 pm

Im using my RPI 2 Power Supply Cable and NOOBs Works and in the process of installing Raspbian but Ubuntu Mate Gets that Small Rainbow Square.

hippy
Posts: 6242
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

Re: 2 RPI3 with 2 SD both not booting

Wed Mar 09, 2016 6:09 pm

ben54i321e432q wrote:massively disappointed, I've spent about 500+ hours building my home automation system on top of Raspbian Wheezy, thought I'd get a PI3 for the improved performance, there is no way I can spend the time to re-build the system on top of Jessie, it's just too time consuming.
I can feel your pain and I hate it when I have to reinstall a Pi OS and there are hours of having to go through configuration files and scripts to set it up how it was. But I have a checklist of what needs to be changed so it's just the drudgery of doing it. In terms of applications and code I run, I just copy those to the new setup and I have never had anything not work as it did.

I think you have to face it that Wheezy is not going to be officially supported on the Pi 3B and is end of line for all other Pi's.

What in particular would cause you difficulty with what you have under Jessie ?

phil95
Posts: 141
Joined: Wed Sep 12, 2012 8:10 am
Location: Paris

Re: 2 RPI3 with 2 SD both not booting

Wed Mar 09, 2016 6:14 pm

Hello,
I have received today my RPI3 from RS.
- without SD card, screen black - OK
- with SD card Jessie 26 02 16, color mire but no activity on green led
- with SD card Jessie 21 11 15, color mire and 4 long flash + 4 short flask
These 2 SD cards are working in RPI1 and RPI2 without problem.
Alim is 2 A.
Any suggestion ?
Philippe

ajm1403
Posts: 3
Joined: Wed Mar 09, 2016 10:04 pm

Re: 2 RPI3 with 2 SD both not booting

Wed Mar 09, 2016 10:19 pm

I purchased a new Raspberry Pi 3 today at Microcenter and see the same behavior (4 slow, 4 fast led, rainbow video)

I have attempted to boot with new and old (working) installs of :
Raspbian Jessie version February 2016 (2016-02-26)
Raspbian Jessie version November 2015 (2015-11-21)
on both freshly formatted and old (working)
16GB and 32GB class 10 sdhc cards
with both (working)
2.0 and 2.5 amp power supplies

Same cards and operating system boot fine on Raspberry Pi 1b and 2b with same power supplies.

I will try to attempt with Jessie 02/2016 Lite later this evening.

Return to “Troubleshooting”