Page 1 of 1

Cannot upgrade RPi to JDK 1.8

Posted: Sat Feb 06, 2016 11:32 am
by Yokosumari
Hello. I've been trying to troubleshoot this issue, but I haven't had much luck. When I run "sudo apt-get install oracle-java8-jdk" everything installs fine. However when I run "java -version" it's still coming up as version 1.6. How do I remedy this?

Re: Cannot upgrade RPi to JDK 1.8

Posted: Sat Feb 06, 2016 2:15 pm
by Navyscourge
Are you running the latest Jessie Raspbian? How and when did you install it?

My Jessie gives

Code: Select all

pi@raspberrypi ~ $ java -version
java version "1.8.0"
Java(TM) SE Runtime Environment (build 1.8.0-b132)
Java HotSpot(TM) Client VM (build 25.0-b70, mixed mode)
What do you get from

Code: Select all

apt-cache policy
That should show either jessie or wheezy

Re: Cannot upgrade RPi to JDK 1.8

Posted: Sat Feb 06, 2016 7:29 pm
by johnnyalpha8
You can edit .bashrc in your home directory. Add two lines:

alias java=/path/to/your/java/binary
alias javac=/path/to/your/javac/binary

:)