User avatar
tanix2
Posts: 19
Joined: Sat Sep 19, 2015 12:35 pm

Raspbian not Working (Ubuntu is Ok)

Sun Nov 29, 2015 5:53 pm

Hi Friends, since yesterday I've tried again & again to make raspbian work, using two different cards class 6 and class 10. First time noobs screen is visible on my monitor, raspbian is installed successfully, once it restarts the pi I can't see anything on monitor, can't even find config etc file in sd card to modify neither pressing 1,2,3,4 works.

Ubuntu mate (15.10 desktop.armhf.rpi2) is working perfectly without any issues.
(but can't make riscos work as well)

User avatar
Kratos
Posts: 394
Joined: Sun Apr 12, 2015 12:41 pm

Re: Raspbian not Working (Ubuntu is Ok)

Sun Nov 29, 2015 8:57 pm

What display are you using?
You could try downloading the official image here:
https://downloads.raspberrypi.org/raspbian_latest
Then extract it and write it to an SD card.

Kratos
I have posted mostly with a Pi 2 running either Ubuntu MATE, or Raspbian.

User avatar
tanix2
Posts: 19
Joined: Sat Sep 19, 2015 12:35 pm

Re: Raspbian not Working (Ubuntu is Ok)

Mon Nov 30, 2015 4:56 am

Kratos wrote:What display are you using?
You could try downloading the official image here:
https://downloads.raspberrypi.org/raspbian_latest
Then extract it and write it to an SD card.

Kratos
It's an old LG monitor with VGA so I'm using VGA to HDMI converter jack, let me try this Kratos, Thank you :)

User avatar
Fidelius
Posts: 444
Joined: Wed Jan 01, 2014 8:40 pm
Location: Germany

Re: Raspbian not Working (Ubuntu is Ok)

Mon Nov 30, 2015 1:18 pm

Sounds like some incorrect settings in your "/boot/config.txt" file concerning your VGA monitor. This file is used at boot time by the Pi "BIOS" before the OS is being loaded.

I've got a DVI monitor, and Raspbian works out of the box, but Ubuntu 15.10 showed a black screen because of not sutiable settings in the /boot/config.txt file. So the other way round.

In this config.txt file, the standard Raspbian has all settings commented out I think, whilst Ubuntu 15.10 uses several.

So I'd just insert the two SD cards in a PC or whatever and then copy the config.txt file from your working Ubuntu 15.10 card to your Raspbian card.

Return to “Troubleshooting”