tomdean
Posts: 28
Joined: Tue Feb 19, 2013 4:02 am

calling crda to update world regulatory domain

Thu Oct 01, 2015 7:17 am

I installed jessie on a SD Card. Booted Ok.
Since I am using a USB disk, I
> sudo apt-get update
> sudo apt-get dist-upgrade
... a long time
> sudo reboot

I get lots of
[ 41.449025] cfg80211: Calling CRDA to update world regulatory domain
[ 44.639028] cfg80211: Calling CRDA to update world regulatory domain
[ 47.848992] cfg80211: Calling CRDA to update world regulatory domain

I do not have a wireless adapter!

How to I turn off the calls to CRDA?

Tom Dean

User avatar
DougieLawson
Posts: 34762
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: calling crda to update world regulatory domain

Thu Oct 01, 2015 5:56 pm

Hit it hard. But beware that the rotten thing will reappear when you get a new kernel.
sudo rm /lib/modules/`uname -r`/kernel/net/wireless/cfg80211.ko # beware of the back-ticks.
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a hippy & doctor free zone.

tomdean
Posts: 28
Joined: Tue Feb 19, 2013 4:02 am

Re: calling crda to update world regulatory domain

Thu Oct 01, 2015 6:06 pm

Thanks.

I thought of that, but, ...

I tried blacklisting. A hang on boot where cfg80211 was doing its thing. So, something wants it.

I can not find where cfg80211.ko is loaded.

Any ideas?

Tom Dean

User avatar
rpdom
Posts: 13561
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: calling crda to update world regulatory domain

Thu Oct 01, 2015 6:43 pm

DougieLawson wrote:Hit it hard. But beware that the rotten thing will reappear when you get a new kernel.
sudo rm /lib/modules/`uname -r`/kernel/net/wireless/cfg80211.ko # beware of the back-ticks.
Do people still use the ancient back-ticks?

The $() form is much friendlier and safer when using quotes.

tomdean
Posts: 28
Joined: Tue Feb 19, 2013 4:02 am

Re: calling crda to update world regulatory domain

Thu Oct 01, 2015 7:01 pm

from journalctl, I found a hint. I will try to fix it later...

Oct 01 11:35:48 raspberrypi wpa_supplicant[517]: Could not read interface wlan0 flags: No such device
Oct 01 11:35:48 raspberrypi wpa_supplicant[517]: nl80211: Driver does not support authentication/association or connect commands
Oct 01 11:35:48 raspberrypi dhclient[314]: bound to 192.168.2.12 -- renewal in 703759099 seconds.
Oct 01 11:35:48 raspberrypi ifplugd(eth0)[204]: client: bound to 192.168.2.12 -- renewal in 703759099 seconds.
Oct 01 11:35:48 raspberrypi wpa_supplicant[517]: Could not read interface wlan0 flags: No such device
Oct 01 11:35:48 raspberrypi wpa_supplicant[517]: Could not read interface wlan0 flags: No such device
Oct 01 11:35:48 raspberrypi wpa_supplicant[517]: WEXT: Could not set interface 'wlan0' UP
Oct 01 11:35:48 raspberrypi wpa_supplicant[517]: wlan0: Failed to initialize driver interface
Oct 01 11:35:48 raspberrypi networking[231]: Configuring network interfaces.../etc/network/if-pre-up.d/wpasupplicant: 120: /etc/network/if-pre-up.d/
wpasupplicant: cannot create /dev/stderr: No such device or address
Oct 01 11:35:48 raspberrypi networking[231]: run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Oct 01 11:35:48 raspberrypi networking[231]: Failed to bring up wlan0.
Oct 01 11:35:48 raspberrypi networking[231]: done.
Oct 01 11:35:48 raspberrypi systemd[1]: Started LSB: Raise network interfaces..
Oct 01 11:35:48 raspberrypi systemd[1]: Starting Network.
Oct 01 11:35:48 raspberrypi systemd[1]: Reached target Network.
Oct 01 11:35:48 raspberrypi systemd[1]: Starting Network is Online.
Oct 01 11:35:48 raspberrypi systemd[1]: Reached target Network is Online.
Oct 01 11:35:48 raspberrypi systemd[1]: Starting LSB: RPC portmapper replacement...
Oct 01 11:35:49 raspberrypi rpcbind[602]: Starting rpcbind daemon....
Oct 01 11:35:49 raspberrypi systemd[1]: Started LSB: RPC portmapper replacement.
Oct 01 11:35:49 raspberrypi systemd[1]: Starting RPC Port Mapper.
Oct 01 11:35:49 raspberrypi systemd[1]: Reached target RPC Port Mapper.
Oct 01 11:35:50 raspberrypi ifplugd(eth0)[204]: Program executed successfully.
Oct 01 11:35:51 raspberrypi kernel: cfg80211: Calling CRDA to update world regulatory domain
Oct 01 11:35:54 raspberrypi kernel: cfg80211: Calling CRDA to update world regulatory domain
Oct 01 11:35:57 raspberrypi kernel: cfg80211: Calling CRDA to update world regulatory domain
Oct 01 11:36:00 raspberrypi kernel: cfg80211: Calling CRDA to update world regulatory domain
Oct 01 11:36:04 raspberrypi kernel: cfg80211: Calling CRDA to update world regulatory domain
Oct 01 11:36:07 raspberrypi kernel: cfg80211: Calling CRDA to update world regulatory domain
Oct 01 11:36:10 raspberrypi kernel: cfg80211: Calling CRDA to update world regulatory domain
Oct 01 11:36:13 raspberrypi kernel: cfg80211: Calling CRDA to update world regulatory domain
Oct 01 11:36:16 raspberrypi kernel: cfg80211: Calling CRDA to update world regulatory domain
Oct 01 11:36:20 raspberrypi kernel: cfg80211: Calling CRDA to update world regulatory domain
Oct 01 11:36:23 raspberrypi kernel: cfg80211: Exceeded CRDA call max attempts. Not calling CRDA
Oct 01 11:36:59 raspberrypi systemd[1]: Job dev-disk-by\x2duuid-b1c06464\x2deb1f\x2d4b67\x2db8a5\x2d5afee83a0c3d.device/start timed out.
Oct 01 11:36:59 raspberrypi systemd[1]: Timed out waiting for device dev-disk-by\x2duuid-b1c06464\x2deb1f\x2d4b67\x2db8a5\x2d5afee83a0c3d.device.
Oct 01 11:36:59 raspberrypi systemd[1]: Dependency failed for /dev/disk/by-uuid/b1c06464-eb1f-4b67-b8a5-5afee83a0c3d.
Oct 01 11:36:59 raspberrypi systemd[1]: Dependency failed for Swap.

User avatar
DougieLawson
Posts: 34762
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: calling crda to update world regulatory domain

Thu Oct 01, 2015 7:37 pm

tomdean wrote: I can not find where cfg80211.ko is loaded.
It's somewhere in a wireless driver.
https://github.com/raspberrypi/linux/se ... q=cfg80211

Rip it out (or rename it), reboot and look at dmesg to see what driver fails to load because it's missing.
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a hippy & doctor free zone.

tomdean
Posts: 28
Joined: Tue Feb 19, 2013 4:02 am

Re: calling crda to update world regulatory domain

Thu Oct 01, 2015 11:13 pm

I was looking at the problem all the time and skipped over it in my haste to blame wpa_supplicant!

The total message line started with disk_by with the last half being the CRDA message. Two messages on the same line.

The 90 second delay I saw in the boot process was due to a UUID line in /etc/fstab for the swap partition.

We have three applications for the RPi that change by changing the USB disk attached. All have a swap partition 2 as swap and partition 3 as ext4...

Somehow, mkswap? swapon? the UUID was written to /etc/fstab on one disk. Changing that back to /dev/sda2 fixed the hangs.

I still have the error messages, but, that is fixable. It is not wicd.

Sorry for the misleading subject and discussion.

Tom Dean

tomdean
Posts: 28
Joined: Tue Feb 19, 2013 4:02 am

Re: calling crda to update world regulatory domain

Thu Oct 01, 2015 11:23 pm

In case anyone is interested,

> ifquery --list --allow=hotplug

shows what interfaces will be brought up.

On my machine wlan0 was included. I commented out wlan0 from

/etc/network/interfaces.

No more messages.

Tom Dean

MrB2
Posts: 3
Joined: Tue Oct 13, 2015 12:44 pm

Re: calling crda to update world regulatory domain

Tue Oct 13, 2015 12:53 pm

I have found the solution for this problem. I updated my RPI2 from Wheezy to Jessie. Mostly when fine, but this CRDA was driving me nuts so I did a lot of looking..
Read here:
https://packages.debian.org/jessie/crda

What this is is that certain countries/regions only allow certain frequency bands to be used for WiFi transmissions and the CRDA has that data. No idea what Wheezy did, but Jessie needs it. I am currently connected to the network via cable, but also use Wifi when it leaves my desk.

To solve the "problem" - which actually is that the Jessie distro does not have this included, do:
sudo apt-get install wireless-regdb iw crda
sudo reboot

If you can see the scrolling commands on startup you will now see the CRDA frequency table displayed. And, oh happy days....

dgordon42
Posts: 754
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: calling crda to update world regulatory domain

Tue Oct 13, 2015 11:32 pm

@MrB2,
Good fix, thanks for posting.
I agree that the crda, iw & wireless-regdb packages should be in the Raspbian Jessie download.
The Pi also seems to boot a little faster now!

Dave.

meoow
Posts: 1
Joined: Tue Dec 08, 2015 12:59 pm

Re: calling crda to update world regulatory domain

Tue Dec 08, 2015 1:06 pm

DougieLawson wrote:Hit it hard. But beware that the rotten thing will reappear when you get a new kernel.
sudo rm /lib/modules/`uname -r`/kernel/net/wireless/cfg80211.ko # beware of the back-ticks.
Are you kidding me for suggesting such a misguided approach?
If you want to prevent a module from loading, using the standard way (and it works permanent):

Code: Select all

cat <<__EOF__ >> /etc/modprobe.d/blacklist.conf
blacklist cfg80211
__EOF__

User avatar
DougieLawson
Posts: 34762
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: calling crda to update world regulatory domain

Tue Dec 08, 2015 1:45 pm

The OP said he's tried blacklisting.
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a hippy & doctor free zone.

cephapod
Posts: 1
Joined: Thu Jan 14, 2016 8:36 pm

Re: calling crda to update world regulatory domain

Thu Jan 14, 2016 8:45 pm

DougieLawson wrote:Hit it hard. But beware that the rotten thing will reappear when you get a new kernel.
sudo rm /lib/modules/`uname -r`/kernel/net/wireless/cfg80211.ko # beware of the back-ticks.
I had a similar problem to OP and ran this line of code to see if it would fix the problem and it did. It sure does stop the CRDA calls but unfortunately it also stops wifi working. Now

Code: Select all

sudo ifconfig wlan0
returns device not found :?

Now I realise that zapping my wifi is my own fault for running a sudo rm command on a subdirectory of the kernel but could someone suggest remedial action?

pengshp
Posts: 6
Joined: Fri Oct 02, 2015 8:35 pm
Location: China,GuangZhou

Re: calling crda to update world regulatory domain

Fri Mar 18, 2016 5:00 pm

Hi! I have the same problem as you,but I have solve it.you can try :

Code: Select all

sudo apt-get install crda iw wireless-regdb

doorisys
Posts: 1
Joined: Sun May 15, 2016 4:14 am

Re: calling crda to update world regulatory domain

Sun May 15, 2016 4:48 am

I'm in korea, I have significant issue with wifi connection related to crda.
When I set wifi country code to KR, wifi does not totally work.
I have tested this in raspbian 16-03-18 version and newly released 16-05-10 version, but failed.

In 4.1 kernel, dmesg output follows:
[ 6.919344] cfg80211: Calling CRDA to update world regulatory domain
[ 7.026567] brcmfmac: brcmf_sdio_drivestrengthinit: No SDIO Drive strength init done for chip 43430 rev 1 pmurev 24
[ 7.028604] usbcore: registered new interface driver brcmfmac
[ 7.214586] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Dec 15 2015 18:10:45 version 7.45.41.23 (r606571) FWID 01-cc4eda9c
[ 7.234492] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[ 7.352496] bcm2835-rng 3f104000.rng: hwrng registered
[ 7.576604] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[ 7.576617] cfg80211: World regulatory domain updated:
[ 7.576626] cfg80211: DFS Master region: unset
[ 7.576627] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 7.576636] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 7.576643] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 7.576650] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[ 7.576661] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[ 7.576669] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 7.576676] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 7.576683] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 7.576690] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 7.720262] systemd-journald[107]: Received request to flush runtime journal from PID 1
[ 8.107123] brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
[ 8.107151] brcmfmac: brcmf_add_if: ignore IF event
[ 8.112235] brcmfmac: power management disabled
[ 8.633416] cfg80211: Calling CRDA for country: KR
[ 8.653968] cfg80211: Regulatory domain changed to country: KR
[ 8.653992] cfg80211: DFS Master region: JP
[ 8.654002] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 8.654017] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.654033] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[ 8.654047] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 8.654060] cfg80211: (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 3000 mBm), (0 s)
[ 8.654072] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[ 8.680655] brcmfmac: brcmf_run_escan: error (-52)
[ 8.680684] brcmfmac: brcmf_cfg80211_scan: scan error (-52)

and scan command output is:
pi@raspberrypi:~ $ iwlist wlan0 scan
wlan0 No scan results

When I click upper right corner network mananger icon, it still says "No APs found - scanning..."
and dmesg output:
[ 78.711053] brcmfmac: brcmf_run_escan: error (-52)
[ 78.711075] brcmfmac: brcmf_cfg80211_scan: scan error (-52)
[ 138.713075] brcmfmac: brcmf_run_escan: error (-52)
[ 138.713102] brcmfmac: brcmf_cfg80211_scan: scan error (-52)
[ 142.078535] brcmfmac: brcmf_run_escan: error (-52)
[ 142.078562] brcmfmac: brcmf_cfg80211_scan: scan error (-52)
[ 147.078755] brcmfmac: brcmf_run_escan: error (-52)
[ 147.078776] brcmfmac: brcmf_cfg80211_scan: scan error (-52)
[ 152.080014] brcmfmac: brcmf_run_escan: error (-52)
[ 152.080040] brcmfmac: brcmf_cfg80211_scan: scan error (-52)
[ 157.082507] brcmfmac: brcmf_run_escan: error (-52)
[ 157.082534] brcmfmac: brcmf_cfg80211_scan: scan error (-52)
[ 162.082871] brcmfmac: brcmf_run_escan: error (-52)
[ 162.082899] brcmfmac: brcmf_cfg80211_scan: scan error (-52)

In 4.4 kernel, dmesg output follows:
[ 7.461868] brcmfmac: brcmf_sdio_drivestrengthinit: No SDIO Drive strength init done for chip 43430 rev 1 pmurev 24
[ 7.464349] usbcore: registered new interface driver brcmfmac
[ 7.532876] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[ 7.615208] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Dec 15 2015 18:10:45 version 7.45.41.23 (r606571) FWID 01-cc4eda9c
[ 7.639329] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[ 7.877854] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[ 7.877881] cfg80211: World regulatory domain updated:
[ 7.877890] cfg80211: DFS Master region: unset
[ 7.877898] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 7.877912] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 7.877925] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 7.877937] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[ 7.877951] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[ 7.877965] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 7.877977] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 7.877989] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 7.878001] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 8.281471] systemd-journald[137]: Received request to flush runtime journal from PID 1
[ 8.808939] brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
[ 8.808961] brcmfmac: brcmf_add_if: ignore IF event
[ 8.814182] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 8.814230] brcmfmac: power management disabled
[ 9.223714] cfg80211: Regulatory domain changed to country: KR
[ 9.223739] cfg80211: DFS Master region: JP
[ 9.223749] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 9.223765] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 9.223780] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[ 9.223794] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 9.223807] cfg80211: (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 3000 mBm), (0 s)
[ 9.223819] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)

It's same but no scan error message.
When I click upper right corner network mananger icon, it still says "No APs found - scanning..."
,but no additional scan error message different from 4.1 kernel.

However scan command output is:
pi@raspberrypi:~ $ iwlist wlan0 scan
wlan0 No scan results

In 4.4 kernel, wifi is still not working with crda 'KR'.
wpa_supplicant setting is:
pi@raspberrypi:~ $ sudo cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=KR

When I set crda to 'US' or 'GB', wifi is working normally.

What's the problem?

jomoengineer
Posts: 1
Joined: Tue Jul 19, 2016 4:47 am

Re: calling crda to update world regulatory domain

Tue Jul 19, 2016 4:52 am

I you type 'sudo iwlist wlan0 scan' you should see the correct output.

However, I am seeing this on multiple RasPi 3's and B+ running the latest Jessie and with the cfg80211 blacklisted as well as the latest crda installed. This occurs multiple times in a day and is quite frustrating. Anyone have a cure for this?

i8beef
Posts: 21
Joined: Tue Apr 11, 2017 5:47 am

Re: calling crda to update world regulatory domain

Thu Apr 13, 2017 7:05 pm

Bump? Been almost a year and no one has found a cure?

pasamonte
Posts: 5
Joined: Sun Mar 05, 2017 7:51 pm

Re: calling crda to update world regulatory domain

Tue Jan 15, 2019 11:15 am

tomdean wrote:
Thu Oct 01, 2015 11:23 pm
In case anyone is interested,

> ifquery --list --allow=hotplug

shows what interfaces will be brought up.

On my machine wlan0 was included. I commented out wlan0 from

/etc/network/interfaces.

No more messages.

Tom Dean

This has just worked pretty well for me. In my case it was wlan1 which was useless in the configuration.

Return to “Troubleshooting”