new2rpi
Posts: 19
Joined: Sun Nov 23, 2014 7:53 pm
Location: Cambridge, UK

Brand new camera module "No data received from sensor"

Fri Jul 31, 2015 9:19 pm

Hi all,

I just received my brand new camera module and I am trying to set up a live stream from the camera across the network.

I followed the walk through here https://www.youtube.com/watch?v=JjPsW-7FUng, but I have been receiving the following error
No data received from sensor. Check all connections, including the Sunny one on the camera board
This is my first time using this camera, and my first time using raspberry pi cameras too. So I am not sure if the hardware (camera module or my raspberry pi) is faulty or have I made a stupid mistake somewhere.

I have checked the connection multiple times (taking it out and reconnecting the ribbon), and I have also tried the camera on my second raspberry pi to the same effect. Is there any way I can check if the camera is working in the first place?

I've included everything from the terminal below.

Any help is greatly appreciated Thanks!

pi@raspberrypi ~ $ raspivid -o - -t 0 -hf -w 1280 -h 720 -fps 24 |cvlc -vvv stream:///dev/stdin --sout '#standard{access=http,mux=ts,dst=:8­160}' :demux=h264
VLC media player 2.0.3 Twoflower (revision 2.0.2-93-g77aa89e)
[0x7008f0] main libvlc debug: VLC media player - 2.0.3 Twoflower
[0x7008f0] main libvlc debug: Copyright © 1996-2012 VLC authors and VideoLAN
[0x7008f0] main libvlc debug: revision 2.0.2-93-g77aa89e
[0x7008f0] main libvlc debug: configured with ./configure '--enable-static' '--build=arm-linux-gnueabihf' 'CFLAGS=-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security' 'CPPFLAGS=-D_FORTIFY_SOURCE=2' 'CXXFLAGS=-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security' 'LDFLAGS=-Wl,-z,relro' '--config-cache' '--disable-maintainer-mode' '--disable-silent-rules' '--disable-update-check' '--enable-fast-install' '--prefix=/usr' '--docdir=/usr/share/doc/vlc-nox' '--sysconfdir=/etc' '--with-binary-version=5+deb7u2' '--enable-a52' '--enable-aa' '--enable-bluray' '--enable-bonjour' '--enable-caca' '--enable-dbus' '--enable-dca' '--enable-dirac' '--enable-directfb' '--enable-dvbpsi' '--enable-dvdnav' '--enable-faad' '--enable-flac' '--enable-fluidsynth' '--enable-freetype' '--enable-fribidi' '--enable-gnutls' '--enable-jack' '--enable-kate' '--enable-libass' '--enable-libmpeg2' '--enable-libproxy' '--enable-libxml2' '--enable-lirc' '--enable-live555' '--enable-mad' '--enable-mkv' '--enable-mod' '--enable-mpc' '--enable-mtp' '--enable-mux_ogg' '--enable-ncurses' '--enable-notify' '--enable-ogg' '--enable-oss' '--enable-pulse' '--enable-qt4' '--enable-realrtsp' '--enable-samplerate' '--enable-schroedinger' '--enable-sdl' '--enable-shout' '--enable-skins2' '--enable-smb' '--enable-speex' '--enable-svg' '--enable-taglib' '--enable-theora' '--enable-twolame' '--enable-upnp' '--enable-vcd' '--enable-vcdx' '--enable-vorbis' '--enable-x264' '--enable-zvbi' '--with-kde-solid=/usr/share/kde4/apps/solid/actions/' '--disable-dxva2' '--disable-gnomevfs' '--disable-goom' '--disable-portaudio' '--disable-projectm' '--disable-sqlite' '--disable-telx' '--enable-alsa' '--enable-atmo' '--enable-dc1394' '--enable-dv' '--enable-fbosd' '--enable-libva' '--enable-linsys' '--enable-omxil' '--enable-pvr' '--enable-udev' '--enable-v4l2' '--disable-crystalhd' '--disable-mmx' '--disable-sse' '--disable-neon' '--disable-altivec' 'build_alias=arm-linux-gnueabihf'
[0x7008f0] main libvlc debug: searching plug-in modules
[0x7008f0] main libvlc debug: loading plugins cache file /usr/lib/vlc/plugins/plugins.dat
[0x7008f0] main libvlc debug: recursively browsing `/usr/lib/vlc/plugins'
[0x7008f0] main libvlc debug: saving plugins cache /usr/lib/vlc/plugins/plugins.dat
[0x7008f0] main libvlc debug: plug-ins loaded: 410 modules
[0x7008f0] main libvlc debug: opening config file (/home/pi/.config/vlc/vlcrc)
[0x7008f0] main libvlc debug: translation test: code is "en_GB"
[0x7008f0] main libvlc debug: CPU has capabilities FPU
[0x7008f0] main libvlc debug: looking for memcpy module: 1 candidate
[0x7008f0] main libvlc debug: using memcpy module "memcpy"
[0x86c738] main input debug: Creating an input for 'Media Library'
[0x86c738] main input debug: Input is a meta file: disabling unneeded options
[0x86c738] main input debug: using timeshift granularity of 50 MiB, in path '/tmp'
[0x86c738] main input debug: `file/xspf-open:///home/pi/.local/share/vlc/ml.xspf' gives access `file' demux `xspf-open' path `/home/pi/.local/share/vlc/ml.xspf'
[0x86c738] main input debug: creating demux: access='file' demux='xspf-open' location='/home/pi/.local/share/vlc/ml.xspf' file='/home/pi/.local/share/vlc/ml.xspf'
[0x713fc8] main demux debug: looking for access_demux module: 3 candidates
[0x713fc8] main demux debug: no access_demux module matching "file" could be loaded
[0x713fc8] main demux debug: TIMER module_need() : 43.200 ms - Total 43.200 ms / 1 intvls (Avg 43.200 ms)
[0x86c738] main input debug: creating access 'file' location='/home/pi/.local/share/vlc/ml.xspf', path='/home/pi/.local/share/vlc/ml.xspf'
[0x799c18] main access debug: looking for access module: 2 candidates
[0x799c18] filesystem access debug: opening file `/home/pi/.local/share/vlc/ml.xspf'
[0x799c18] main access debug: using access module "filesystem"
[0x799c18] main access debug: TIMER module_need() : 10.522 ms - Total 10.522 ms / 1 intvls (Avg 10.522 ms)
[0x799078] main stream debug: Using stream method for AStream*
[0x799078] main stream debug: starting pre-buffering
[0x799078] main stream debug: received first data after 0 ms
[0x799078] main stream debug: pre-buffering done 296 bytes in 0s - 653 KiB/s
[0x799268] main stream debug: looking for stream_filter module: 7 candidates
[0x799268] main stream debug: no stream_filter module matching "any" could be loaded
[0x799268] main stream debug: TIMER module_need() : 36.196 ms - Total 36.196 ms / 1 intvls (Avg 36.196 ms)
[0x799268] main stream debug: looking for stream_filter module: 1 candidate
[0x799268] main stream debug: using stream_filter module "stream_filter_record"
[0x799268] main stream debug: TIMER module_need() : 18.640 ms - Total 18.640 ms / 1 intvls (Avg 18.640 ms)
[0x86c738] main input debug: creating demux: access='file' demux='xspf-open' location='/home/pi/.local/share/vlc/ml.xspf' file='/home/pi/.local/share/vlc/ml.xspf'
[0x79c6d8] main demux debug: looking for demux module: 1 candidate
[0x79c6d8] playlist demux debug: using XSPF playlist reader
[0x79c6d8] main demux debug: using demux module "playlist"
[0x79c6d8] main demux debug: TIMER module_need() : 10.123 ms - Total 10.123 ms / 1 intvls (Avg 10.123 ms)
[0x79b7b8] main demux meta debug: looking for meta reader module: 2 candidates
[0x79b7b8] lua demux meta debug: Trying Lua scripts in /home/pi/.local/share/vlc/lua/meta/reader
[0x79b7b8] lua demux meta debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/reader
[0x79b7b8] lua demux meta debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/reader/filename.luac
[0x79b7b8] lua demux meta debug: Trying Lua scripts in /usr/share/vlc/lua/meta/reader
[0x79b7b8] main demux meta debug: no meta reader module matching "any" could be loaded
[0x79b7b8] main demux meta debug: TIMER module_need() : 133.438 ms - Total 133.438 ms / 1 intvls (Avg 133.438 ms)
[0x86c738] main input debug: `file/xspf-open:///home/pi/.local/share/vlc/ml.xspf' successfully opened
[0x78f528] main xml reader debug: looking for xml reader module: 1 candidate
[0x78f528] main xml reader debug: using xml reader module "xml"
[0x78f528] main xml reader debug: TIMER module_need() : 44.545 ms - Total 44.545 ms / 1 intvls (Avg 44.545 ms)
[0x79c6d8] playlist demux debug: parsed 0 tracks successfully
[0x86c738] main input debug: EOF reached
[0x79c6d8] main demux debug: removing module "playlist"
[0x799268] main stream debug: removing module "stream_filter_record"
[0x799c18] main access debug: removing module "filesystem"
[0x86c738] main input debug: TIMER input launching for 'Media Library' : 271.508 ms - Total 271.508 ms / 1 intvls (Avg 271.508 ms)
[0x799078] main interface debug: looking for interface module: 1 candidate
[0x799078] main interface debug: using interface module "hotkeys"
[0x799078] main interface debug: TIMER module_need() : 4.642 ms - Total 4.642 ms / 1 intvls (Avg 4.642 ms)
[0x86c738] main interface debug: looking for interface module: 1 candidate
[0x788568] main playlist debug: playlist threads correctly activated
[0x86c738] main interface debug: using interface module "inhibit"
[0x86c738] main interface debug: TIMER module_need() : 39.638 ms - Total 39.638 ms / 1 intvls (Avg 39.638 ms)
[0x788568] main playlist debug: adding item `stdin' ( stream:///dev/stdin )
[0x788568] main playlist debug: rebuilding array of current - root Playlist
[0x788568] main playlist debug: rebuild done - 0 items, index -1
[0x712f58] main interface debug: looking for interface module: 1 candidate
[0x721800] main input debug: Creating an input for 'stdin'
[0x788568] main playlist debug: meta ok for (null), need to fetch art
[0x7218a8] main demux meta debug: looking for meta fetcher module: 1 candidate
[0x7218a8] lua demux meta debug: Trying Lua scripts in /home/pi/.local/share/vlc/lua/meta/fetcher
[0x7218a8] lua demux meta debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/fetcher
[0x7218a8] lua demux meta debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/fetcher/tvrage.luac
[0x712f58] main interface debug: using interface module "globalhotkeys"
[0x712f58] main interface debug: TIMER module_need() : 60.964 ms - Total 60.964 ms / 1 intvls (Avg 60.964 ms)
[0x795900] main interface debug: looking for interface module: 1 candidate
[0x7218a8] main demux meta debug: using meta fetcher module "lua"
[0x7218a8] main demux meta debug: TIMER module_need() : 60.148 ms - Total 60.148 ms / 1 intvls (Avg 60.148 ms)
[0x7218a8] main demux meta debug: removing module "lua"
[0x788568] main playlist debug: searching art for stdin
[0x7218a8] main art finder debug: looking for art finder module: 2 candidates
[0x7218a8] lua art finder debug: Trying Lua scripts in /home/pi/.local/share/vlc/lua/meta/art
[0x7218a8] lua art finder debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/art
[0x795900] dummy interface: using the dummy interface module...
[0x795900] main interface debug: using interface module "dummy"
[0x795900] main interface debug: TIMER module_need() : 26.859 ms - Total 26.859 ms / 1 intvls (Avg 26.859 ms)
[0x788568] main playlist debug: rebuilding array of current - root Playlist
[0x788568] main playlist debug: rebuild done - 1 items, index -1
[0x788568] main playlist debug: processing request item: null, node: Playlist, skip: 0
[0x788568] main playlist debug: starting playback of the new playlist item
[0x788568] main playlist debug: resyncing on stdin
[0x788568] main playlist debug: stdin is at 0
[0x788568] main playlist debug: creating new input thread
[0x78fc48] main input debug: Creating an input for 'stdin'
[0x86eea8] main stream output debug: using sout chain=`standard{access=http,mux=ts,dst=:8­160}'
[0x86eea8] main stream output debug: stream=`standard'
[0x7218a8] lua art finder debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/00_musicbrainz.luac
[0x86f100] main stream out debug: looking for sout stream module: 1 candidate
[0x86f100] main stream out debug: set config option: sout-standard-access to http
[0x86f100] main stream out debug: set config option: sout-standard-mux to ts
[0x86f100] main stream out debug: set config option: sout-standard-dst to :8­160
[0x871868] main access out debug: looking for sout access module: 1 candidate
[0x7218a8] lua art finder debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/01_googleimage.luac
[0x7218a8] lua art finder debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/02_frenchtv.luac
[0x871868] main access out debug: net: listening to * port 8
[0x7218a8] lua art finder debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/03_lastfm.luac
[0x7218a8] lua art finder debug: Trying Lua scripts in /usr/share/vlc/lua/meta/art
[0x7218a8] main art finder debug: no art finder module matching "any" could be loaded
[0x7218a8] main art finder debug: TIMER module_need() : 141.077 ms - Total 141.077 ms / 1 intvls (Avg 141.077 ms)
[0x788568] main playlist debug: art not found for stdin
[0x871868] main access out error: socket bind error (Permission denied)
[0x871868] main access out debug: socket error: Address family not supported by protocol
[0x871868] main access out error: cannot create socket(s) for HTTP host
[0x871868] access_output_http access out error: cannot start HTTP server
[0x871868] main access out debug: no sout access module matching "http" could be loaded
[0x871868] main access out debug: TIMER module_need() : 145.411 ms - Total 145.411 ms / 1 intvls (Avg 145.411 ms)
[0x86f100] stream_out_standard stream out error: no suitable sout access module for `http/ts://:8­160'
[0x86f100] main stream out debug: no sout stream module matching "standard" could be loaded
[0x86f100] main stream out debug: TIMER module_need() : 175.184 ms - Total 175.184 ms / 1 intvls (Avg 175.184 ms)
[0x86f100] main stream out debug: destroying chain... (name=(null))
[0x86f100] main stream out debug: destroying chain done
[0x86eea8] main stream output error: stream chain failed for `standard{access=http,mux=ts,dst=:8­160}'
[0x788568] main playlist debug: finished input
[0x78fc48] main input error: cannot start stream output instance, aborting
[0x788568] main playlist debug: dead input
[0x788568] main playlist debug: changing item without a request (current 0/1)
[0x788568] main playlist debug: nothing to play
mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

DirkS
Posts: 9941
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Brand new camera module "No data received from sensor"

Fri Jul 31, 2015 10:02 pm

Have you also checked the 'Sunny' connector as mentioned in the error message.
It's located on the camera board itself and it needs a firm push to get it seated fully

drgeoff
Posts: 9808
Joined: Wed Jan 25, 2012 6:39 pm

Re: Brand new camera module "No data received from sensor"

Fri Jul 31, 2015 10:06 pm

Check the ribbon cable is the correct way round at both ends.

User avatar
MattHawkinsUK
Posts: 538
Joined: Tue Jan 10, 2012 8:48 pm
Location: UK
Contact: Website

Re: Brand new camera module "No data received from sensor"

Fri Jul 31, 2015 10:27 pm

You need to start with the basics to check the camera is working before you try streaming.

You need to try the raspistill utility on the command line to take a single photo.

i.e.

Code: Select all

raspistill -o myimage.jpg
See http://www.raspberrypi-spy.co.uk/2013/0 ... ra-module/ for more details.

At least this will check the camera is working.
My Raspberry Pi blog and home of the BerryClip Add-on board : http://www.raspberrypi-spy.co.uk/
Follow me on Google+, Facebook, Pinterest and Twitter (@RPiSpy)

User avatar
DougieLawson
Posts: 36135
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Brand new camera module "No data received from sensor"

Fri Jul 31, 2015 10:53 pm

What do you get from
vcgencmd get_camera
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

new2rpi
Posts: 19
Joined: Sun Nov 23, 2014 7:53 pm
Location: Cambridge, UK

Re: Brand new camera module "No data received from sensor"

Fri Jul 31, 2015 11:27 pm

DougieLawson wrote:What do you get from
vcgencmd get_camera
it says
supported=1 detected=1

new2rpi
Posts: 19
Joined: Sun Nov 23, 2014 7:53 pm
Location: Cambridge, UK

Re: Brand new camera module "No data received from sensor"

Fri Jul 31, 2015 11:30 pm

MattHawkinsUK wrote:You need to start with the basics to check the camera is working before you try streaming.

You need to try the raspistill utility on the command line to take a single photo.

i.e.

Code: Select all

raspistill -o myimage.jpg
I tried the code and it gives the same error message
mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

new2rpi
Posts: 19
Joined: Sun Nov 23, 2014 7:53 pm
Location: Cambridge, UK

Re: Brand new camera module "No data received from sensor"

Fri Jul 31, 2015 11:31 pm

DirkS wrote:Have you also checked the 'Sunny' connector as mentioned in the error message.
It's located on the camera board itself and it needs a firm push to get it seated fully
drgeoff wrote:Check the ribbon cable is the correct way round at both ends.
I have removed the connections at both ends and reattach a few times including the sunny connector, but it is still giving the same message.

User avatar
DougieLawson
Posts: 36135
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Brand new camera module "No data received from sensor"

Fri Jul 31, 2015 11:42 pm

I think it's the SUNNY connector on the camera board that's disconnected.

vcgencmd get_camera shows that the config.txt stuff has been done and the camera board is responding to I2C traffic, but the sensor isn't giving a sensible result for the mmal calls.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

new2rpi
Posts: 19
Joined: Sun Nov 23, 2014 7:53 pm
Location: Cambridge, UK

Re: Brand new camera module "No data received from sensor"

Sat Aug 08, 2015 10:36 am

Thank you for all your help. I bought a new camera and it worked! I suspect my original camera is a gonner. However, now I have the camera working, but I can't get it to stream on the network. Any ideas? Here below is the log from terminal.
pi@raspberrypi ~ $ raspivid -o - -t 0 -hf -w 800 -h 400 -fps 24 |cvlc -vvv stream:///dev/stdin --sout '#standard{access=http,mux=ts,dst=:8­160}' :demux=h264
VLC media player 2.0.3 Twoflower (revision 2.0.2-93-g77aa89e)
[0x8b58f0] main libvlc debug: VLC media player - 2.0.3 Twoflower
[0x8b58f0] main libvlc debug: Copyright © 1996-2012 VLC authors and VideoLAN
[0x8b58f0] main libvlc debug: revision 2.0.2-93-g77aa89e
[0x8b58f0] main libvlc debug: configured with ./configure '--enable-static' '--build=arm-linux-gnueabihf' 'CFLAGS=-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security' 'CPPFLAGS=-D_FORTIFY_SOURCE=2' 'CXXFLAGS=-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security' 'LDFLAGS=-Wl,-z,relro' '--config-cache' '--disable-maintainer-mode' '--disable-silent-rules' '--disable-update-check' '--enable-fast-install' '--prefix=/usr' '--docdir=/usr/share/doc/vlc-nox' '--sysconfdir=/etc' '--with-binary-version=5+deb7u2' '--enable-a52' '--enable-aa' '--enable-bluray' '--enable-bonjour' '--enable-caca' '--enable-dbus' '--enable-dca' '--enable-dirac' '--enable-directfb' '--enable-dvbpsi' '--enable-dvdnav' '--enable-faad' '--enable-flac' '--enable-fluidsynth' '--enable-freetype' '--enable-fribidi' '--enable-gnutls' '--enable-jack' '--enable-kate' '--enable-libass' '--enable-libmpeg2' '--enable-libproxy' '--enable-libxml2' '--enable-lirc' '--enable-live555' '--enable-mad' '--enable-mkv' '--enable-mod' '--enable-mpc' '--enable-mtp' '--enable-mux_ogg' '--enable-ncurses' '--enable-notify' '--enable-ogg' '--enable-oss' '--enable-pulse' '--enable-qt4' '--enable-realrtsp' '--enable-samplerate' '--enable-schroedinger' '--enable-sdl' '--enable-shout' '--enable-skins2' '--enable-smb' '--enable-speex' '--enable-svg' '--enable-taglib' '--enable-theora' '--enable-twolame' '--enable-upnp' '--enable-vcd' '--enable-vcdx' '--enable-vorbis' '--enable-x264' '--enable-zvbi' '--with-kde-solid=/usr/share/kde4/apps/solid/actions/' '--disable-dxva2' '--disable-gnomevfs' '--disable-goom' '--disable-portaudio' '--disable-projectm' '--disable-sqlite' '--disable-telx' '--enable-alsa' '--enable-atmo' '--enable-dc1394' '--enable-dv' '--enable-fbosd' '--enable-libva' '--enable-linsys' '--enable-omxil' '--enable-pvr' '--enable-udev' '--enable-v4l2' '--disable-crystalhd' '--disable-mmx' '--disable-sse' '--disable-neon' '--disable-altivec' 'build_alias=arm-linux-gnueabihf'
[0x8b58f0] main libvlc debug: searching plug-in modules
[0x8b58f0] main libvlc debug: loading plugins cache file /usr/lib/vlc/plugins/plugins.dat
[0x8b58f0] main libvlc debug: recursively browsing `/usr/lib/vlc/plugins'
[0x8b58f0] main libvlc debug: saving plugins cache /usr/lib/vlc/plugins/plugins.dat
[0x8b58f0] main libvlc debug: plug-ins loaded: 410 modules
[0x8b58f0] main libvlc debug: opening config file (/home/pi/.config/vlc/vlcrc)
[0x8b58f0] main libvlc debug: translation test: code is "en_GB"
[0x8b58f0] main libvlc debug: CPU has capabilities FPU
[0x8b58f0] main libvlc debug: looking for memcpy module: 1 candidate
[0x8b58f0] main libvlc debug: using memcpy module "memcpy"
[0xa21738] main input debug: Creating an input for 'Media Library'
[0xa21738] main input debug: Input is a meta file: disabling unneeded options
[0xa21738] main input debug: using timeshift granularity of 50 MiB, in path '/tmp'
[0xa21738] main input debug: `file/xspf-open:///home/pi/.local/share/vlc/ml.xspf' gives access `file' demux `xspf-open' path `/home/pi/.local/share/vlc/ml.xspf'
[0xa21738] main input debug: creating demux: access='file' demux='xspf-open' location='/home/pi/.local/share/vlc/ml.xspf' file='/home/pi/.local/share/vlc/ml.xspf'
[0x8c8fc8] main demux debug: looking for access_demux module: 3 candidates
[0x8c8fc8] main demux debug: no access_demux module matching "file" could be loaded
[0x8c8fc8] main demux debug: TIMER module_need() : 28.448 ms - Total 28.448 ms / 1 intvls (Avg 28.448 ms)
[0xa21738] main input debug: creating access 'file' location='/home/pi/.local/share/vlc/ml.xspf', path='/home/pi/.local/share/vlc/ml.xspf'
[0x94ec18] main access debug: looking for access module: 2 candidates
[0x94ec18] filesystem access debug: opening file `/home/pi/.local/share/vlc/ml.xspf'
[0x94ec18] main access debug: using access module "filesystem"
[0x94ec18] main access debug: TIMER module_need() : 19.304 ms - Total 19.304 ms / 1 intvls (Avg 19.304 ms)
[0x94e078] main stream debug: Using stream method for AStream*
[0x94e078] main stream debug: starting pre-buffering
[0x94e078] main stream debug: received first data after 0 ms
[0x94e078] main stream debug: pre-buffering done 296 bytes in 0s - 646 KiB/s
[0x94e268] main stream debug: looking for stream_filter module: 7 candidates
[0x94e268] main stream debug: no stream_filter module matching "any" could be loaded
[0x94e268] main stream debug: TIMER module_need() : 22.248 ms - Total 22.248 ms / 1 intvls (Avg 22.248 ms)
[0x94e268] main stream debug: looking for stream_filter module: 1 candidate
[0x94e268] main stream debug: using stream_filter module "stream_filter_record"
[0x94e268] main stream debug: TIMER module_need() : 8.339 ms - Total 8.339 ms / 1 intvls (Avg 8.339 ms)
[0xa21738] main input debug: creating demux: access='file' demux='xspf-open' location='/home/pi/.local/share/vlc/ml.xspf' file='/home/pi/.local/share/vlc/ml.xspf'
[0x9516d8] main demux debug: looking for demux module: 1 candidate
[0x9516d8] playlist demux debug: using XSPF playlist reader
[0x9516d8] main demux debug: using demux module "playlist"
[0x9516d8] main demux debug: TIMER module_need() : 8.016 ms - Total 8.016 ms / 1 intvls (Avg 8.016 ms)
[0x9507b8] main demux meta debug: looking for meta reader module: 2 candidates
[0x9507b8] lua demux meta debug: Trying Lua scripts in /home/pi/.local/share/vlc/lua/meta/reader
[0x9507b8] lua demux meta debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/reader
[0x9507b8] lua demux meta debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/reader/filename.luac
[0x9507b8] lua demux meta debug: Trying Lua scripts in /usr/share/vlc/lua/meta/reader
[0x9507b8] main demux meta debug: no meta reader module matching "any" could be loaded
[0x9507b8] main demux meta debug: TIMER module_need() : 101.935 ms - Total 101.935 ms / 1 intvls (Avg 101.935 ms)
[0xa21738] main input debug: `file/xspf-open:///home/pi/.local/share/vlc/ml.xspf' successfully opened
[0x944528] main xml reader debug: looking for xml reader module: 1 candidate
[0x944528] main xml reader debug: using xml reader module "xml"
[0x944528] main xml reader debug: TIMER module_need() : 31.254 ms - Total 31.254 ms / 1 intvls (Avg 31.254 ms)
[0x9516d8] playlist demux debug: parsed 0 tracks successfully
[0xa21738] main input debug: EOF reached
[0x9516d8] main demux debug: removing module "playlist"
[0x94e268] main stream debug: removing module "stream_filter_record"
[0x94ec18] main access debug: removing module "filesystem"
[0xa21738] main input debug: TIMER input launching for 'Media Library' : 209.790 ms - Total 209.790 ms / 1 intvls (Avg 209.790 ms)
[0x94e078] main interface debug: looking for interface module: 1 candidate
[0x94e078] main interface debug: using interface module "hotkeys"
[0x94e078] main interface debug: TIMER module_need() : 10.820 ms - Total 10.820 ms / 1 intvls (Avg 10.820 ms)
[0xa21738] main interface debug: looking for interface module: 1 candidate
[0x93d568] main playlist debug: playlist threads correctly activated
[0xa21738] main interface debug: using interface module "inhibit"
[0xa21738] main interface debug: TIMER module_need() : 22.146 ms - Total 22.146 ms / 1 intvls (Avg 22.146 ms)
[0x93d568] main playlist debug: adding item `stdin' ( stream:///dev/stdin )
[0x93d568] main playlist debug: rebuilding array of current - root Playlist
[0x93d568] main playlist debug: rebuild done - 0 items, index -1
[0x8c7f58] main interface debug: looking for interface module: 1 candidate
[0x8d6800] main input debug: Creating an input for 'stdin'
[0x93d568] main playlist debug: meta ok for (null), need to fetch art
[0x8c8d48] main demux meta debug: looking for meta fetcher module: 1 candidate
[0x8c8d48] lua demux meta debug: Trying Lua scripts in /home/pi/.local/share/vlc/lua/meta/fetcher
[0x8c8d48] lua demux meta debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/fetcher
[0x8c8d48] lua demux meta debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/fetcher/tvrage.luac
[0x8c7f58] main interface debug: using interface module "globalhotkeys"
[0x8c7f58] main interface debug: TIMER module_need() : 38.964 ms - Total 38.964 ms / 1 intvls (Avg 38.964 ms)
[0x8d55b0] main interface debug: looking for interface module: 1 candidate
[0x8d55b0] dummy interface: using the dummy interface module...
[0x8d55b0] main interface debug: using interface module "dummy"
[0x8d55b0] main interface debug: TIMER module_need() : 19.675 ms - Total 19.675 ms / 1 intvls (Avg 19.675 ms)
[0x8c8d48] main demux meta debug: using meta fetcher module "lua"
[0x8c8d48] main demux meta debug: TIMER module_need() : 45.335 ms - Total 45.335 ms / 1 intvls (Avg 45.335 ms)
[0x8c8d48] main demux meta debug: removing module "lua"
[0x93d568] main playlist debug: searching art for stdin
[0x8c8bd8] main art finder debug: looking for art finder module: 2 candidates
[0x93d568] main playlist debug: rebuilding array of current - root Playlist
[0x93d568] main playlist debug: rebuild done - 1 items, index -1
[0x93d568] main playlist debug: processing request item: null, node: Playlist, skip: 0
[0x93d568] main playlist debug: starting playback of the new playlist item
[0x93d568] main playlist debug: resyncing on stdin
[0x93d568] main playlist debug: stdin is at 0
[0x93d568] main playlist debug: creating new input thread
[0x9455d0] main input debug: Creating an input for 'stdin'
[0x8c8bd8] lua art finder debug: Trying Lua scripts in /home/pi/.local/share/vlc/lua/meta/art
[0x8c8bd8] lua art finder debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/art
[0x8c8bd8] lua art finder debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/00_musicbrainz.luac
[0x945108] main stream output debug: using sout chain=`standard{access=http,mux=ts,dst=:8­160}'
[0x945108] main stream output debug: stream=`standard'
[0xa228d0] main stream out debug: looking for sout stream module: 1 candidate
[0xa228d0] main stream out debug: set config option: sout-standard-access to http
[0xa228d0] main stream out debug: set config option: sout-standard-mux to ts
[0xa228d0] main stream out debug: set config option: sout-standard-dst to :8­160
[0xb4d00538] main access out debug: looking for sout access module: 1 candidate
[0xb4d00538] main access out debug: net: listening to * port 8
[0x8c8bd8] lua art finder debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/01_googleimage.luac
[0x8c8bd8] lua art finder debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/02_frenchtv.luac
[0x8c8bd8] lua art finder debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/03_lastfm.luac
[0x8c8bd8] lua art finder debug: Trying Lua scripts in /usr/share/vlc/lua/meta/art
[0x8c8bd8] main art finder debug: no art finder module matching "any" could be loaded
[0x8c8bd8] main art finder debug: TIMER module_need() : 145.780 ms - Total 145.780 ms / 1 intvls (Avg 145.780 ms)
[0x93d568] main playlist debug: art not found for stdin
[0xb4d00538] main access out error: socket bind error (Permission denied)
[0xb4d00538] main access out debug: socket error: Address family not supported by protocol
[0xb4d00538] main access out error: cannot create socket(s) for HTTP host
[0xb4d00538] access_output_http access out error: cannot start HTTP server
[0xb4d00538] main access out debug: no sout access module matching "http" could be loaded
[0xb4d00538] main access out debug: TIMER module_need() : 157.528 ms - Total 157.528 ms / 1 intvls (Avg 157.528 ms)
[0xa228d0] stream_out_standard stream out error: no suitable sout access module for `http/ts://:8­160'
[0xa228d0] main stream out debug: no sout stream module matching "standard" could be loaded
[0xa228d0] main stream out debug: TIMER module_need() : 181.646 ms - Total 181.646 ms / 1 intvls (Avg 181.646 ms)
[0xa228d0] main stream out debug: destroying chain... (name=(null))
[0xa228d0] main stream out debug: destroying chain done
[0x945108] main stream output error: stream chain failed for `standard{access=http,mux=ts,dst=:8­160}'
[0x93d568] main playlist debug: finished input
[0x9455d0] main input error: cannot start stream output instance, aborting
[0x93d568] main playlist debug: dead input
[0x93d568] main playlist debug: changing item without a request (current 0/1)
[0x93d568] main playlist debug: nothing to play

new2rpi
Posts: 19
Joined: Sun Nov 23, 2014 7:53 pm
Location: Cambridge, UK

Re: Brand new camera module "No data received from sensor"

Sat Aug 08, 2015 1:43 pm

UPDATE: I changed the port and it is all working now!

Return to “Troubleshooting”