SlightyMiffedMax
Posts: 3
Joined: Wed May 27, 2015 3:48 pm

USB drive not automounting

Wed May 27, 2015 3:57 pm

Hey all,

I have a 5tb drive formatted to ext4 that I'm trying to get automounted on a new RasPi 2. It isn't automounting, though using umount -a works fine. Here;s my fstab entry:

Code: Select all

UUID=<too lazy to type> /media/plexmediadrive ext4 defaults,rw,auto 0 0
I have added rootdelay=60 to /boot/cmdline.txt, and it still isn't mounting.

Does anyone have any idea why this isn't working? I'd be grateful for any help.

Thanks

User avatar
MarkHaysHarris777
Posts: 1820
Joined: Mon Mar 23, 2015 7:39 am
Location: Rochester, MN
Contact: Website

Re: USB drive not automounting

Wed May 27, 2015 4:34 pm

Does the device show up in lsusb?
Does the device show up in /dev
Can you mount it manually?
[recheck your fstab entry]
When it does not mount automatically, what shows up in dmesg?
marcus
:ugeek:

SlightyMiffedMax
Posts: 3
Joined: Wed May 27, 2015 3:48 pm

Re: USB drive not automounting

Fri May 29, 2015 1:34 am

I think these are the only relevant parts of dmseg output

Code: Select all

[    4.328106] usb 1-1.2: new high-speed USB device number 5 using dwc_otg
[    4.471105] usb 1-1.2: New USB device found, idVendor=0bc2, idProduct=3322
[    4.481985] usb 1-1.2: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[    4.494140] usb 1-1.2: Product: Expansion Desk
[    4.503921] usb 1-1.2: Manufacturer: Seagate
[    4.511699] usb 1-1.2: SerialNumber: NA8E5RJC
[    4.521883] usb-storage 1-1.2:1.0: USB Mass Storage device detected
[    4.537982] scsi host0: usb-storage 1-1.2:1.0
[    4.966200] random: nonblocking pool is initialized
[    5.058127] usbcore: registered new interface driver rtl8192cu
[    5.538862] scsi 0:0:0:0: Direct-Access     Seagate  Expansion Desk   9401 PQ: 0 ANSI: 6
[    5.553641] sd 0:0:0:0: [sda] Spinning up disk...
and

Code: Select all

[   18.688718] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[   18.689143] sd 0:0:0:0: [sda] 9767541167 512-byte logical blocks: (5.00 TB/4.54 TiB)
[   18.718490] sd 0:0:0:0: [sda] Write Protect is off
[   18.718527] sd 0:0:0:0: [sda] Mode Sense: 4f 00 00 00
[   18.719198] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   18.721098] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[   18.836305]  sda: sda1
[   18.839328] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[   18.841000] sd 0:0:0:0: [sda] Attached SCSI disk
The drive does show up in lsusb and as /dev/sda /sda1. I can mount the drive manually, as well as through sudo mount -a.

User avatar
rpdom
Posts: 16087
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: USB drive not automounting

Fri May 29, 2015 5:34 am

It is possible that the drive isn't ready by the time the Pi has booted.

Try adding "rootdelay=5" to the kernel command line in /boot/cmdline.txt to make the system wait 5 seconds during the boot.
(All the options in that file are on one line, separated by spaces. The position in the line isn't important)

By the way, the "rw" and "auto" options are included in "defaults", so you don't need to put those in your fstab.

SlightyMiffedMax
Posts: 3
Joined: Wed May 27, 2015 3:48 pm

Re: USB drive not automounting

Fri May 29, 2015 2:09 pm

Ah ha! All of the options have to be on one line. I was hoping for a simple solution, and there it is. Drive is automounting fine now.

Thanks so much!

rubikwizard
Posts: 95
Joined: Tue Jan 10, 2012 10:37 pm
Location: West Yorkshire
Contact: Website

Re: USB drive not automounting

Fri May 29, 2015 8:43 pm

Does anyone have any idea why this isn't working? I'd be grateful for any help.
The version of Rasbian (5/5/2015) has a known issue that stops mounts from etc/fstab during bootup. As a workaround you can add "mount -a" to the end of the file /etc/rc.local (before the line "exit 0"), and it will work again.

User avatar
rpdom
Posts: 16087
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: USB drive not automounting

Fri May 29, 2015 9:15 pm

rubikwizard wrote:
Does anyone have any idea why this isn't working? I'd be grateful for any help.
The version of Rasbian (5/5/2015) has a known issue that stops mounts from etc/fstab during bootup. As a workaround you can add "mount -a" to the end of the file /etc/rc.local (before the line "exit 0"), and it will work again.
That issue only affects network mounts. It has nothing to with USB drives, as can be seen in this thread where the problem is solved.

Return to “Troubleshooting”