m4r35n357
Posts: 25
Joined: Fri Jul 06, 2012 4:31 pm

RPi2 low desktop resolution (solved)

Wed Mar 18, 2015 8:35 pm

I'm only getting 1776x952 in the Raspbian desktop. My older model Bs can do full HD. Looks like fbset is to blame. An ideas how to fix this? I've tried putting a config.txt with

Code: Select all

hdmi_group=1
hdmi_mode=16
to no avail (there was no config.txt before).

SYSTEM INFO:

Code: Select all

pi@raspberrypi ~ $ tvservice -m CEA && tvservice -m DMT
Group CEA has 16 modes:
           mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive 
           mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive 
           mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive 
           mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive 
           mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 
           mode 6: 720x480 @ 60Hz 4:3, clock:27MHz x2 interlaced 
           mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced 
  (prefer) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive 
           mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive 
           mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive 
           mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive 
           mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced 
           mode 21: 720x576 @ 50Hz 4:3, clock:27MHz x2 interlaced 
           mode 22: 720x576 @ 50Hz 16:9, clock:27MHz x2 interlaced 
           mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive 
           mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive 
Group DMT has 4 modes:
           mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive 
           mode 9: 800x600 @ 60Hz 4:3, clock:40MHz progressive 
           mode 16: 1024x768 @ 60Hz 4:3, clock:65MHz progressive 
           mode 35: 1280x1024 @ 60Hz 5:4, clock:108MHz progressive 
pi@raspberrypi ~ $ tvservice -s
state 0x12001a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive
pi@raspberrypi ~ $ fbset

mode "1776x952"
    geometry 1776 952 1776 952 16
    timings 0 0 0 0 0 0 0
    rgba 5/11,6/5,5/0,0/16
endmode



gordon77
Posts: 4233
Joined: Sun Aug 05, 2012 3:12 pm

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 9:27 pm

Are you sure there was no config.txt in /boot ?

User avatar
AndyD
Posts: 2331
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 9:41 pm

m4r35n357 wrote:...to no avail (there was no config.txt before)...
Are you using Raspbian via NOOBS?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5341
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 9:48 pm

Try running

Code: Select all

sudo raspi-config
and disabling overscan.

m4r35n357
Posts: 25
Joined: Fri Jul 06, 2012 4:31 pm

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 10:03 pm

Thanks for the replies, I can confirm that there was definitely no config.txt to start with, and yes I'm running Noobs. Disabling overscan made no difference, the monitor settings dialogue in the desktop preferences still only allows 1776x952 (or auto, again no difference).

User avatar
xoopha
Posts: 106
Joined: Mon Feb 09, 2015 9:52 pm

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 10:08 pm

Did you reboot? The firmware just doesn't allow resolution change on the fly, you are locked to whatever resolution you boot with.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5109
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 10:11 pm

m4r35n357 wrote:Thanks for the replies, I can confirm that there was definitely no config.txt to start with, and yes I'm running Noobs. Disabling overscan made no difference, the monitor settings dialogue in the desktop preferences still only allows 1776x952 (or auto, again no difference).
NOOBS itself doesn't have a config.txt file but creates one for each O.S. it installs. Hence you may not have created/edited the "correct" file (in the right place). The recommended way to do so is to use NOOBS' own editor from its recovery mode (as shown in the link below, albeit for an old version):
http://www.cpmspectrepi.webspace.virgin ... ting_Tools
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, A+ and a B2) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

m4r35n357
Posts: 25
Joined: Fri Jul 06, 2012 4:31 pm

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 10:15 pm

I didn't select Raspbian, it just booted into it straight away. I've gone into the rescue mode and the editor is greyed out. That is the first time I have seen the other OSs listed . . .

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5109
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 10:22 pm

m4r35n357 wrote:I didn't select Raspbian, it just booted into it straight away. I've gone into the rescue mode and the editor is greyed out. That is the first time I have seen the other OSs listed . . .
Strange** - was this a "pre-installed card" or did you create it yourself? What version of NOOBS? (The current version is 1.4)
Trev.
** It is possible for that behaviour to be enabled, but it's not (shouldn't be) the default:
https://github.com/raspberrypi/noobs#ho ... tall-an-os
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, A+ and a B2) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

m4r35n357
Posts: 25
Joined: Fri Jul 06, 2012 4:31 pm

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 10:32 pm

OK, it's starting to look like I have a bad install, so I'm reinstalling. I'll post back when I have tried that.

m4r35n357
Posts: 25
Joined: Fri Jul 06, 2012 4:31 pm

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 10:33 pm

er, yes it was a preloaded card.

User avatar
DougieLawson
Posts: 36322
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 10:36 pm

xoopha wrote:Did you reboot? The firmware just doesn't allow resolution change on the fly, you are locked to whatever resolution you boot with.
That's not entirely true. You can change things on the fly with the tvservice command.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

m4r35n357
Posts: 25
Joined: Fri Jul 06, 2012 4:31 pm

Re: RPi2 low desktop resolution

Wed Mar 18, 2015 10:44 pm

hmm, just reinstalled (it's Noobs 1.4 BTW) and I have a config.txt file but the desktop is still stuck at 1776x952.
Not sure why the new model should be any different to the old ones, or why fbdev is set to 1776x952, or why my default HDMI display seems to be correct but isn't used. Anyway, it's late now so I'll have to look at this another time . . .

m4r35n357
Posts: 25
Joined: Fri Jul 06, 2012 4:31 pm

Re: RPi2 low desktop resolution

Thu Mar 19, 2015 7:41 pm

Looks to be sorted now, I've got a config.txt and set up the framebuffer and HDMI manually. The desktop now reports 1920x1080.
Thanks to all for the help, BTW I eventually found http://elinux.org/RPiconfig which I'd forgotten about.

calpolee
Posts: 2
Joined: Sun Apr 12, 2015 4:30 am

Re: RPi2 low desktop resolution

Sun Apr 12, 2015 4:35 am

I'm running into the same issue with only getting 1776x952. What did you configure to get 1920x1080 working? I think I might be running into the same issues you were. I did already have a config.txt in /boot.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5341
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: RPi2 low desktop resolution

Sun Apr 12, 2015 12:27 pm

dom wrote:Try running

Code: Select all

sudo raspi-config
and disabling overscan.

m4r35n357
Posts: 25
Joined: Fri Jul 06, 2012 4:31 pm

Re: RPi2 low desktop resolution

Sun Apr 12, 2015 12:31 pm

Code: Select all

framebuffer_width=1920
framebuffer_height=1080

hdmi_group=1
hdmi_mode=16

disable_overscan=1
I think that's it , you might have to look up your hdmi_mode setting . . .

calpolee
Posts: 2
Joined: Sun Apr 12, 2015 4:30 am

Re: RPi2 low desktop resolution

Sun Apr 12, 2015 11:42 pm

Thanks much. I had done all but setting disabling overscan so I will give that a go.

Return to “Troubleshooting”