Dumbnoob
Posts: 7
Joined: Sat Jul 29, 2017 2:15 pm

Re: Edimax EW-7811UTC Raspbian

Sat Jul 29, 2017 2:30 pm

Hi,

I'm running retropie built on the most recent version of raspbian Jessie (linux 4.9.35-v7+) on a pi 3b. I was able to get the 8812au driver installed, but I got some errors and it appears to have not worked properly. I can scan for networks with my dongle properly in WICD-CURSES, but it refuses to connect to any of the networks. Can anyone verify the driver set I should be downloading and the process for reinstalling? Thank you!

MrEngman
Posts: 3844
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC Raspbian

Sat Jul 29, 2017 6:52 pm

Dumbnoob wrote:
Sat Jul 29, 2017 2:30 pm
Hi,

I'm running retropie built on the most recent version of raspbian Jessie (linux 4.9.35-v7+) on a pi 3b. I was able to get the 8812au driver installed, but I got some errors and it appears to have not worked properly. I can scan for networks with my dongle properly in WICD-CURSES, but it refuses to connect to any of the networks. Can anyone verify the driver set I should be downloading and the process for reinstalling? Thank you!
I'm running the 8812au driver on a couple of Pi's, a Pi 2b and EW-7811UTC, and a Pi B+ with Asus USB-AC56 with no problems. I have also run the EW-7811UTC on a Pi 3B without issues.

What wifi adapter are you using - the EW-7811UTC? How did you install the driver? Did you use the driver I compile or did you compile your own? What errors did you get? How is your wifi set up and what about the Broadcom wifi built in to the Pi 3B?

Just saying things don't work is not very useful.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Dumbnoob
Posts: 7
Joined: Sat Jul 29, 2017 2:15 pm

Re: Edimax EW-7811UTC Raspbian

Sat Jul 29, 2017 7:07 pm

MrEngman wrote:
Sat Jul 29, 2017 6:52 pm
What wifi adapter are you using - the EW-7811UTC? How did you install the driver? Did you use the driver I compile or did you compile your own? What errors did you get? How is your wifi set up and what about the Broadcom wifi built in to the Pi 3B?

Just saying things don't work is not very useful.
Sorry I couldn't leave more details, I was away from my pi.

1) The wireless adapter is an ourlink AC600, which, as I understand it, uses the 8812 chipset; https://www.ourlink.us/collections/some ... hz-433mbps

2) The instructions I used can be found here: https://layereight.de/raspberry-pi/2016 ... 812au.html ; the instructions are:

Code: Select all

$ # install necessary software
$ sudo apt-get update
$ sudo apt-get install bc git
$ 
$ # download raspbian kernel sources, takes some minutes
$ sudo wget "https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source" -O /usr/bin/rpi-source
$ sudo chmod 755 /usr/bin/rpi-source
$ rpi-source
$ 
$ # download the rtl8812au kernel driver and compile it, takes some minutes
$ git clone "https://github.com/gnab/rtl8812au"
$ cd rtl8812au
$ sed -i 's/CONFIG_PLATFORM_I386_PC = y/CONFIG_PLATFORM_I386_PC = n/g' Makefile
$ sed -i 's/CONFIG_PLATFORM_ARM_RPI = n/CONFIG_PLATFORM_ARM_RPI = y/g' Makefile
$ make
$ # copy the driver and use it
$ sudo cp 8812au.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless
$ sudo depmod -a
$ sudo modprobe 8812au
$ 
$ # check wlan0 interface appeared
$ ifconfig
$ iwconfig
However, I did encounter a permission error when running the make command that I suspect might have led to some problems with the install.

3) The rest of the Wifi setup and the Broadcom chip work smoothly with no discernible issues except for a much noisier/slower signal than the 5ghz network due to apartment congestion.

Edit: I instaled using the compiled version you posted on your site. The install went smoothly, but it doesn't seem to be functioning still. When I try to get started with setting up wifi, I get:

Code: Select all

sudo ifup wlan1
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan1.

MrEngman
Posts: 3844
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC Raspbian

Sat Jul 29, 2017 8:29 pm

Dumbnoob wrote:
Sat Jul 29, 2017 7:07 pm

Edit: I instaled using the compiled version you posted on your site. The install went smoothly, but it doesn't seem to be functioning still. When I try to get started with setting up wifi, I get:

Code: Select all

sudo ifup wlan1
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan1.
This error would suggest there may be a problem with one of the wifi config files, either /etc/network/interfaces or /etc/wpa_supplicant/wpa_supplicant.conf. If you can post the output of these two files I can check if they are look OK or not. Can you also post the USB id of your wifi as I cannot find any reference on the internet.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Dumbnoob
Posts: 7
Joined: Sat Jul 29, 2017 2:15 pm

Re: Edimax EW-7811UTC Raspbian

Sat Jul 29, 2017 8:44 pm

Thanks for helping.

Gonna go backwards with what you asked for here:

1) The info from #lsusb for the receiver is:

Bus 001 Device 006: ID 0bda:a811 Realtek Semiconductor Corp.

2) the config for /network/interfaces contains:

Code: Select all

# interfaces(6) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
3) The config for wpa_supplicant.conf contains :

Code: Select all

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
# RETROPIE CONFIG START
network={
        ssid="FBI Homicide Division Van 2.4"
        psk="###REDACTED PASSWORD###"
}
# RETROPIE CONFIG END

MrEngman
Posts: 3844
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC Raspbian

Sat Jul 29, 2017 10:22 pm

Dumbnoob wrote:
Sat Jul 29, 2017 8:44 pm
Thanks for helping.

Gonna go backwards with what you asked for here:

1) The info from #lsusb for the receiver is:

Bus 001 Device 006: ID 0bda:a811 Realtek Semiconductor Corp.

2) the config for /network/interfaces contains:

Code: Select all

# interfaces(6) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
3) The config for wpa_supplicant.conf contains :

Code: Select all

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
# RETROPIE CONFIG START
network={
        ssid="FBI Homicide Division Van 2.4"
        psk="###REDACTED PASSWORD###"
}
# RETROPIE CONFIG END
Looks pretty much like my configuration. I have connected a wifi using the 8812au driver to my Pi 3B and it works fine with my driver. The 3B currently has 3 wifi adapters connected, the built in Broadcom, a TP-Link TL-WN725N using the 8188eu driver and an Asus USB-AC56 using the 8812au driver.

Your configuration is similar to mine so I'm not sure why you are getting the error although if that is the SSID you are using that may be the problem. AFAIA the SSID should only use alphanumeric characters so shouldn't use spaces or periods.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Dumbnoob
Posts: 7
Joined: Sat Jul 29, 2017 2:15 pm

Re: Edimax EW-7811UTC Raspbian

Sat Jul 29, 2017 10:34 pm

Hmm. I'm going to roll back to a backup and see if I can get it working there. The SSID has never been a problem for the original broadcom chipset, so I highly doubt that is the issue. Retropie must have entered that text into the file automatically, seems fine.

Dumbnoob
Posts: 7
Joined: Sat Jul 29, 2017 2:15 pm

Re: Edimax EW-7811UTC Raspbian

Sun Jul 30, 2017 12:03 am

Rolled back and the wpa_supplicant is still behaving strangely. Crap. Let me ask a silly question. All I ran to install the driver was

Code: Select all

wget http://fars-robotics.net/8812au-4.4.50-v7-970.tar.gz
tar xzf 8812au-4.4.50-v7-970.tar.gz
./install.sh
Was there something else that I needed to run? I thought was was odd that I didn't need to modprobe anything.

MrEngman
Posts: 3844
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC Raspbian

Sun Jul 30, 2017 1:21 pm

I've created an SD card with the Retropie image and have the 8812au driver running with the Asus USB-AC56 wifi module.

I got an SD card and copied the retropie-4.2-rpi2_rpi3.img to it using Win32DiskImager. Plugged it into my Pi 3B. Connected a keyboard, mouse, the Asus wifi and a USB card reader to the Pi and powered on.

Booted OK and came up with the WELCOME screen. I don't have a gamepad so I quit using key F4 and entered the command line interface. I then set up the wifi. First I got one of my other SD cards from another Pi and plugged it into the card reader, mounted the SD card on the /mnt directory and copied the file /mnt/etc/wpa_supplicant/wpa_supplicant.conf from the card in the card reader to the file /etc/wpa_supplicant/wpa_supplicant.conf on the Pi 3B reptropie card. I then downloaded and installed the 8812au driver using the commands you showed in your post above.

I also ran command sudo raspi-config and enabled SSH and set my timezone as I usually do. Then I rebooted.

Pi 3B rebooted and came up with the WELCOME screen again.

On another PC I checked the devices connected to the network and it showed the Pi 3B running retropie twice, the built in Broadcom wifi and the USB Asus wifi running the 8812au driver were both connected. No issues with wpa_supplicant.conf.

So both wifi's working but essentially I did not use Retropie to set up the wifi.

I tried setting up Retropie using the keyboard to emulate a gamepad but after configuring all the settings it just got stuck and would not continue except if I pressed F4 which took me to the command line screen.

So not sure what the problem I have is, and doesn't seem to help determining the issue you have I'm afraid, except the 8812au drive does work.

Just wondering if it may possibly be an issue with WICD. I never use that.

I usually check wifi is working using commands like sudo iwlist wlan0 scan or wlan1 etc.

Sorry it doesn't help sort your problem but at least it shows the wifi should probably work.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

MrEngman
Posts: 3844
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC Raspbian

Sun Jul 30, 2017 2:17 pm

Finally figured out how to exit the welcome screen after setting up the gamepad configuration using the keyboard rather than a real gamepad - just needed to press the right key on the keyboard.

I now see the Retropie EmulationStation page and additional configurations. Enter the wifi setup and it shows wifi is connected. I then disabled the built in wifi driver and restarted and now retropie shows I am connected to the wifi using the Asus wifi with the 8812au driver.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Dumbnoob
Posts: 7
Joined: Sat Jul 29, 2017 2:15 pm

Re: Edimax EW-7811UTC Raspbian

Sun Jul 30, 2017 4:53 pm

Thanks for testing to see if retopie works! Sorry for the frustrating interface, generally, you move forward with the "A" button that you assigned and backwards with the "b" button that you assigned. On keyboard I usually set it so that to spacebar=forward and b = back.

So I was able to rebuild the wpa_supplicant file without much trouble by refollowing the instructions that I originally followed, the ones you used. The problem is gone now, for whatever reasons. Here's where I'm at:

I was able to get the Wlan1 receiver, the dongle, working. Yay! The problem is that it only connects to the 2.4ghz network. The 5ghz network does not seem to want to connect when I try to log in via wpa_config, even though it will properly detect the network.

Can you verify two things: What version of the 8812au driver do you have installed? And, have you confirmed that you can actually connect to a 5ghz network, instead of just scanning for them?

MrEngman
Posts: 3844
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC Raspbian

Sun Jul 30, 2017 5:07 pm

I have a Pi 2B using an Edimax EW-7811UTC and a Pi 3B using an Asus USB-AC56. Both are using 5GHz.

The source I use to compile my drivers is from here https://github.com/diederikdehaas/rtl8812AU
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Dumbnoob
Posts: 7
Joined: Sat Jul 29, 2017 2:15 pm

Re: Edimax EW-7811UTC Raspbian

Mon Jul 31, 2017 2:05 am

I think I got it, with one small issue. I've recapped what I did below for others with this issue. The current issue is that the bit rate registers as 150 mb/s; but it should be 433mb/s when connected to a 5ghz network. Not sure how to fix that right now.

Your hint of doing all connections manually was what gave me the idea. Here's what I did to get the Ourlink AC600 working in retropie:
1) Install the drivers according to this code:

Code: Select all

 sudo apt-get update
sudo apt-get install bc git


sudo wget "https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source" -O /usr/bin/rpi-source
sudo chmod 755 /usr/bin/rpi-source
rpi-source
 

git clone "https://github.com/diederikdehaas/rtl8812AU"
 cd rtl8812AU
 sed -i 's/CONFIG_PLATFORM_I386_PC = y/CONFIG_PLATFORM_I386_PC = n/g' Makefile
 sed -i 's/CONFIG_PLATFORM_ARM_RPI = n/CONFIG_PLATFORM_ARM_RPI = y/g' Makefile
 make

 sudo cp 8812au.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless
 sudo depmod -a
 sudo modprobe 8812au
2) DO NOT USE WICD-CURSES or WPA-CLI. Instead:

Code: Select all

sudo nano /etc/network/interfaces


### The file's contents should look like this:
auto lo

iface lo inet loopback
iface eth0 inet dhcp

##[IGNORE ALL wlan0 stuff]

allow-hotplug wlan1
iface wlan1 inet dhcp
   wpa-ssid "NETWORK_NAME"
   wpa-psk "NETWORK_PASSWORD"
3) reboot. iwconfig should show you connected to the network you just specified for the dongle. However, it might also show you connected to a different network via the internal broadcom chip. Odd! To fix this, I just killed the wlan process on boot entirely. There is probably a more elegant solution:

Code: Select all

sudo nano /etc/rc.local
#Add this anywhere before the "exit 0 phrase"
ifconfig wlan0 down
Done!

code-it-felix
Posts: 1
Joined: Tue Dec 05, 2017 3:51 pm

Re: Edimax EW-7811UTC Raspbian

Tue Dec 05, 2017 3:55 pm

MrEngman wrote:
Thu Jun 04, 2015 5:07 pm
dtown123 wrote:Thank you for having consistent file naming conventions!

I was able to get the Edimax AC600 working using Pi B and kernel 3.18.14+ #793 using this driver:

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8812au-3.18.14-793.tar.gz
tar xzf 8812au-3.18.14-793.tar.gz
./install.sh
Hi,

Glad to be able to help.

FYI I try to update the drivers whenever a new version/build appears. I currently compile drivers for 8188eu, 8192eu, 8812au and mt7601 adapters all using the same file format and install method.


MrEngman
Mr.Engman,

Do you have the the link to the latest driver for Linux raspberrypi 4.9.24-v7+ #993"? "wget https://dl.dropboxusercontent.com/u/802 ... 993.tar.gz" is returning a 404 response.

TomBoland
Posts: 1
Joined: Tue Dec 26, 2017 6:55 pm

Re: Edimax EW-7811UTC Raspbian

Tue Dec 26, 2017 7:20 pm

I just picked up an EdiMax Ew-7811utc for Christmas to use as a 5gHz dongle for my Raspberry PI 2B. It worked, but I did have to compile the driver. EdiMax has a page specifically for this. It works. Open that up and do what it says.

I created a script for that procedure. Use at your own peril, and use in conjunction with the EdiMax link.

[*] Copy the script to /home/pi
[*] Run it as the pi user with ./ew7811.sh
[*] It will reboot twice as part of the procedure. Log back in and rerun ./ew7811.sh each time. It uses a flag to figure out where it left off last time.
[*] You will be asked to inspect a directory listing for the build directory. If it does not exist at this point, something failed. Use the EdiMax procedure to fix it.
[*]After finding the build directory, run ./ew7811.sh one more time. This is the big one. Once the make starts, it's going to take some time.
[*] Once you get dumped back to a command prompt, you are done with the driver compile and install. You would still have to make sure that your /etc/wpa-supplicant/wpa-supplicant.conf file is correct and connecting to a 5gHz network SSID.

If you are going to use the EdiMax procedure, change ./rpi-source to ./rpi-source --skip-gcc. This disables a version check on gcc, which can often be in conflict with the stated system. My system is updated completely and this is a known issue sometimes.

ew7811.sh

Code: Select all

#!/bin/bash
cd ~
if [ ! -f ~/ew7811.flag ]; then
    echo "0" > ~/ew7811.flag
fi
flag=$(cat ~/ew7811.flag)
if [ "$flag" == "0" ]
then
 echo "Cleaning up old install, if needed"
 if [  -d ~/rpi-source ]; then
  sudo rm -Rf ~/rpi-source
 fi
 if [  -d ~/rtl8812AU ]; then
  sudo rm -Rf ~/rtl8812AU
 fi
 echo "Updating and Upgrading"
 sudo apt-get -y update
 sudo apt-get -y upgrade
 sudo apt-get -y dist-upgrade
 echo "1" > ~/ew7811.flag
 sudo reboot
fi
if [ "$flag" == "1" ]
then
 echo "rpi-update"
 sudo rpi-update
 echo "2" > ~/ew7811.flag
 sudo reboot
fi
if [ "$flag" == "2" ]
then
 echo "git rpi-source"
 git clone https://github.com/notro/rpi-source.git
 echo "Adding libncurses if needed"
 cd rpi-source
 chmod +x rpi-source
 sudo apt-get -y install libncurses5-dev
 echo "Running rpi-source. Long process"
 sudo ./rpi-source --skip-gcc
 cd ..
 echo "3" > ~/ew7811.flag
 echo "Check for build/ directory. Important"
 ls /lib/modules/$(uname -r)/
fi
if [ "$flag" == "3" ]
then
 echo "git the driver, finally"
 git clone https://github.com/diederikdehaas/rtl8812AU.git
 cd rtl8812AU
 echo "Modify the Makefile for pi vs default 1386 platform"
 sed -i 's/CONFIG_PLATFORM_I386_PC = y/CONFIG_PLATFORM_I386_PC = n/g' Makefile
 sed -i 's/CONFIG_PLATFORM_ARM_RPI = n/CONFIG_PLATFORM_ARM_RPI = y/g' Makefile
 echo "Finally make. Long Long Long process."
 sudo make
 echo "make install. Pretty quick."
 sudo make install
 rm ~/ew7811.flag
fi

AaronLiang
Posts: 1
Joined: Wed Mar 27, 2019 8:50 am

Re: Edimax EW-7811UTC Raspbian

Wed Mar 27, 2019 8:53 am

I need the driver for my new RPi3
The kernel version is list below.
Thanks for your help.

Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/

-- Aaron

MrEngman
Posts: 3844
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC Raspbian

Wed Mar 27, 2019 10:38 am

AaronLiang wrote:
Wed Mar 27, 2019 8:53 am
I need the driver for my new RPi3
The kernel version is list below.
Thanks for your help.

Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/

-- Aaron
I have a variety of different drivers available at http://downloads.fars-robotics.net/wifi-drivers including the 8812au driver.

Try this

Code: Select all

wget http://downloads.fars-robotics.net/wifi-drivers/8812au-drivers/8812au-4.14.98-v7-1200.tar.gz
tar xzf 8812au-4.14.98-v7-1200.tar.gz
install.sh
MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

stewhar
Posts: 3
Joined: Wed Jul 03, 2019 7:26 pm

Re: Edimax EW-7811UTC Raspbian

Wed Jul 03, 2019 7:44 pm

Hello Mr Engman,

I've tried using one of your drivers... following the examples you give to other people but I've (probably inevitably) ran into a problem.

Linux mediapc-001 4.19.50-v7+ #896 SMP Thu Jun 20 16:11:44 BST 2019 armv7l GNU/Linux I have the latest Raspbian running on raspi 3+

I ran the following:

wget http://downloads.fars-robotics.net/wifi ... 234.tar.gz
tar xzf 8812au-4.19.50-v7-1234.tar.gz
./install.sh

Success (or so I thought) I can see my 5G network but can't connect. I've checked the wpa_supplicant.conf file and everything is correct in there.

My dongle has an external antenna connection but I don't think that matters (it uses the same chipset etc., I believe) lsusb shows... Bus 001 Device 008: ID 7392:a812 Edimax Technology Co., Ltd

Did I install the wrong file, could you help, please?

Will I need to uninstall anything?

Many thanks,
Steven.

MrEngman
Posts: 3844
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC Raspbian

Wed Jul 03, 2019 11:31 pm

stewhar wrote:
Wed Jul 03, 2019 7:44 pm
Hello Mr Engman,

I've tried using one of your drivers... following the examples you give to other people but I've (probably inevitably) ran into a problem.

Linux mediapc-001 4.19.50-v7+ #896 SMP Thu Jun 20 16:11:44 BST 2019 armv7l GNU/Linux I have the latest Raspbian running on raspi 3+

I ran the following:

wget http://downloads.fars-robotics.net/wifi ... 234.tar.gz
tar xzf 8812au-4.19.50-v7-1234.tar.gz
./install.sh

Success (or so I thought) I can see my 5G network but can't connect. I've checked the wpa_supplicant.conf file and everything is correct in there.

My dongle has an external antenna connection but I don't think that matters (it uses the same chipset etc., I believe) lsusb shows... Bus 001 Device 008: ID 7392:a812 Edimax Technology Co., Ltd

Did I install the wrong file, could you help, please?

Will I need to uninstall anything?

Many thanks,
Steven.
Hi stewhar,

Just tried a wifi chip, Edimax EW-7811UTC, with the same USB ID, 7392:a812, you are using on a Pi 3A+ with the same kernel version, 4.19.50-v7+ #896, you are using and using the same driver file you tried, 8812au-4.19.50-v7-1234.tar.gz, and all is working fine.

Just one slight oddity, the built in wifi is not working.

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

stewhar
Posts: 3
Joined: Wed Jul 03, 2019 7:26 pm

Re: Edimax EW-7811UTC Raspbian

Thu Jul 04, 2019 5:49 am

MrEngman wrote:
Wed Jul 03, 2019 11:31 pm

Hi stewhar,

Just tried a wifi chip, Edimax EW-7811UTC, with the same USB ID, 7392:a812, you are using on a Pi 3A+ with the same kernel version, 4.19.50-v7+ #896, you are using and using the same driver file you tried, 8812au-4.19.50-v7-1234.tar.gz, and all is working fine.

Just one slight oddity, the built in wifi is not working.

MrEngman

Ah great thanks, I wasn't expecting such a quick reply.

Interestingly my internal wifi is still working. The dongle does appear to be working but won't connect, I'm 100% sure the password is correct (I've entered it a couple of times and copied from the router). Also it is only picking up 5G networks and nothing else.

I actually tried the driver above the 1234 version before trying that one, because it wasn't working, maybe that has something to do with it?

Please let me know if there's any more information I can send you.

Out of curiosity... I've added a dvb-t dongle which was recognised with lsusb and to install all I had to do was add the firmware to the lib folder; why is this different?

I've noticed you've been helping users out with this for years so thanks, MrEngman, I appreciate your help.

Rgds,
Steven.

MrEngman
Posts: 3844
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC Raspbian

Thu Jul 04, 2019 10:24 pm

stewhar wrote:
Thu Jul 04, 2019 5:49 am
MrEngman wrote:
Wed Jul 03, 2019 11:31 pm

Hi stewhar,

Just tried a wifi chip, Edimax EW-7811UTC, with the same USB ID, 7392:a812, you are using on a Pi 3A+ with the same kernel version, 4.19.50-v7+ #896, you are using and using the same driver file you tried, 8812au-4.19.50-v7-1234.tar.gz, and all is working fine.

Just one slight oddity, the built in wifi is not working.

MrEngman

Ah great thanks, I wasn't expecting such a quick reply.

Interestingly my internal wifi is still working. The dongle does appear to be working but won't connect, I'm 100% sure the password is correct (I've entered it a couple of times and copied from the router). Also it is only picking up 5G networks and nothing else.

I actually tried the driver above the 1234 version before trying that one, because it wasn't working, maybe that has something to do with it?

Please let me know if there's any more information I can send you.

Out of curiosity... I've added a dvb-t dongle which was recognised with lsusb and to install all I had to do was add the firmware to the lib folder; why is this different?

I've noticed you've been helping users out with this for years so thanks, MrEngman, I appreciate your help.

Rgds,
Steven.
I now have my Pi 3A+ with both built in wifi and the EW-7811UTC wifi working.

First I created a set of wifi drivers by copying files with build #901 and #902 to files with build #895 and #896 to match the kernel versions in the original Buster image.

Then basically created a new SD card with the Buster lite image and added SSH and wpa_supplicant.conf files that I use in all my different Pi's to the boot partition. With the EW-7811UTC connected to the Pi I booted the Pi and the built in wifi connected without problems. Connected to the Pi using SSH and changed password and set a new host name and rebooted.

I then installed my install-wifi script using commands

Code: Select all

sudo wget http://downloads.fars-robotics.net/wifi-drivers/install-wifi -O /usr/bin/install-wifi
sudo chmod +x /usr/bin/install-wifi
and installed the 8812au driver using command

Code: Select all

sudo install-wifi
and the new driver installed and loaded and the EW-7811UTC started up and connected to my network straight away. So I had the built in wifi and 8812au wifi both connected to my 5GHz wifi.

Rebooted the Pi again and the Pi started with both wifi modules connecting to my network.

I have had the odd problem when wifi drivers start up but the wifi will not connect, often when moving an SD card from one Pi to another. This could be down to the fact that a wifi module has a lease file defined by the original Pi it was in and it causes a problem if trying to connect with a different lease when in the new Pi. Deleating the lease files and rebooting can fix the issue. Other times instead of rebooting first power off the pi and then power it up again and that could fix the issue. And other times changing the USB port a wifi module is connected to has fixed the problem. All rather odd issues and no obvious answer to why they occurred.

You could perhaps power off the Pi and remove the wifi dongle and power the Pi back up and then reconnect the wifi to the Pi and see what happens. Wifi issues could be caused by insufficient power which has most effect when the Pi is starting up after powering on. This can stop a wifi connecting.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

stewhar
Posts: 3
Joined: Wed Jul 03, 2019 7:26 pm

Re: Edimax EW-7811UTC Raspbian

Fri Jul 05, 2019 6:22 am

MrEngman wrote:
Thu Jul 04, 2019 10:24 pm
stewhar wrote:
Thu Jul 04, 2019 5:49 am
MrEngman wrote:
Wed Jul 03, 2019 11:31 pm

Hi stewhar,

Just tried a wifi chip, Edimax EW-7811UTC, with the same USB ID, 7392:a812, you are using on a Pi 3A+ with the same kernel version, 4.19.50-v7+ #896, you are using and using the same driver file you tried, 8812au-4.19.50-v7-1234.tar.gz, and all is working fine.

Just one slight oddity, the built in wifi is not working.

MrEngman

Ah great thanks, I wasn't expecting such a quick reply.

Interestingly my internal wifi is still working. The dongle does appear to be working but won't connect, I'm 100% sure the password is correct (I've entered it a couple of times and copied from the router). Also it is only picking up 5G networks and nothing else.

I actually tried the driver above the 1234 version before trying that one, because it wasn't working, maybe that has something to do with it?

Please let me know if there's any more information I can send you.

Out of curiosity... I've added a dvb-t dongle which was recognised with lsusb and to install all I had to do was add the firmware to the lib folder; why is this different?

I've noticed you've been helping users out with this for years so thanks, MrEngman, I appreciate your help.

Rgds,
Steven.
I now have my Pi 3A+ with both built in wifi and the EW-7811UTC wifi working.

First I created a set of wifi drivers by copying files with build #901 and #902 to files with build #895 and #896 to match the kernel versions in the original Buster image.

Then basically created a new SD card with the Buster lite image and added SSH and wpa_supplicant.conf files that I use in all my different Pi's to the boot partition. With the EW-7811UTC connected to the Pi I booted the Pi and the built in wifi connected without problems. Connected to the Pi using SSH and changed password and set a new host name and rebooted.

I then installed my install-wifi script using commands

Code: Select all

sudo wget http://downloads.fars-robotics.net/wifi-drivers/install-wifi -O /usr/bin/install-wifi
sudo chmod +x /usr/bin/install-wifi
and installed the 8812au driver using command

Code: Select all

sudo install-wifi
and the new driver installed and loaded and the EW-7811UTC started up and connected to my network straight away. So I had the built in wifi and 8812au wifi both connected to my 5GHz wifi.

Rebooted the Pi again and the Pi started with both wifi modules connecting to my network.

I have had the odd problem when wifi drivers start up but the wifi will not connect, often when moving an SD card from one Pi to another. This could be down to the fact that a wifi module has a lease file defined by the original Pi it was in and it causes a problem if trying to connect with a different lease when in the new Pi. Deleating the lease files and rebooting can fix the issue. Other times instead of rebooting first power off the pi and then power it up again and that could fix the issue. And other times changing the USB port a wifi module is connected to has fixed the problem. All rather odd issues and no obvious answer to why they occurred.

You could perhaps power off the Pi and remove the wifi dongle and power the Pi back up and then reconnect the wifi to the Pi and see what happens. Wifi issues could be caused by insufficient power which has most effect when the Pi is starting up after powering on. This can stop a wifi connecting.



MrEngman
Fantastic - thanks MrEngman

I had to restart a couple of times (also removed the DVB-T) and it works now.

You're right I do need a powered USB hub, it doesn't work if I use a extension cable. It also picks up non 5Ghz networks, not as many as the internal WiFi but I think this is a power issue.

Thanks for your help :)

S

Return to “Troubleshooting”