johnernestuk
Posts: 2
Joined: Fri Oct 30, 2015 8:21 pm

Cannot get official raspberry pi 7inch screen to work by tou

Sat Oct 31, 2015 12:01 am

Had the official pi 7 inch :o touch screen for a few days. And mounted on new pimorini stand.Have updated and upgraded my pi 2 as well as rpi updated . Get display ok but unable to browse or do anything via touch screen(does not respond to touch). Have installed according to raspberry pi tv video and have checked connections many times. Have used jumpers to power interface. Any help/ solution would be appreciated.
Best Regards
John

doismellburning
Posts: 2
Joined: Sat Oct 31, 2015 2:34 pm

Re: Cannot get official raspberry pi 7inch screen to work by

Sat Oct 31, 2015 3:13 pm

You have my sympathies, but I'm glad it's not just me!

My situation sounds near identical:

* Raspberry Pi 2 B + Pimoroni frame
* Latest Raspbian (8)
* All OS packages up to date
* Firmware up to date (according to `rpi-update`)
* DSI ribbon cable appears correctly seated (contacts facing up / towards USB ports)
* Display _displays_ just fine
* Touch inputs don't seem to be detected

https://www.raspberrypi.org/documentati ... hooting.md didn't prove very enlightening

Given we both have the Pimoroni frame in common, and I've not found reports of this issue otherwise, that's likely to be my next angle of investigation (but I'm clutching at straws slightly!)

doismellburning
Posts: 2
Joined: Sat Oct 31, 2015 2:34 pm

Re: Cannot get official raspberry pi 7inch screen to work by

Sun Nov 01, 2015 7:25 pm

...and thanks to shauno from #raspberrypi pointing out that there's _two_ ribbon cables from the screen to the screen board, and the smaller of the two is the one that deals with touch (and I'd not noticed it and thus not plugged it in).

All's working fine for me now; I'm not sure how likely it is that you've made the same mistake as me, but I'd recommend making that your first point of investigation - good luck!

johnernestuk
Posts: 2
Joined: Fri Oct 30, 2015 8:21 pm

Re: Cannot get official raspberry pi 7inch screen to work by

Tue Nov 03, 2015 8:32 pm

Thank you for your help. Having looked at the small ribbon connection again it appears as though it has broke within the connector and the plastic catch that holds it in is also broke. Not sure when this happened or if it was fitting the stand . I have contacted Pi hut and hope that they can help me out.
Thanks again. Another learning curve for this senior citizen !
Best Regards
John

Return to “Official Foundation Display”