Page 1 of 1

Faint Display

Posted: Tue Sep 29, 2015 9:00 am
by xXAzazelXx
Hey Guys,

Just received my new official display and at first I thought it was dead on arrival but after carefully looking in to it its actually very faint.

I have tried:
[*]different USB cables
[*]different USB charges (tried apple ones too which usually power my pi with no issues)
[*]tried powering from PIN 1/3
[*]tried RaspberryPI B,B+,2
[*]watched all sorts of YouTube videos and wiggles cables around.

As far as i can tell there is no brightness button anywhere. Rapsbian is up to date but the issue occurs during boot process so i doubt its software.

Please dont tell me i somehow fried something or that its faulty :cry: :cry: :cry: :cry: :cry: :cry:

Re: Faint Display

Posted: Tue Sep 29, 2015 9:08 am
by BMS Doug
xXAzazelXx wrote:Hey Guys,

Just received my new official display and at first I thought it was dead on arrival but after carefully looking in to it its actually very faint.

I have tried:
[*]different USB cables
[*]different USB charges (tried apple ones too which usually power my pi with no issues)
[*]tried powering from PIN 1/3
[*]tried RaspberryPI B,B+,2
[*]watched all sorts of YouTube videos and wiggles cables around.

As far as i can tell there is no brightness button anywhere. Rapsbian is up to date but the issue occurs during boot process so i doubt its software.

Please dont tell me i somehow fried something or that its faulty :cry: :cry: :cry: :cry: :cry: :cry:
Did you try disconnecting & reconnecting the ribbon cables between the screen and the interface board?

Re: Faint Display

Posted: Tue Sep 29, 2015 10:05 am
by xXAzazelXx
yep, sure have :(

Image
Image
Image
Image
Image
Image

Re: Faint Display

Posted: Fri Oct 09, 2015 2:08 pm
by solar3000
xXAzazelXx wrote:Hey Guys,

Just received my new official display and at first I thought it was dead on arrival but after carefully looking in to it its actually very faint.

I have tried:
[*]different USB cables
[*]different USB charges (tried apple ones too which usually power my pi with no issues)
[*]tried powering from PIN 1/3
[*]tried RaspberryPI B,B+,2
[*]watched all sorts of YouTube videos and wiggles cables around.

As far as i can tell there is no brightness button anywhere. Rapsbian is up to date but the issue occurs during boot process so i doubt its software.

Please dont tell me i somehow fried something or that its faulty :cry: :cry: :cry: :cry: :cry: :cry:


I'm more interested in how you're watching all sorts of youtube videos.

Re: Faint Display

Posted: Sat Oct 10, 2015 10:12 pm
by xXAzazelXx
lol on my computer of course :)
Looks like it was faulty display, it was tested by the place i bought it from and they are sending me another one.