doczoidberg
Posts: 2
Joined: Fri Sep 25, 2015 9:09 am

Touch problems with the official RPi display

Fri Sep 25, 2015 9:20 am

I put all the parts together like in the instructions.
Installed latest Raspian and updated & upgraded.

Everything works fine.

But after maybe 30 sec or a minute, the arrow starts hopping up and down (maybe a cm) in the lower middle of the screen.
I cant really use other devices while this happens. (Mouse or keyboard with touchpanel)

I tried to reinstall the system, checked the cabels and tried different versions of she power supply.
Nothing helped.

Does someone have any solution or help?

fruitoftheloom
Posts: 20680
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Touch problems with the official RPi display

Fri Sep 25, 2015 9:44 am

doczoidberg wrote:I put all the parts together like in the instructions.
Installed latest Raspian and updated & upgraded.

Everything works fine.

But after maybe 30 sec or a minute, the arrow starts hopping up and down (maybe a cm) in the lower middle of the screen.
I cant really use other devices while this happens. (Mouse or keyboard with touchpanel)

I tried to reinstall the system, checked the cabels and tried different versions of she power supply.
Nothing helped.

Does someone have any solution or help?
viewtopic.php?f=108&t=121576
Retired disgracefully.....

User avatar
PeterO
Posts: 5001
Joined: Sun Jul 22, 2012 4:14 pm

Re: Touch problems with the official RPi display

Fri Sep 25, 2015 11:23 am

fruitoftheloom wrote:
doczoidberg wrote:I put all the parts together like in the instructions.
Installed latest Raspian and updated & upgraded.

Everything works fine.

But after maybe 30 sec or a minute, the arrow starts hopping up and down (maybe a cm) in the lower middle of the screen.
I cant really use other devices while this happens. (Mouse or keyboard with touchpanel)

I tried to reinstall the system, checked the cabels and tried different versions of she power supply.
Nothing helped.

Does someone have any solution or help?
viewtopic.php?f=108&t=121576
New firmware fixes the touch screen becoming unresponsive which does not sound like the symptoms described here.
I would be double checking that the smaller of the two cables onto the display driver board is fully inserted into its socket.

PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

doczoidberg
Posts: 2
Joined: Fri Sep 25, 2015 9:09 am

Re: Touch problems with the official RPi display

Sun Sep 27, 2015 3:31 pm

I checked the small cable more than one time.

If it is the cable, wouldn't the problem be there immedeatly?
Not after maybe a minute.

If its the cable why is it working for at least 30 secs?


You know what I mean

Return to “Official Foundation Display”