Page 1 of 1

Problems with I2C Accelerometer Project

Posted: Thu Jun 25, 2015 8:05 pm
by FabianBueren
Dear all,

i was trying to do the following project:

https://microsoft.hackster.io/en-US/win ... ter-sample

I set up my Raspberry Pi and made the hardware settings.

I installed MS Visual Studio 2015 and tried to open the accelerometer.csproj file. But MS Visual Studio gives me the following error:

"Accelerometer.csproj: Error on line 4. Expected 'SYSTEM or PUBLIC' but found '>'."

Can you please help me and tell me how to open the file. I am totally new to the programming with MS Visual Studio.

The files can be found here:

https://github.com/ms-iot/samples/tree/ ... rometer/CS

Thank you very much for your help

Greetings

Fabian

Re: Problems with I2C Accelerometer Project

Posted: Thu Jun 25, 2015 9:17 pm
by markrad_msft
If you followed all the instructions on this page http://ms-iot.github.io/content/en-US/win10/SetupPC.htm then I see no reason why it would not work for you unless the project file is corrupt. I downloaded for myself and did not see an issue either opening or building the Accelerometer project.
Please make sure you following all the steps in the webpage indicated above. If you still can't open the project then I suggest you download it again.

Re: Problems with I2C Accelerometer Project

Posted: Fri Jun 26, 2015 9:57 pm
by FabianBueren
Dear Mark,

thank you very much for your quick reply. Is there any chance to use Windows 7 for programming APPs for a Raspberry running Windows 10 Iot.

Greetings

Fabian

Re: Problems with I2C Accelerometer Project

Posted: Mon Jun 29, 2015 10:22 pm
by markrad_msft
There have been some community hacks to enable app development for Windows 10 IoT but it is not a platform that is officially supported by Microsoft. Windows 8.1 is the minimum and even then you may find that certain things don't work as expected. Running Windows 10 in a virtual machine is a common method to circumvent this restriction.