tjtrolinger
Posts: 4
Joined: Fri May 22, 2015 3:20 pm

Mouse and keyboard issue

Fri May 22, 2015 3:24 pm

I cant get the mouse or the keyboard to work with the latest Win10 IOT Core.
The release notes say it can be a power issue and suggest using a powered USB hub, but that doesn't work either.
I have also tried plugging them in one at a time before and after boot without success.
The mouse and keyboard work just fine with all other operating systems I use with the Pi2.
Anyone found a solution to this issue?
Thanks,
TJ

jtanner_msft
Posts: 105
Joined: Fri May 01, 2015 7:12 pm

Re: Mouse and keyboard issue

Fri May 22, 2015 5:23 pm

The only other suggestion I can offer is to try different brands of mice / keyboards.
Jonathan Tanner | Microsoft | Windows 10 IoT Core Insider Preview Support | This posting is provided 'as is' with no warranties and confers no rights.

tjtrolinger
Posts: 4
Joined: Fri May 22, 2015 3:20 pm

Re: Mouse and keyboard issue

Fri May 22, 2015 5:31 pm

Thanks for the reply.
I have tried all three mice and three keyboards I have including one Microsoft mouse and keyboard.
One would think that at least the Microsoft products with work with it.......
TJ

GerritV
Posts: 91
Joined: Fri May 01, 2015 4:16 pm
Location: St Catharines, ON
Contact: Website

Re: Mouse and keyboard issue

Fri May 22, 2015 11:09 pm

There is a utility called devcon.exe on WinIoT. It can provide a lot of detail about peripherals, what drivers the are using etc.

Log in with powershell, devcon.exe help lists the commands, devcon help <command> gives details of <command>

tjtrolinger
Posts: 4
Joined: Fri May 22, 2015 3:20 pm

Re: Mouse and keyboard issue

Sat May 23, 2015 3:14 am

Thanks for the info.
Restarting the "HID" drivers using Devcon made the keyboard start working, but not the mouse.
Devcon says the mouse driver is loaded and working when I plug in the mouse. Every once in a while I see a pointer show up on the screen temporarily but it never moves with the mouse.
TJ

deandob
Posts: 12
Joined: Thu Aug 15, 2013 10:44 am

Re: Mouse and keyboard issue

Sat May 23, 2015 10:20 pm

I have a similar issue - sometimes the keyboard works but not all keys and very occasionally the mouse cursor pops up but disappears when the mouse is moved. Tried a number of things (powered hub, different devices) and it works fine on Linux NOOBs. I have put it down to bugs in the current beta version, will wait until the next Windows IoT build is available before looking at it again.

Do log your issue at the Microsoft connect site, if enough people register this bug then the dev team will look into it. There is already a bug logged for a similar issue, vote it up and put a comment about your problem.
https://connect.microsoft.com/windowsem ... T/Feedback

tjtrolinger
Posts: 4
Joined: Fri May 22, 2015 3:20 pm

Re: Mouse and keyboard issue

Sat May 23, 2015 10:54 pm

Thanks deandob, just added a comment there.
TJ

Return to “Windows 10 for IoT”