rooflz
Posts: 5
Joined: Tue May 12, 2015 3:02 am

Z-Stick S2 Drivers

Tue May 12, 2015 3:13 am

I was at the Build conference and received the AEOTEC Z-Stick S2 along with a smart switch. My main goal is just to create a simple application that can turn the switch on and off. I'm trying to follow the 'Build2015_AllJoyn_ZWave_Setup_Guide_v1.0' document however under prerequisites it states that I need a Raspberry Pi2 with the //Build/2015 image. I loaded the latest insider build however when I plug in my z-stick and check the Rasperry Pi device manager via the web I do not see it listed.

Anyone know where I can find this //Build/2015 image? Or where I can find drivers the following drivers?

Aeon Labs DSA02203-ZWUS Z-Wave Z-Stick Series 2 USB Dongle
Aeon Labs DSC24-ZWUS Smart Switch Z-Wave Appliance Module

Thanks for any help that can be provided.

jtanner_msft
Posts: 105
Joined: Fri May 01, 2015 7:12 pm

Re: Z-Stick S2 Drivers

Tue May 12, 2015 7:40 pm

The most recent build for Rpi2 was released on 4/29, and that should match the version which was used in the labs at //Build 2015:
https://connect.microsoft.com/windowsem ... adID=57782

I hope that helps.
Jonathan Tanner | Microsoft | Windows 10 IoT Core Insider Preview Support | This posting is provided 'as is' with no warranties and confers no rights.

rooflz
Posts: 5
Joined: Tue May 12, 2015 3:02 am

Re: Z-Stick S2 Drivers

Thu May 14, 2015 1:46 am

Thanks Jonathan. For some reason I the Z-Stick is not being recognized. I just updated my Rpi2 to the latest Windows 10 IoT Core build (5/12), however still no luck. After plugging in the usb Z-Stick the light illuminates. I check the web interface however I do not see it listed, Should I? The Windows IoT Core Watcher can access my Rpi2 and I changed the firewall settings according to the documentation. When I bring up AllJoyn Explorer it cannot find any devices. Anything special I can do to debug this?

Thanks again for any help.

jtanner_msft
Posts: 105
Joined: Fri May 01, 2015 7:12 pm

Re: Z-Stick S2 Drivers

Thu May 14, 2015 6:54 pm

I've heard that sometimes the Rpi2 has issues providing enough power to its USB ports. Can you maybe try using a powered USB hub with the device?
Jonathan Tanner | Microsoft | Windows 10 IoT Core Insider Preview Support | This posting is provided 'as is' with no warranties and confers no rights.

rooflz
Posts: 5
Joined: Tue May 12, 2015 3:02 am

Re: Z-Stick S2 Drivers

Sat May 16, 2015 12:54 am

Tried with a self powered usb hub but the results were the same. Any other ideas? Is there any sort of logging that can be enabled to provide more information?

rooflz
Posts: 5
Joined: Tue May 12, 2015 3:02 am

Re: Z-Stick S2 Drivers

Wed May 27, 2015 3:45 pm

FYI the ZWaveBackgroundService was not running. Once I built and deployed this all devices now show up in AllJoyn Explorer.

Return to “Windows 10 for IoT”