Page 1 of 1

How do I get HDMI/DVI-D to work?

Posted: Fri May 01, 2015 8:17 pm
by DougieLawson
My RPi2 normally runs with my Philips V-Line 196V4LAB2 18.5" DVI-D monitor which is 1366 x 768 Pixels and runs in hdmi_group=2, hdmi_mode=86. Raspbian handles that with no troubles and it automagically picks an ideal mode.

To get anything other than scrambled fuzziness with Win10 IoT I've currently coded hdmi_group=2, hdmi_mode=4 (I found a config.txt on /dev/sda1 when I mounted my IoT SDCard on another RPi) but now the main screen is truncated so only the top left of the screen shows.

What's the minimum size needed to get the full picture on the screen? Because I'm going to need to reboot Raspbian to see what other modes are possible with my DVI-D monitor. (I've had the same problem with FreeBSD when I tried that.)

Re: How do I get HDMI/DVI-D to work?

Posted: Fri May 01, 2015 9:17 pm
by pranishk
Hi,

We've seen issues with some monitors in the current release, but I'm not sure what's happening here - usually hdmi_group=2 fixes the issue. Have you checked your other configuration settings?
viewtopic.php?t=5851

Pranish Kumar (pranishk@microsoft.com)
Microsoft Corporation

Re: How do I get HDMI/DVI-D to work?

Posted: Fri May 01, 2015 9:22 pm
by DougieLawson
I'll try hdmi_group=2 without anything for hdmi_mode and see what happens.

If that doesn't work I'm planning on setting hdmi_mode=81 for a test (that's what Raspbian chooses) and if that doesn't work I'll resort to hdmi_mode=18 (which I'm testing now with Raspbian).

If I can find where this stuff is done on FreeBSD I may be able to solve two problems in one go.

Re: How do I get HDMI/DVI-D to work?

Posted: Sat May 02, 2015 6:36 am
by Robpol86
If you're still stuck you can probably just set the display resolution manually with "hdmi_cvt=width height 60" and "hdmi_mode=87".

I got that from https://www.raspberrypi.org/documentati ... fig-txt.md

Re: How do I get HDMI/DVI-D to work?

Posted: Sat May 02, 2015 10:15 am
by DougieLawson
I've now got

Code: Select all

hdmi_group=2
hdmi_mode=16
and a screen full of goodness. I could find the settings icon so it's also been moved into the GMT/BST time zone.

Onwards and upwards, next step winking an LED.