User avatar
Robpol86
Posts: 18
Joined: Wed Jul 18, 2012 7:29 pm
Location: San Francisco, CA
Contact: Website

Raspberry Pi on an Atrix Lapdock

Fri May 01, 2015 2:40 am

Headed mode doesn't seem to be very feasible on my Atrix Lapdock :(

Image

I managed to get the IP from my router and configured it from my Win10 VM, and issuing "SetDisplayResolution 1366 768" doesn't seem to help. This is the first release so I'm looking forward optimistically for somebody out there in Redmond to tweak things a bit one day :) . This is still pretty cool!

Mostly posting this as a heads up, there aren't very many threads here yet and none of the others seemed like a good fit.

jtanner_msft
Posts: 105
Joined: Fri May 01, 2015 7:12 pm

Re: Raspberry Pi on an Atrix Lapdock

Fri May 01, 2015 10:43 pm

Hello,
I'm sorry but I don't quite follow how you are trying to use the Atrix Lapdock. Is it as a display with a Rpi2 board running Windows 10 IoT Core?

Or are you just trying to get a build of Windows 10 Technical Preview running on that device and having display issues?

There were some display issues with the Rpi2 that you might double check:

My display doesn't look right, the screen appears cropped or stretched

This can happen on some monitors. To work around this force the board into DVI mode (vs. HDMI mode). You can read more about this here. Mount the SD card to a local PC and proceed to edit the file in the EFIESP partition. For example if the partition is mark as H drive, edit H:\config.txt by adding the following line.

hdmi_group=2 # forces DVI timing to be used
Jonathan Tanner | Microsoft | Windows 10 IoT Core Insider Preview Support | This posting is provided 'as is' with no warranties and confers no rights.

User avatar
Robpol86
Posts: 18
Joined: Wed Jul 18, 2012 7:29 pm
Location: San Francisco, CA
Contact: Website

Re: Raspberry Pi on an Atrix Lapdock

Fri May 01, 2015 10:55 pm

Ooooh cool. I'll definitely try that out tonight. I think that might fix it.

Yep it is as you described: just an HDMI display/keyboard/mouse for my RPi2 running Win10 IoT.

Edit: Unfortunately that didn't work. The initial rainbow square shows up (same one displayed on other OSes for the RPi) but after that everything is skewed.

User avatar
Robpol86
Posts: 18
Joined: Wed Jul 18, 2012 7:29 pm
Location: San Francisco, CA
Contact: Website

Re: Raspberry Pi on an Atrix Lapdock

Sat May 02, 2015 6:25 am

Ok so I figured it out. I had to set these settings in my config.txt after referencing the documentation:

Code: Select all

hdmi_group=2
hdmi_cvt=1366 768 60
hdmi_mode=87
That manually sets the resolution using the pseudo hdmi mode 87 (one above the last valid number).

Image

Return to “Windows 10 for IoT”