Posts: 1
Joined: Sun Jan 28, 2018 6:11 pm

Using an RPLidar a2 with Raspberry Pi

Sun Jan 28, 2018 6:21 pm

I am trying to run a Lidar sensor on my pi and it won't function at all. It is connected via UART to USB and is plugged into one of the USB ports. I swapped the serial ports on it because that is what most answers said to do when I looked it up. I am using exagear and wine to run the ultra_simple.exe that came with the lidar that ran perfectly on my windows laptop. I go into the correct folder and what not, but when I run 'wine ultra_simple serial0' I get nothing from the sensor. I don't exactly know what port to use in order to get a valid response. I am not sure if this helps but I also get the error 'fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub'. Anything should help, but I think it's just an issue of what port I am using on the Pi. I use the COM4 port on my computer when I run it there. Anything helps, thanks in advance. ( Sorry for not using the code tags, I am not sure how to use them)

Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Using an RPLidar a2 with Raspberry Pi

Mon Jan 29, 2018 1:33 pm

Don't know which unit you are using. Is it this one? ... heet-1.pdf

It shows it sends data at115200-8-N-1. Do this before plugging in the unit, then do it again after plugging it in. You should see a new device. It will probably be something like ttyUSB0 or ttyAMA0.

Code: Select all

cd /dev
ls -l
I don't use this unit, but it looks pretty straightforward. It appears by the datasheet that it sets bit7 on the start byte, and all other bytes have bit7 clear.

Edit: My bad it is an A2. Same protocol though. 115200-8-N-1. ... 1.0_en.pdf

Return to “Assistive technology and accessibility”