Go to advanced search

by przemof
Thu Aug 02, 2018 9:26 pm
Forum: Raspbian
Topic: B3+ no wif
Replies: 13
Views: 945

Re: B3+ no wif

OK, thank you! I'll try a fresh install on another card. If that doesn't work it means I have a faulty hardware.
by przemof
Thu Aug 02, 2018 6:02 pm
Forum: Raspbian
Topic: B3+ no wif
Replies: 13
Views: 945

Re: B3+ no wif

Thanks!
Localisation fo wifi set, but rfkill shows only bluetooth:

Code: Select all

pi@raspberrypi:~ $ rfkill list
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
Can someone confirm that wifi on B3+ actually works with the latest raspbian + latest firmware?
by przemof
Thu Aug 02, 2018 3:04 pm
Forum: Raspbian
Topic: B3+ no wif
Replies: 13
Views: 945

Re: B3+ no wif

raspbian stretch doesn't work either. The graphical tool to set county code doesn't work (no error, just nothing is set). I added country to wpa_supplicant.conf -with nano, but no change. I might need to ask the seller for a replacement :-/ Edit: That's from fresh installation of raspbian stretch: p...
by przemof
Thu Aug 02, 2018 1:27 pm
Forum: Raspbian
Topic: B3+ no wif
Replies: 13
Views: 945

Re: B3+ no wif

Thanks! I'm writing new image right now. If it works I'll do the upgrade. The dmesg part suggests that it's the kernel level problem, so running newer release might fix it.
by przemof
Thu Aug 02, 2018 12:29 pm
Forum: Raspbian
Topic: B3+ no wif
Replies: 13
Views: 945

Re: B3+ no wif

lshw shows no wifi: pi@raspberrypi:~ $ sudo lshw -short H/W path Device Class Description ======================================================= system Raspberry Pi 3 Model B Plus Rev 1.3 /0 bus Motherboard /0/0 processor cpu /0/1 processor cpu /0/2 processor cpu /0/3 processor cpu /0/4 memory 927M...
by przemof
Thu Aug 02, 2018 10:35 am
Forum: Raspbian
Topic: B3+ no wif
Replies: 13
Views: 945

B3+ no wif

I just upgraded from B3 to B3+. I didn't use wifi before, but now I want the 5GHz wifi connection. Raspbian updated, firmware updated: pi@raspberrypi:~ $ sudo apt-get update Hit http://mirrordirector.raspbian.org jessie InRelease Hit http://archive.raspberrypi.org jessie InRelease Hit http://mirrord...
by przemof
Wed Apr 19, 2017 11:06 am
Forum: General discussion
Topic: Pi Zero W - wireless and bluetooth (BLE)
Replies: 5
Views: 4667

Re: Pi Zero W - wireless and bluetooth (BLE)

To get fully working touchscreen add: dtoverlay=pitft28-capacitive,rotate=90,speed=32000000 to //boot/config.txt and paste: -65536 0 15728640 -320 -65536 20971520 65536 to /etc/pointercal Details of the "magic" numbers here: http://blog.firszt.eu/index.php?post/2014/10/15/PiTFT-capacitive-calibratio...
by przemof
Sat Apr 01, 2017 7:51 am
Forum: General discussion
Topic: Pi Zero W - wireless and bluetooth (BLE)
Replies: 5
Views: 4667

[SOLVED] Pi Zero W - wireless and bluetooth (BLE)

Modifications required in /boot/config.txt 1. Uncomment dtparam=spi=on 2. Add dtoverlay=pitft28-capacitive,rotate=90,speed=32000000,fps=20 Modifications required in /boot/cmdline.txt 1. Add after rootwait (the end of line) fbcon=map:10 fbcon=font:VGA8x8 logo.nologo That's it! No other modifications ...
by przemof
Wed Mar 22, 2017 7:21 pm
Forum: General discussion
Topic: Pi Zero W - wireless and bluetooth (BLE)
Replies: 5
Views: 4667

Re: Pi Zero W - wireless and bluetooth (BLE)

Looks like installing adafruit kernel to handle PiTFT display kills wifi and bluetooth on RPI Zero W.
by przemof
Sun Mar 12, 2017 5:48 pm
Forum: General discussion
Topic: Pi Zero W - wireless and bluetooth (BLE)
Replies: 5
Views: 4667

Pi Zero W - wireless and bluetooth (BLE)

I'm trying to replace PI A+ with Pi Zero W on an embedded project. I have a raspbian installation that works fine with A+ with an usb wifi dongle. Do i need to make any configuration changes (load modules, change wpa_supplicant config or network config) to make wifi work on Pi Zero W? External USB w...
by przemof
Sat Mar 04, 2017 11:19 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: BLE (Bluetooth Low Energy) on low voltage (3.7V) rpi A+
Replies: 8
Views: 1339

Re: BLE (Bluetooth Low Energy) on low voltage (3.7V) rpi A+

Judging by the CYP43438 datasheet , it appears we may have usable bluetooth on the Zero W when supplied directly from a LiPo :D Just to have all info in one place.. If direct PS from Lipo doesn't work pimoroni Lipo supply should solve the problem: https://shop.pimoroni.com/products/zero-lipo P.S. I...
by przemof
Mon Feb 27, 2017 1:44 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: BLE (Bluetooth Low Energy) on low voltage (3.7V) rpi A+
Replies: 8
Views: 1339

Re: BLE (Bluetooth Low Energy) on low voltage (3.7V) rpi A+

I'll have 2 dongles, so I might try to open one to see if there is an internal voltage regulator that we could by-pass.
by przemof
Mon Feb 27, 2017 12:03 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: BLE (Bluetooth Low Energy) on low voltage (3.7V) rpi A+
Replies: 8
Views: 1339

Re: BLE (Bluetooth Low Energy) on low voltage (3.7V) rpi A+

Can you post lsusb results? i have the same dongle - at least that's what is says on the tin.

P.S. Another ble dongle + a voltage step-up are on the way, so I'll update the info later.
by przemof
Fri Feb 24, 2017 6:49 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: BLE (Bluetooth Low Energy) on low voltage (3.7V) rpi A+
Replies: 8
Views: 1339

Re: BLE (Bluetooth Low Energy) on low voltage (3.7V) rpi A+

Anyone tried to use a step up 3.7V->5V module for USB port only?
by przemof
Sun Feb 19, 2017 9:06 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: BLE (Bluetooth Low Energy) on low voltage (3.7V) rpi A+
Replies: 8
Views: 1339

BLE (Bluetooth Low Energy) on low voltage (3.7V) rpi A+

I'm looking for a solution that allows to connect RPI A+ to BLE devices. The problem is that RPI A+ is powered from a 3.7V LiPo battery - everything (I2C sensors, PiTFT screen, serial gps, wifi usb dongle) works fine. Everything except BLE usb dongle...
by przemof
Tue Feb 07, 2017 10:04 pm
Forum: Other projects
Topic: ON/OFF Power Controller
Replies: 3
Views: 1506

Re: ON/OFF Power Controller

Thanks! Looks very interesting, but I need something smaller and I already have a lipo battery and a charging module. Also a Coulomb counter with low battery warning is on the way.
by przemof
Tue Feb 07, 2017 9:23 pm
Forum: Other projects
Topic: ON/OFF Power Controller
Replies: 3
Views: 1506

ON/OFF Power Controller

Anyone know where to buy on/of power controller for RPI with similar functionality like this [1]? I need something small for an embedded project (cycling computer). There doesn't seem to be anything on the internet except Pi Supply Switch with mixed reviews and "out of stock" status :-/ [1] http://w...
by przemof
Wed Mar 09, 2016 10:00 pm
Forum: Polski
Topic: VLC
Replies: 2
Views: 3343

Re: VLC

A VLC lokalnie działa bez prolemu?
Masz uruchomione Xy czy wszystko z konsoli?
Nie wiem czy omxplayer jest w stanie to odtworzyć, ale warto spróbować.
by przemof
Mon Oct 26, 2015 10:26 pm
Forum: C/C++
Topic: Starting programming on Raspbian
Replies: 2
Views: 1849

Re: Starting programming on Raspbian

by przemof
Sat Oct 03, 2015 10:12 pm
Forum: Beginners
Topic: how often to reboot pi 2? every time an upgrade is applied?
Replies: 8
Views: 1235

Re: how often to reboot pi 2? every time an upgrade is appli

I had a uptime of +250 days on the old model B with raspbian - there is no need to reboot unless you want to update the kernel.
by przemof
Thu Oct 01, 2015 6:53 pm
Forum: Raspbian
Topic: [SOLVED] Model B 256Mb to model 2 B migration
Replies: 2
Views: 453

Re: Model B 256Mb to model 2 B migration

I was fairly sure I did it, but to be 100% sure I've just done it again. No luck - the same error. Edit: 1. Download an up to date raspbian image 2. Unpack & mount 3. Copy content of /boot to the sd card Looks like for some reason apt-get was not updating the boot files. I don't know if this is an e...
by przemof
Thu Oct 01, 2015 2:21 pm
Forum: Raspbian
Topic: [SOLVED] Model B 256Mb to model 2 B migration
Replies: 2
Views: 453

[SOLVED] Model B 256Mb to model 2 B migration

How can I migrate raspbian from old model B 256Mb to model 2 B? After copyting the image to a new card the system starts, but crashes with this error (image) http://snag.gy/Krr7N.jpg It's a TV-screenshot, but should be readable. Edit: I think I got the answer, but it needs to be tested: https://www....
by przemof
Mon Mar 30, 2015 11:36 am
Forum: Python
Topic: Setting up Vim for Python
Replies: 4
Views: 2615

Re: Setting up Vim for Python

I'd also recommend Syntastic [1] and flake8 [2] for vim

[1] https://github.com/scrooloose/syntastic
[2] https://github.com/PyCQA/flake8
by przemof
Thu Mar 19, 2015 5:20 pm
Forum: Python
Topic: Bug issue
Replies: 3
Views: 709

Re: Bug issue

The whole program is: GPIO.cleanup() file.close() The rest including code after '#Main program loop' is part of the subroutine - that's why you're getting the error. BTW I have a discussion in another thread about using 2 vs 4 vs 8 spaces as indent. Use 8 - you'd see the problem straight away. Fixed...

Go to advanced search